aboutsummaryrefslogtreecommitdiff
path: root/irc/kvirc-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/kvirc-devel/Makefile')
-rw-r--r--irc/kvirc-devel/Makefile68
1 files changed, 0 insertions, 68 deletions
diff --git a/irc/kvirc-devel/Makefile b/irc/kvirc-devel/Makefile
deleted file mode 100644
index 31ad65bbe596..000000000000
--- a/irc/kvirc-devel/Makefile
+++ /dev/null
@@ -1,68 +0,0 @@
-# New ports collection makefile for: kvirc
-# Date created: 05 January 2004
-# Whom: Michael Ranner
-#
-# $FreeBSD$
-#
-
-PORTNAME= kvirc
-PORTVERSION= 3.0.1
-PORTREVISION= 2
-CATEGORIES= irc kde
-MASTER_SITES= ftp://ftp.kvirc.net/pub/%SUBDIR%/ \
- ftp://ftp.kvirc.de/pub/%SUBDIR%/ \
- ftp://mirror.dudcore.net/pub/%SUBDIR%/ \
- ftp://ftp.kvirc.pragmaware.net/pub/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}/source
-
-MAINTAINER= mranner@inode.at
-COMMENT= IRC client for QT and KDE
-
-GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
-USE_BZIP2= yes
-USE_KDELIBS_VER=3
-USE_GMAKE= yes
-USE_REINPLACE= yes
-USE_INC_LIBTOOL_VER= 15
-CONFIGURE_TARGET=
-CONFIGURE_ARGS+= --mandir=${PREFIX}/man/man1
-PLIST_SUB= VER=${PORTVERSION}
-
-MAN1= kvirc.1
-
-OPTIONS= ARTS "Compile with arts support" on \
- AUDIOFILE "Compile with libaudiofile support" on \
- ESOUND "Compile with esound support" off \
- GSM "Compile with gsm support" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_ARTS)
-LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
-.else
-CONFIGURE_ARGS+= --without-arts-support
-.endif
-
-.if defined(WITH_AUDIOFILE)
-LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
-.else
-CONFIGURE_ARGS+= --without-af-support
-.endif
-
-.if defined(WITH_ESOUND)
-LIB_DEPENDS+= esd.2:${PORTSDIR}/audio/esound
-.else
-CONFIGURE_ARGS+= --without-esd-support
-.endif
-
-.if defined(WITH_GSM)
-LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
-.else
-CONFIGURE_ARGS+= --without-gsm
-.endif
-
-post-patch:
- ${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
-
-.include <bsd.port.post.mk>