aboutsummaryrefslogtreecommitdiff
path: root/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile')
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
index 4efd536e0539..dac534df5930 100644
--- a/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
@@ -17,16 +17,18 @@ BUILD_DEPENDS= p5-Math-Random>=0.69:${PORTSDIR}/math/p5-Math-Random \
RUN_DEPENDS:= ${BUILD_DEPENDS}
PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= configure
-MAN3= POE::Component::IRC::Plugin::POE::Knee.3
+OPTIONS_DEFINE= EXAMPLES
+
+PORTEXAMPLES= *
+SHEBANG_FILES= examples/*.pl
+
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-install:
-.ifndef(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>