aboutsummaryrefslogtreecommitdiff
path: root/irc/svrx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/svrx/Makefile')
-rw-r--r--irc/svrx/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/irc/svrx/Makefile b/irc/svrx/Makefile
new file mode 100644
index 000000000000..b2983273c3ba
--- /dev/null
+++ b/irc/svrx/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: srvx
+# Date created: 2003-11-28
+# Whom: Walter Venable <weaseal@hotmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= srvx
+PORTVERSION= 1.2
+CATEGORIES= irc net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= srvx
+
+MAINTAINER= weaseal@hotmail.com
+COMMENT= Srvx IRC services
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+.if defined(WITH_PROTOCOL_BAHAMUT)
+CONFIGURE_ARGS+= --with-protocol=bahamut
+.endif
+
+.include <bsd.port.pre.mk>
+
+pre-fetch:
+ @ ${ECHO} ""
+ @ ${ECHO} "--------------------------------------------------------------------------------"
+ @ ${ECHO} ""
+ @ ${ECHO} "The following build options are availabe:"
+ @ ${ECHO} ""
+ @ ${ECHO} " WITH_PROTOCOL_BAHAMUT=yes Enables Bahamut protocol"
+ @ ${ECHO} " (P10 is default)."
+ @ ${ECHO} ""
+ @ ${ECHO} " WITH_DEBUG=yes Enables debug mode."
+ @ ${ECHO} ""
+ @ ${ECHO} "--------------------------------------------------------------------------------"
+ @ ${ECHO} ""
+
+post-install:
+ @ ${ECHO} ""
+ @ ${ECHO} " When you 'make deinstall', any files generated by ${PORTNAME} (logs, etc)"
+ @ ${ECHO} " will remain in ${PREFIX}/etc/. These files must be removed"
+ @ ${ECHO} " manually."
+ @ ${ECHO} ""
+ @ ${ECHO} " ${PORTNAME} .help files are located in ${DOCSDIR}."
+ @ ${ECHO} ""
+
+.include <bsd.port.post.mk>