aboutsummaryrefslogtreecommitdiff
path: root/irc/weechat-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/weechat-devel/Makefile')
-rw-r--r--irc/weechat-devel/Makefile32
1 files changed, 25 insertions, 7 deletions
diff --git a/irc/weechat-devel/Makefile b/irc/weechat-devel/Makefile
index 1b21c4261e8f..9da79c7a2a39 100644
--- a/irc/weechat-devel/Makefile
+++ b/irc/weechat-devel/Makefile
@@ -6,9 +6,11 @@
#
PORTNAME= weechat
-PORTVERSION= 20120707
+PORTVERSION= 20120808
CATEGORIES= irc
-MASTER_SITES= http://perturb.me.uk/distfiles/
+MASTER_SITES= http://perturb.me.uk/distfiles/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= jase
PKGNAMESUFFIX= -devel
DISTNAME= weechat-devel-${GITREV}
@@ -22,22 +24,20 @@ CONFLICTS= weechat-0.3*
USE_ICONV= yes
USE_LDCONFIG= yes
USE_NCURSES= yes
-WITH_NCURSES_PORT= yes
USE_CMAKE= yes
-CMAKE_ARGS+= -DNCURSES_INCLUDE_PATH=${LOCALBASE}/include/ncurses
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
WANT_PERL= yes
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
-GITREV= 92aa9bf
+GITREV= 3c615a9
WRKSRC= ${WRKDIR}/${PORTNAME}-${GITREV}
# Please note: the DEBUG option is *NOT* empty, it is utilised by
# bsd.cmake.mk to set the cmake build type to Debug instead of
# Release.
-OPTIONS_DEFINE= RUBY PYTHON PERL TCL LUA GUILE CHARSET BACKTRACE DEBUG ASPELL GNUTLS NLS DOCUMENTATION SASL
+OPTIONS_DEFINE= RUBY PYTHON PERL TCL LUA GUILE CHARSET BACKTRACE DEBUG ASPELL GNUTLS NLS DOCUMENTATION SASL COLOR256
OPTIONS_DEFAULT=CHARSET BACKTRACE DEBUG
BACKTRACE_DESC= Provide crash backtraces
@@ -49,6 +49,8 @@ PERL_DESC= Perl scripting support
PYTHON_DESC= Python scripting support
RUBY_DESC= Ruby scripting support
TCL_DESC= Tcl scripting support
+SASL_DESC= SASL with DH-Blowfish support
+COLOR256_DESC= Use ncurses port for 256 color support
.include <bsd.port.options.mk>
@@ -157,10 +159,15 @@ LIB_DEPENDS+= execinfo:${PORTSDIR}/devel/libexecinfo
LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt
PLIST_SUB+= SASL=""
.else
-CMAKE_ARGS+= -DENABLE_SASL=no
+CMAKE_ARGS+= -DENABLE_GCRYPT=no
PLIST_SUB+= SASL="@comment "
.endif
+.if ${PORT_OPTIONS:MCOLOR256}
+WITH_NCURSES_PORT= yes
+CMAKE_ARGS+= -DNCURSES_INCLUDE_PATH=${LOCALBASE}/include/ncurses
+.endif
+
MAN1= weechat-curses.1
post-patch:
@@ -173,6 +180,17 @@ post-patch:
@${REINPLACE_CMD} -e '/IF.*FreeBSD/,/ENDIF.*FreeBSD/d' ${WRKSRC}/src/core/CMakeLists.txt
.endif
+pre-configure:
+.if ${PORT_OPTIONS:MCOLOR256}
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "==> You have selected the ncurses 256 color option. Please ensure that"
+ @${ECHO_MSG} "==> the devel/ncurses port is built with the EXTCOLORS option enabled."
+ @${ECHO_MSG} "==>"
+ @${ECHO_MSG} "==> Ctrl-C now if you'd like to reconfigure."
+ @${ECHO_MSG} ""
+ @sleep 5
+.endif
+
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/weechat-curses.1 ${MAN1PREFIX}/man/man1