aboutsummaryrefslogtreecommitdiff
path: root/irc/weechat-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/weechat-devel/Makefile')
-rw-r--r--irc/weechat-devel/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/irc/weechat-devel/Makefile b/irc/weechat-devel/Makefile
new file mode 100644
index 000000000000..af5688e4f26c
--- /dev/null
+++ b/irc/weechat-devel/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: weechat
+# Date created: 2003-03-07
+# Whom: clement
+#
+# $FreeBSD$
+#
+
+PORTNAME= weechat
+PORTVERSION= 0.0.5
+CATEGORIES= irc
+MASTER_SITES= http://weechat.flashtux.org/download/
+
+MAINTAINER= clement@FreeBSD.org
+COMMENT= A lightweight and user friendly ncurse based IRC client
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GETTEXT= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lintl"
+CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
+
+MAN1= weechat.1
+
+PLIST_FILES= bin/weechat-curses share/locale/fr/LC_MESSAGES/weechat.mo
+
+post-patch:
+ @${CP} ${LOCALBASE}/share/gettext/config.rpath ${WRKSRC}
+
+.include <bsd.port.mk>