aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
Diffstat (limited to 'irc')
-rw-r--r--irc/irssi/Makefile2
-rw-r--r--irc/irssi/files/patch-src-core-log.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/irc/irssi/Makefile b/irc/irssi/Makefile
index 9e21ccb1a7c6..1d81811b9211 100644
--- a/irc/irssi/Makefile
+++ b/irc/irssi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= irssi
PORTVERSION= 0.8.11
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= irc
MASTER_SITES= http://mirror.irssi.org/
diff --git a/irc/irssi/files/patch-src-core-log.c b/irc/irssi/files/patch-src-core-log.c
new file mode 100644
index 000000000000..2d97d87debaf
--- /dev/null
+++ b/irc/irssi/files/patch-src-core-log.c
@@ -0,0 +1,15 @@
+Index: src/core/log.c
+===================================================================
+--- src/core/log.c (revision 4490)
++++ src/core/log.c (revision 4491)
+@@ -299,9 +299,7 @@
+ if ((level & rec->level) == 0)
+ continue;
+
+- if (item == NULL) {
+- if (rec->temp == 0) log_write_rec(rec, str, level);
+- } else if (rec->items == NULL)
++ if (rec->items == NULL)
+ fallbacks = g_slist_append(fallbacks, rec);
+ else if (log_item_find(rec, LOG_ITEM_TARGET, item,
+ server_tag) != NULL)