aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
Diffstat (limited to 'irc')
-rw-r--r--irc/Makefile1
-rw-r--r--irc/eggcreator/Makefile33
-rw-r--r--irc/eggcreator/distinfo2
-rw-r--r--irc/eggcreator/pkg-descr2
4 files changed, 38 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index d37f912f3aab..86e18b036113 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -16,6 +16,7 @@
SUBDIR += darkbot
SUBDIR += dcc
SUBDIR += dircproxy
+ SUBDIR += eggcreator
SUBDIR += eggdrop
SUBDIR += epic4
SUBDIR += ezbounce
diff --git a/irc/eggcreator/Makefile b/irc/eggcreator/Makefile
new file mode 100644
index 000000000000..939e0656020a
--- /dev/null
+++ b/irc/eggcreator/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: eggcreator
+# Date created: May 4, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= eggcreator
+PORTVERSION= 0.1
+CATEGORIES= irc
+MASTER_SITES= http://free.top.bg/tcl/eggcreator/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Eggdrop.conf creator
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+
+WRKSRC= ${WRKDIR}/eggconfcreator
+MAKE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
+ QTDIR=${X11BASE}
+QMAKE= ${LOCALBASE}/bin/qmake
+
+PLIST_FILES= bin/egg
+
+do-build:
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} egg.pro && \
+ ${SETENV} ${MAKE_ENV} make)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/egg ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/irc/eggcreator/distinfo b/irc/eggcreator/distinfo
new file mode 100644
index 000000000000..87610f9825da
--- /dev/null
+++ b/irc/eggcreator/distinfo
@@ -0,0 +1,2 @@
+MD5 (eggcreator-0.1.tar.gz) = a6aaf0fd1163a98a0d69e7e6e1458772
+SIZE (eggcreator-0.1.tar.gz) = 23572
diff --git a/irc/eggcreator/pkg-descr b/irc/eggcreator/pkg-descr
new file mode 100644
index 000000000000..aaa2b0d1c0cf
--- /dev/null
+++ b/irc/eggcreator/pkg-descr
@@ -0,0 +1,2 @@
+Eggdrop.conf creator is a small X11 application for helping beginning eggdrop
+users generate .conf files.