aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
Diffstat (limited to 'irc')
-rw-r--r--irc/insub/Makefile4
-rw-r--r--irc/insub/distinfo4
-rw-r--r--irc/insub/files/patch-throttle42
3 files changed, 4 insertions, 46 deletions
diff --git a/irc/insub/Makefile b/irc/insub/Makefile
index c5755ca9e421..e37a2e2a937d 100644
--- a/irc/insub/Makefile
+++ b/irc/insub/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= insub
-PORTVERSION= 9.8
-PORTREVISION= 1
+PORTVERSION= 10.0
+#PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://gruntle.org/projects/irssi/insub/
diff --git a/irc/insub/distinfo b/irc/insub/distinfo
index e1a635bab47f..0fd2524e6141 100644
--- a/irc/insub/distinfo
+++ b/irc/insub/distinfo
@@ -1,2 +1,2 @@
-MD5 (insub-9.8.tar.bz2) = 0e5adddaf68e3ac4ef0bae166d254ffc
-SIZE (insub-9.8.tar.bz2) = 42297
+MD5 (insub-10.0.tar.bz2) = 784d868626e046a1a5c5f83b46cee488
+SIZE (insub-10.0.tar.bz2) = 45254
diff --git a/irc/insub/files/patch-throttle b/irc/insub/files/patch-throttle
deleted file mode 100644
index 8084fa646771..000000000000
--- a/irc/insub/files/patch-throttle
+++ /dev/null
@@ -1,42 +0,0 @@
---- insub.old Wed May 11 00:33:48 2005
-+++ insub.pl Wed May 11 00:33:51 2005
-@@ -364,19 +364,24 @@
- $text =~ s/</&lt;/g;
- $text =~ s/>/&gt;/g;
-
-- if (defined($prev_bg_color) && $bg_col == $prev_bg_color &&
-- defined($prev_fg_color) && $fg_col == $prev_fg_color) {
-- $ret = $text;
-+ if ((defined($prev_bg_color) && $bg_col != $prev_bg_color) ||
-+ (defined($prev_fg_color) && $fg_col != $prev_fg_color)) {
-+ $ret .= qq(</span>);
-+ }
-+
-+ if ((defined($prev_bg_color) && $bg_col == $prev_bg_color) &&
-+ (defined($prev_fg_color) && $fg_col == $prev_fg_color)) {
-+ $ret .= $text;
- } elsif ($bg_col == 1) {
- # black is assumed because of a div taggy
-- $ret = sprintf(
-- qq(<span style="color:%s;">%s</span>),
-+ $ret .= sprintf(
-+ qq(<span style="color:%s;">%s),
- $html_map->{$fg_col},
- $text,
- );
- } else {
-- $ret = sprintf(
-- qq(<span style="color:%s;background-color:%s;">%s</span>),
-+ $ret .= sprintf(
-+ qq(<span style="color:%s;background-color:%s;">%s),
- $html_map->{$fg_col},
- $html_map->{$bg_col},
- $text,
-@@ -916,6 +921,7 @@
- }
-
-
-+ $| = 1 if ($throttle);
- foreach my $line (split(/\n/, $text)) {
- if ($CONTEXT eq 'irssi') {
- $cmd = "msg $sendto" unless $cmd;