aboutsummaryrefslogtreecommitdiff
path: root/japanese/acroread/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/acroread/Makefile')
-rw-r--r--japanese/acroread/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/japanese/acroread/Makefile b/japanese/acroread/Makefile
index 5da96b54ddce..cde175cf4685 100644
--- a/japanese/acroread/Makefile
+++ b/japanese/acroread/Makefile
@@ -17,8 +17,7 @@ COMMENT= Adobe Reader which allows view, print, and search PDF documents
BUILD_DEPENDS= ${LOCALBASE}/bin/jless:${PORTSDIR}/japanese/less
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-x11-2.0.so.0:${PORTSDIR}/x11-toolkits/linux-gtk2 \
- ${LINUXBASE}/usr/lib/libpango-1.0.so.0:${PORTSDIR}/x11-toolkits/linux-pango \
- ${LINUXBASE}/usr/X11R6/lib/libXext.so.6:${PORTSDIR}/x11/linux-XFree86-libs
+ ${LINUXBASE}/usr/lib/libpango-1.0.so.0:${PORTSDIR}/x11-toolkits/linux-pango
RESTRICTED= "Must fill out redistribution form at http://www.adobe.com/products/acrobat/distribute.html"
NO_PACKAGE= "Use and redistribution with repackaging are not allowed"
@@ -26,9 +25,9 @@ IS_INTERACTIVE= yes
CONFLICTS= acroread-[0-9]* acroread[57]-[0-9]* \
ja-acroread5-[0-9]*
ONLY_FOR_ARCHS= amd64 i386
-USE_LINUX?= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
NO_BUILD= yes
-NO_FILTER_SHLIBS= yes
PLIST_SUB= ACRODIR=${ACRODIR}
SUB_FILES= acroread
SUB_LIST= INSTALLDIR=${INSTALLDIR}
@@ -43,6 +42,7 @@ INSTALLEXEC= ${SETENV} UNAME_s=Linux \
${SH} ./INSTALL
do-install:
+# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
${MKDIR} ${INSTALLDIR}
cd ${WRKSRC} && ${INSTALLEXEC}
# disable the PPKLite plugin as it requires an LDAP share lib