aboutsummaryrefslogtreecommitdiff
path: root/japanese/eb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/eb/Makefile')
-rw-r--r--japanese/eb/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/japanese/eb/Makefile b/japanese/eb/Makefile
index 282a3dea6bf5..007ece5c7c78 100644
--- a/japanese/eb/Makefile
+++ b/japanese/eb/Makefile
@@ -3,6 +3,7 @@
PORTNAME= eb
PORTVERSION= 4.4.3
+PORTREVISION= 1
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.sra.co.jp/pub/misc/eb/ \
ftp://ftp.sra.co.jp/pub/misc/eb/old/eb-${PORTVERSION:C/^([0-9]+)\.([0-9]+).*/\1.\2/}/
@@ -65,7 +66,7 @@ PORTDOCS= eb-01.html eb-02.html eb-03.html eb-04.html eb-05.html eb-06.html \
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
-USES= gettext perl5
+USES= perl5
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-pkgdocdir=${DOCSDIR}
@@ -77,6 +78,7 @@ APPENDIXDIR= ${DATADIR}/appendix
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
CONFIGURE_ARGS+= --enable-nls \
--with-gettext-includes=${LOCALBASE}/include \
--with-gettext-libraries=${LOCALBASE}/lib \
@@ -84,6 +86,7 @@ CONFIGURE_ARGS+= --enable-nls \
--with-iconv-libraries=${LOCALBASE}/lib
PLIST_SUB= NLS=""
.else
+CONFIGURE_ARGS+= --disable-nls
PLIST_SUB= NLS="@comment "
.endif