aboutsummaryrefslogtreecommitdiff
path: root/japanese/ebnetd
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/ebnetd')
-rw-r--r--japanese/ebnetd/Makefile45
-rw-r--r--japanese/ebnetd/distinfo1
-rw-r--r--japanese/ebnetd/files/ndtpd.sh.sample49
-rw-r--r--japanese/ebnetd/pkg-comment1
-rw-r--r--japanese/ebnetd/pkg-descr14
-rw-r--r--japanese/ebnetd/pkg-install61
-rw-r--r--japanese/ebnetd/pkg-message19
-rw-r--r--japanese/ebnetd/pkg-plist13
8 files changed, 0 insertions, 203 deletions
diff --git a/japanese/ebnetd/Makefile b/japanese/ebnetd/Makefile
deleted file mode 100644
index dbeb18ed2a87..000000000000
--- a/japanese/ebnetd/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-# New ports collection makefile for: ndtpd
-# Version required: 2.3.6
-# Date created: 4 Aug 1998
-# Whom: Motoyuki Kasahara <m-kasahr@sra.co.jp>
-#
-# $FreeBSD$
-#
-
-DISTNAME= ndtpd-2.3.6
-PKGNAME= ja-ndtpd-2.3.6
-CATEGORIES= japanese
-MASTER_SITES= ftp://ftp.sra.co.jp/pub/net/ndtp/ndtpd/
-
-MAINTAINER= takamune@avrl.mei.co.jp
-
-LIB_DEPENDS= eb.3:${PORTSDIR}/japanese/eb
-
-USE_LIBTOOL= yes
-CONFIGURE_ARGS= --localstatedir=${RUNDIR} --with-logdir=${LOGDIR} \
- --with-eb --with-eb-includes=${PREFIX}/include \
- --with-zlib --with-eb-libraries=${PREFIX}/lib
-
-.if !defined(PACKAGE_BUILDING)
-IS_INTERACTIVE= Maybe_interactive_at_install_stage
-.endif
-
-# Local variables
-LOGDIR= /var/log
-RUNDIR= /var/run
-STARTUP_SCRIPT= ndtpd.sh.sample
-
-post-extract:
- cd ${WRKSRC} && ${RM} -rf eb
-
-post-build:
- ${SED} "s,@prefix@,${PREFIX},; s,@rundir@,${RUNDIR},"\
- ${FILESDIR}/${STARTUP_SCRIPT} > ${WRKDIR}/${STARTUP_SCRIPT}
-
-post-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${STARTUP_SCRIPT} ${PREFIX}/etc/rc.d
- @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${ECHO}
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>
diff --git a/japanese/ebnetd/distinfo b/japanese/ebnetd/distinfo
deleted file mode 100644
index 437f2b7593b3..000000000000
--- a/japanese/ebnetd/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (ndtpd-2.3.6.tar.gz) = e5c5c70b321edbf34eeb7cd3b8120340
diff --git a/japanese/ebnetd/files/ndtpd.sh.sample b/japanese/ebnetd/files/ndtpd.sh.sample
deleted file mode 100644
index bbf4f41b7508..000000000000
--- a/japanese/ebnetd/files/ndtpd.sh.sample
+++ /dev/null
@@ -1,49 +0,0 @@
-#!/bin/sh -e -
-# startup script for ndtpd
-
-# Usage: ndtpd.sh [kill|restart|status|terminate|stop|start]
-
-command=$1
-standalone=YES # Run ndtpd as a standalone daemon.
-#standalone=NO # Run ndtpd as a child of inetd.
-
-GetDirective() {
- directive=$1
-
- awk '/^[ ]*'${directive}'[ ]+/ {print $2; exit}' ${conf}
-}
-
-MakeWorkingDirectory() {
- user="`GetDirective user`"
- group="`GetDirective group`"
- work="`GetDirective work-path`"
-
- rm -rf ${work:=@rundir@/ndtpd}
- eval install -d ${user:+-o ${user}} ${group:+-g ${group}} ${work}
-}
-
-conf=@prefix@/etc/ndtpd.conf
-
-[ -f ${conf} ] || exit
-ndtpcheck || exit
-
-if [ "${standalone}" = YES ]; then
- ctrl=ndtpcontrol
- start="echo -n ' ndtpd'; ndtpd"
-else
- ctrl="echo 'Error: inetd invokes ndtpd.' >&2; false"
-fi
-
-case "${command}" in
-kill|restart|status|terminate)
- eval ${ctrl} ${command};;
-
-stop)
- eval ${ctrl} terminate;;
-
-start|*)
- MakeWorkingDirectory
- eval ${start};;
-esac
-
-exit
diff --git a/japanese/ebnetd/pkg-comment b/japanese/ebnetd/pkg-comment
deleted file mode 100644
index 3580121cba9a..000000000000
--- a/japanese/ebnetd/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Server for accessing CD-ROM books with NDTP
diff --git a/japanese/ebnetd/pkg-descr b/japanese/ebnetd/pkg-descr
deleted file mode 100644
index c62a145acf09..000000000000
--- a/japanese/ebnetd/pkg-descr
+++ /dev/null
@@ -1,14 +0,0 @@
-NDTPD is a server for accessing CD-ROM books with NDTP (Network
-Dictionary Transfer Protocol) on TCP. You can replace dserver with
-NDTPD. NDTPD can run on UNIX derived systems. It supports to access
-CD-ROM books of EB, EBG, EBXA and EPWING formats. CD-ROM books of
-those formats are popular in Japan. Since CD-ROM books themseves are
-stands on the ISO 9660 format, you can mount the discs by the same way
-as other ISO 9660 discs.
-
--- Motoyuki Kasahara <m-kasahr@sra.co.jp>
-
-You can get information about NDTPD from their website.
-WWW: http://www.sra.co.jp/people/m-kasahr/ndtpd/
-
--- Kazutoki TAKAMUNE <takamune@avrl.mei.co.jp>
diff --git a/japanese/ebnetd/pkg-install b/japanese/ebnetd/pkg-install
deleted file mode 100644
index d29231b3efb6..000000000000
--- a/japanese/ebnetd/pkg-install
+++ /dev/null
@@ -1,61 +0,0 @@
-#!/bin/sh -
-# an installation script for ndtpd
-
-ask() {
- local question default answer
-
- question=$1
- default=$2
-
- if [ -z "${PACKAGE_BUILDING}" ]; then
- read -p "${question} (y/n) [${default}]? " answer
- [ "${answer}" ] && default=${answer}
- fi
- echo ${default}
-}
-
-yesno() {
- local question default
-
- question=$1
- default=$2
-
- while :; do
- case `ask "${question}" ${default}` in
- [Yy]*) return 0;;
- [Nn]*) return 1;;
- esac
- echo "Please answer yes or no."
- done
-}
-
-[ "$2" = POST-INSTALL ] || exit 0
-
-#
-# Add an entry for `ndtp' to /etc/services.
-#
-file=/etc/services
-back=${file}.bak
-name=ndtp
-port=2010/tcp
-comment="Network Dictionary Transfer Protocol"
-
-echo "************************************************************************"
-if sed 's/#.*//' ${file} | grep -qw ${name}; then
- echo "This system has already an entry for ${name} in ${file}."
-else
- echo "This system has no entry for ${name} in ${file}."
- if yesno " Would you like to add it automatically?" y; then
- cp -f ${file} ${back}
- echo " The original file is saved as ${back}."
-
- if sed 's/#.*//' ${file} | grep -qw ${port}; then
- sed 's,^\([^#]*[ ]'${port}'\),\1 '${name}, ${back} > ${file}
- else
- echo "${name} ${port} #${comment}" >> ${file}
- fi
- fi
-fi
-echo "************************************************************************"
-
-exit 0
diff --git a/japanese/ebnetd/pkg-message b/japanese/ebnetd/pkg-message
deleted file mode 100644
index 796592a8b02a..000000000000
--- a/japanese/ebnetd/pkg-message
+++ /dev/null
@@ -1,19 +0,0 @@
-************************************************************************
-You'll need manual configurations to actually activate `ndtpd'.
-
-**** IF YOU WANT TO SETUP PRIVATE SYSLOG, edit /etc/syslog.conf.
-
-1st) Copy a sample configuration file `ndtpd.conf.sample' to `ndtpd.conf'
- in `${PREFIX}/etc' directory, and edit it.
- Consult the "Configuration File" section of info file.
-
-2nd) Copy a sample startup script `ndtpd.sh.sample' to `ndtpd.sh'
- in `${PREFIX}/etc/rc.d' directory, and edit it.
-
- a) To start `ndtpd' as a standalone daemon, set the variable
- `standalone' in the script to `YES', and exec it.
-
- b) Otherwise, to start as a child process of `inetd',
- set `standalone' to `NO', and edit the file `/etc/inetd.conf'.
- Consult the "Run as a Child of inetd" section of info file.
-************************************************************************
diff --git a/japanese/ebnetd/pkg-plist b/japanese/ebnetd/pkg-plist
deleted file mode 100644
index f3eb721f059a..000000000000
--- a/japanese/ebnetd/pkg-plist
+++ /dev/null
@@ -1,13 +0,0 @@
-etc/ndtpd.conf.sample
-etc/rc.d/ndtpd.sh.sample
-@unexec install-info --delete %D/info/ndtpd-ja.info %D/info/dir
-@unexec install-info --delete %D/info/ndtpd.info %D/info/dir
-info/ndtpd-ja.info
-info/ndtpd.info
-@exec install-info %B/ndtpd-ja.info %B/dir
-@exec install-info %B/ndtpd.info %B/dir
-libexec/ndtpstat
-sbin/ndtpcheck
-sbin/ndtpcontrol
-sbin/ndtpd
-sbin/ndtpdaily