aboutsummaryrefslogtreecommitdiff
path: root/japanese/gauche-kakasi
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/gauche-kakasi')
-rw-r--r--japanese/gauche-kakasi/Makefile40
-rw-r--r--japanese/gauche-kakasi/distinfo1
-rw-r--r--japanese/gauche-kakasi/pkg-descr3
-rw-r--r--japanese/gauche-kakasi/pkg-plist6
4 files changed, 50 insertions, 0 deletions
diff --git a/japanese/gauche-kakasi/Makefile b/japanese/gauche-kakasi/Makefile
new file mode 100644
index 000000000000..5f1187385014
--- /dev/null
+++ b/japanese/gauche-kakasi/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Gauche-kakasi
+# Date created: 12 April 2003
+# Whom: Kimura Fuyuki <fuyuki@hadaly.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kakasi
+PORTVERSION= 0.0
+CATEGORIES= japanese textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gauche
+DISTNAME= Gauche-${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= fuyuki@hadaly.org
+COMMENT= KAKASI binding for Gauche
+
+BUILD_DEPENDS= gosh:${PORTSDIR}/lang/gauche
+RUN_DEPENDS= ${BUILD_DEPENDS}
+LIB_DEPENDS= kakasi.3:${PORTSDIR}/japanese/kakasi
+
+WRKSRC= ${WRKDIR}/Gauche-${PORTNAME}
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-kakasi=${PREFIX}
+DOCSDIR= ${PREFIX}/share/doc/gauche/${PORTNAME}
+PLIST_SUB= VERSION="`gauche-config -V`" \
+ TARGET="${CONFIGURE_TARGET}"
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.eucjp ${DOCSDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+PKGNAMEPREFIX:= ${PKGNAMEPREFIX}gauche-
+
+.include <bsd.port.post.mk>
diff --git a/japanese/gauche-kakasi/distinfo b/japanese/gauche-kakasi/distinfo
new file mode 100644
index 000000000000..8882a7c1cca2
--- /dev/null
+++ b/japanese/gauche-kakasi/distinfo
@@ -0,0 +1 @@
+MD5 (Gauche-kakasi-0.0.tgz) = 8c8e40469ae17fe43719561888e7af09
diff --git a/japanese/gauche-kakasi/pkg-descr b/japanese/gauche-kakasi/pkg-descr
new file mode 100644
index 000000000000..914394d6d976
--- /dev/null
+++ b/japanese/gauche-kakasi/pkg-descr
@@ -0,0 +1,3 @@
+This is a Gauche extension module to use KAKASI.
+
+WWW: http://www.shiro.dreamhost.com/scheme/gauche/index.html
diff --git a/japanese/gauche-kakasi/pkg-plist b/japanese/gauche-kakasi/pkg-plist
new file mode 100644
index 000000000000..0892f88ef74f
--- /dev/null
+++ b/japanese/gauche-kakasi/pkg-plist
@@ -0,0 +1,6 @@
+lib/gauche/site/%%VERSION%%/%%TARGET%%/kakasi.so
+share/gauche/site/lib/text/kakasi.scm
+@unexec rmdir %D/share/gauche/site/lib/text 2>/dev/null || true
+%%PORTDOCS%%%%DOCSDIR%%/README.eucjp
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@unexec rmdir %D/share/doc/gauche 2>/dev/null || true