aboutsummaryrefslogtreecommitdiff
path: root/japanese/lyx
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/lyx')
-rw-r--r--japanese/lyx/Makefile52
-rw-r--r--japanese/lyx/distinfo6
-rw-r--r--japanese/lyx/files/patch-aa11
-rw-r--r--japanese/lyx/files/patch-ab57
-rw-r--r--japanese/lyx/files/patch-ac12
-rw-r--r--japanese/lyx/pkg-descr13
-rw-r--r--japanese/lyx/pkg-plist238
7 files changed, 0 insertions, 389 deletions
diff --git a/japanese/lyx/Makefile b/japanese/lyx/Makefile
deleted file mode 100644
index 30af1bf07c4a..000000000000
--- a/japanese/lyx/Makefile
+++ /dev/null
@@ -1,52 +0,0 @@
-# New ports collection makefile for: lyx
-# Date created: 27 April 1999
-# Whom: Seiichirou Hiraoka
-#
-# $FreeBSD$
-#
-
-PORTNAME= lyx
-PORTVERSION= 1.0.3
-PORTREVISION= 1
-CATEGORIES= japanese print
-MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
- ftp://ftp.sdsc.edu/pub/other/lyx/stable/ \
- ${MASTER_SITE_LOCAL:S/$/:local/}
-MASTER_SITE_SUBDIR= flathill/:local
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${PORTNAME}-jp-kit0.10b4for${PORTVERSION}.tar.gz:local
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG)
-
-LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms
-
-USE_XORG= xpm
-USE_PERL5= yes
-GNU_CONFIGURE= yes
-STRIP=
-CONFIGURE_ARGS= --with-extra-lib=${LOCALBASE}/lib --with-extra-inc="${LOCALBASE}/include ${LOCALBASE}/include/X11"
-MAN1= lyx.1 reLyX.1
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
-pre-fetch:
-.if !defined(WITH_ISPELL)
- @${ECHO_MSG} "if you want this port build with spell checker type"
- @${ECHO_MSG} "make WITH_ISPELL=yes"
-.endif
-
-post-patch:
- @cd ${WRKSRC}; ${PATCH} -p1 < ../lyx-jp-patch
-
-post-install:
- ${STRIP_CMD} ${PREFIX}/bin/lyx
- ${INSTALL_DATA} ${WRKDIR}/ChangeLog.jis ${PREFIX}/share/lyx
- ${INSTALL_DATA} ${WRKDIR}/README.jis ${PREFIX}/share/lyx
- ${INSTALL_DATA} ${WRKSRC}/lib/lyxrc.jp ${PREFIX}/share/lyx
-
-.include <bsd.port.post.mk>
diff --git a/japanese/lyx/distinfo b/japanese/lyx/distinfo
deleted file mode 100644
index c6c7eb7f01bc..000000000000
--- a/japanese/lyx/distinfo
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 (lyx-1.0.3.tar.gz) = c7a8191795160de3a138a66041dc8de6
-SHA256 (lyx-1.0.3.tar.gz) = f96dd579e1775fb5e33d63e8a60058a367d26725c92bbd225ce73efe22a08b40
-SIZE (lyx-1.0.3.tar.gz) = 2934652
-MD5 (lyx-jp-kit0.10b4for1.0.3.tar.gz) = e0472429c7381f726fd29c7a60e96c80
-SHA256 (lyx-jp-kit0.10b4for1.0.3.tar.gz) = 5764b6e95b80d19d77cbb4e23e06527d24883047d008a4ffb4ec7479dc6de327
-SIZE (lyx-jp-kit0.10b4for1.0.3.tar.gz) = 43753
diff --git a/japanese/lyx/files/patch-aa b/japanese/lyx/files/patch-aa
deleted file mode 100644
index 9bccd8a35872..000000000000
--- a/japanese/lyx/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Tue Jun 1 19:07:35 1999
-+++ configure Mon Apr 24 21:02:48 2000
-@@ -5777,7 +5777,7 @@
- #ifdef HAVE_SYS_SOCKET_H
- #include <sys/socket.h>
- #endif
--extern select ($ac_cv_func_select_arg1,$ac_cv_func_select_arg234,$ac_cv_func_select_arg234,$ac_cv_func_select_arg234,$ac_cv_func_select_arg5);
-+extern int select ($ac_cv_func_select_arg1,$ac_cv_func_select_arg234,$ac_cv_func_select_arg234,$ac_cv_func_select_arg234,$ac_cv_func_select_arg5);
- int main() {
-
- ; return 0; }
diff --git a/japanese/lyx/files/patch-ab b/japanese/lyx/files/patch-ab
deleted file mode 100644
index 90179d0a41c1..000000000000
--- a/japanese/lyx/files/patch-ab
+++ /dev/null
@@ -1,57 +0,0 @@
---- src/main.C.orig Tue Jul 2 00:11:14 2002
-+++ src/main.C Tue Jul 2 00:11:52 2002
-@@ -21,16 +21,6 @@
- static char vcid[] = "$Id: main.C,v 1.2 1998/06/22 05:50:57 arrae Exp $";
- #endif /* lint */
-
--// I keep these here so that it will be processed as early in
--// the compilation process as possible.
--#if !defined(FL_REVISION) || (FL_REVISION != 81 && FL_REVISION != 86 &&\
-- FL_REVISION != 87 && FL_REVISION != 88) \
-- || FL_VERSION != 0
--#error LyX will not compile with this version of XForms.\
-- Please get version 0.88 (0.81 and 0.86 also work).\
-- If you want to try to compile anyway, delete this test in src/main.C.
--#endif
--
-
- int main(int argc, char *argv[])
- {
---- src/lyx_gui_misc.h.orig Tue Jul 2 00:23:13 2002
-+++ src/lyx_gui_misc.h Tue Jul 2 00:23:32 2002
-@@ -64,7 +64,7 @@
- inline
- void LyXBell() {
- // if (audio()) ON/OFF switch yet to be implemented
--#if FL_REVISION > 85
-+#if FL_VERSION > 0 || FL_REVISION > 85
- fl_ringbell(20);
- #else
- ringbell();
---- src/lyx_gui_misc.C.orig Tue Jul 2 00:27:17 2002
-+++ src/lyx_gui_misc.C Tue Jul 2 00:30:10 2002
-@@ -379,7 +379,7 @@
- {
- fl_set_resource("flQuestion.yes.label", idex(_("Yes|Yy#y")));
- fl_set_resource("flQuestion.no.label", idex(_("No|Nn#n")));
--#if FL_REVISION > 85
-+#if FL_VERSION > 0 || FL_REVISION > 85
- return fl_show_question((s1 + "\n" + s2 + "\n" + s3).c_str(), 0);
- #else
- return fl_show_question(s1.c_str(), s2.c_str(), s3.c_str());
-@@ -392,13 +392,12 @@
- fl_set_choices_shortcut(scex(_("Yes|Yy#y")),
- scex(_("No|Nn#n")),
- scex(_("Cancel|^[")));
--#if FL_REVISION < 86
-+#if FL_VERSION == 0 && FL_REVISION < 86
- return fl_show_choice(s1.c_str(), s2.c_str(), s3.c_str(),
- 3, idex(_("Yes|Yy#y")),
- idex(_("No|Nn#n")),
- idex(_("Cancel|^[")));
--#endif
--#if FL_REVISION > 85
-+#else
- return fl_show_choice(s1.c_str(), s2.c_str(), s3.c_str(),
- 3, idex(_("Yes|Yy#y")),
- idex(_("No|Nn#n")),
diff --git a/japanese/lyx/files/patch-ac b/japanese/lyx/files/patch-ac
deleted file mode 100644
index 7531db9275d1..000000000000
--- a/japanese/lyx/files/patch-ac
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/screen.C.orig Tue Jul 2 00:53:03 2002
-+++ src/screen.C Tue Jul 2 00:53:23 2002
-@@ -809,9 +809,6 @@
- // I want the buttons back before 0.12. OK, this is very simple,
- // like what is done in xforms sources. (Ale)
-
-- // This one is too dirty. Get rid of it.
-- extern GC fl_gc;
--
- // Please comment this annonymous variable.
- int d = 2;
-
diff --git a/japanese/lyx/pkg-descr b/japanese/lyx/pkg-descr
deleted file mode 100644
index fb9b5322e07d..000000000000
--- a/japanese/lyx/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-LyX is a document processor interfaced with LaTeX, which gives both the
-ease-of-use of a wordprocessor, and the flexibility and power of
-LaTeX.
-
-Quasi-WYSIWYG interface, many LaTeX styles and layouts automatically
-generated. Speeds up learning LaTeX and makes complicated layouts
-easy and intuitive. New features include spell-checking, international
-character support, WYSIWYG graphics, tables, and equations.
-
-WWW: http://www.lyx.org/
-
-Author: Matthias Ettrich <ettrich@informatik.uni-tuebingen.de>
-Maintained-by: Lars Gullik BjBxnnes <larsbj@ifi.uio.no>
diff --git a/japanese/lyx/pkg-plist b/japanese/lyx/pkg-plist
deleted file mode 100644
index 184d09237a89..000000000000
--- a/japanese/lyx/pkg-plist
+++ /dev/null
@@ -1,238 +0,0 @@
-bin/lyx
-bin/noweb2lyx
-bin/reLyX
-share/locale/cs/LC_MESSAGES/lyx.mo
-share/locale/da/LC_MESSAGES/lyx.mo
-share/locale/de/LC_MESSAGES/lyx.mo
-share/locale/es/LC_MESSAGES/lyx.mo
-share/locale/fi/LC_MESSAGES/lyx.mo
-share/locale/fr/LC_MESSAGES/lyx.mo
-share/locale/hu/LC_MESSAGES/lyx.mo
-share/locale/it/LC_MESSAGES/lyx.mo
-share/locale/nl/LC_MESSAGES/lyx.mo
-share/locale/no/LC_MESSAGES/lyx.mo
-share/locale/pl/LC_MESSAGES/lyx.mo
-share/locale/pt/LC_MESSAGES/lyx.mo
-share/locale/ru/LC_MESSAGES/lyx.mo
-share/locale/sl/LC_MESSAGES/lyx.mo
-share/locale/sv/LC_MESSAGES/lyx.mo
-share/locale/tr/LC_MESSAGES/lyx.mo
-share/locale/wa/LC_MESSAGES/lyx.mo
-%%DATADIR%%/CREDITS
-%%DATADIR%%/ChangeLog.jis
-%%DATADIR%%/README.jis
-%%DATADIR%%/bind/broadway.bind
-%%DATADIR%%/bind/cua.bind
-%%DATADIR%%/bind/de_menus.bind
-%%DATADIR%%/bind/emacs.bind
-%%DATADIR%%/bind/fr_menus.bind
-%%DATADIR%%/bind/hollywood.bind
-%%DATADIR%%/bind/hu_menus.bind
-%%DATADIR%%/bind/math.bind
-%%DATADIR%%/bind/menus.bind
-%%DATADIR%%/bind/pt_menus.bind
-%%DATADIR%%/bind/sv_menus.bind
-%%DATADIR%%/bind/xemacs.bind
-%%DATADIR%%/chkconfig.ltx
-%%DATADIR%%/clipart/platypus.eps
-%%DATADIR%%/configure
-%%DATADIR%%/doc/BUGS.lyx
-%%DATADIR%%/doc/Customization.lyx
-%%DATADIR%%/doc/DocStyle.lyx
-%%DATADIR%%/doc/Extended.lyx
-%%DATADIR%%/doc/Intro.lyx
-%%DATADIR%%/doc/LaTeXConfig.lyx
-%%DATADIR%%/doc/LaTeXConfig.lyx.in
-%%DATADIR%%/doc/Reference.lyx
-%%DATADIR%%/doc/Tutorial.lyx
-%%DATADIR%%/doc/UserGuide.lyx
-%%DATADIR%%/doc/cs_Tutorial.lyx
-%%DATADIR%%/doc/de_BUGS.lyx
-%%DATADIR%%/doc/de_Customization.lyx
-%%DATADIR%%/doc/de_Extended.lyx
-%%DATADIR%%/doc/de_Intro.lyx
-%%DATADIR%%/doc/de_Tutorial.lyx
-%%DATADIR%%/doc/de_UserGuide.lyx
-%%DATADIR%%/doc/es_Intro.lyx
-%%DATADIR%%/doc/es_Tutorial.lyx
-%%DATADIR%%/doc/es_splash.lyx
-%%DATADIR%%/doc/escher-lsd.eps
-%%DATADIR%%/doc/fr_Intro.lyx
-%%DATADIR%%/doc/fr_Tutorial.lyx
-%%DATADIR%%/doc/mobius.eps
-%%DATADIR%%/doc/pl_Intro.lyx
-%%DATADIR%%/doc/pl_Tutorial.lyx
-%%DATADIR%%/doc/platypus.eps
-%%DATADIR%%/doc/pt_Intro.lyx
-%%DATADIR%%/doc/sl_Intro.lyx
-%%DATADIR%%/doc/sv_Intro.lyx
-%%DATADIR%%/doc/sv_Tutorial.lyx
-%%DATADIR%%/examples/Foils.lyx
-%%DATADIR%%/examples/ItemizeBullets.lyx
-%%DATADIR%%/examples/Literate.lyx
-%%DATADIR%%/examples/MathLabeling.lyx
-%%DATADIR%%/examples/Math_macros.lyx
-%%DATADIR%%/examples/Minipage.lyx
-%%DATADIR%%/examples/TableExamples.lyx
-%%DATADIR%%/examples/aa_head.lyx
-%%DATADIR%%/examples/aa_paper.lyx
-%%DATADIR%%/examples/amsart-test.lyx
-%%DATADIR%%/examples/amsbook-test.lyx
-%%DATADIR%%/examples/beispiel_gelyxt.lyx
-%%DATADIR%%/examples/beispiel_roh.lyx
-%%DATADIR%%/examples/de_splash.lyx
-%%DATADIR%%/examples/ejemplo_con_lyx.lyx
-%%DATADIR%%/examples/ejemplo_sin_lyx.lyx
-%%DATADIR%%/examples/es_splash.lyx
-%%DATADIR%%/examples/example_lyxified.lyx
-%%DATADIR%%/examples/example_raw.lyx
-%%DATADIR%%/examples/exemple_brut.lyx
-%%DATADIR%%/examples/exemple_lyxifie.lyx
-%%DATADIR%%/examples/fr_splash.lyx
-%%DATADIR%%/examples/landslide.lyx
-%%DATADIR%%/examples/noweb2lyx.lyx
-%%DATADIR%%/examples/pl_splash.lyx
-%%DATADIR%%/examples/primer_lyxan.lyx
-%%DATADIR%%/examples/primer_surov.lyx
-%%DATADIR%%/examples/pt_splash.lyx
-%%DATADIR%%/examples/scriptone.lyx
-%%DATADIR%%/examples/sl_splash.lyx
-%%DATADIR%%/examples/splash.lyx
-%%DATADIR%%/images/amssymb.xbm
-%%DATADIR%%/images/amssymb.xpm
-%%DATADIR%%/images/psnfss1.xbm
-%%DATADIR%%/images/psnfss1.xpm
-%%DATADIR%%/images/psnfss2.xbm
-%%DATADIR%%/images/psnfss2.xpm
-%%DATADIR%%/images/psnfss3.xbm
-%%DATADIR%%/images/psnfss3.xpm
-%%DATADIR%%/images/psnfss4.xbm
-%%DATADIR%%/images/psnfss4.xpm
-%%DATADIR%%/images/standard.xbm
-%%DATADIR%%/images/standard.xpm
-%%DATADIR%%/kbd/american-2.kmap
-%%DATADIR%%/kbd/american.kmap
-%%DATADIR%%/kbd/brazil.kmap
-%%DATADIR%%/kbd/brazil2.kmap
-%%DATADIR%%/kbd/czech.kmap
-%%DATADIR%%/kbd/european.kmap
-%%DATADIR%%/kbd/francais.kmap
-%%DATADIR%%/kbd/french.kmap
-%%DATADIR%%/kbd/german-2.kmap
-%%DATADIR%%/kbd/german-3.kmap
-%%DATADIR%%/kbd/german.kmap
-%%DATADIR%%/kbd/greek.kmap
-%%DATADIR%%/kbd/iso8859-1.cdef
-%%DATADIR%%/kbd/iso8859-2.cdef
-%%DATADIR%%/kbd/iso8859-7.cdef
-%%DATADIR%%/kbd/magyar-2.kmap
-%%DATADIR%%/kbd/magyar-3.kmap
-%%DATADIR%%/kbd/magyar.kmap
-%%DATADIR%%/kbd/polish.kmap
-%%DATADIR%%/kbd/portuges.kmap
-%%DATADIR%%/kbd/romanian.kmap
-%%DATADIR%%/kbd/sf.kmap
-%%DATADIR%%/kbd/sg.kmap
-%%DATADIR%%/kbd/slovak.kmap
-%%DATADIR%%/kbd/slovene.kmap
-%%DATADIR%%/kbd/transilvanian.kmap
-%%DATADIR%%/kbd/turkish-f.kmap
-%%DATADIR%%/kbd/turkish.kmap
-%%DATADIR%%/layouts/IEEEtran.layout
-%%DATADIR%%/layouts/aapaper.inc
-%%DATADIR%%/layouts/aapaper.layout
-%%DATADIR%%/layouts/amsart-plain.layout
-%%DATADIR%%/layouts/amsart-seq.layout
-%%DATADIR%%/layouts/amsart.layout
-%%DATADIR%%/layouts/amsbook.layout
-%%DATADIR%%/layouts/amsdefs.inc
-%%DATADIR%%/layouts/amsmaths-plain.inc
-%%DATADIR%%/layouts/amsmaths-seq.inc
-%%DATADIR%%/layouts/amsmaths.inc
-%%DATADIR%%/layouts/apa.layout
-%%DATADIR%%/layouts/article.layout
-%%DATADIR%%/layouts/book.layout
-%%DATADIR%%/layouts/broadway.layout
-%%DATADIR%%/layouts/dinbrief.layout
-%%DATADIR%%/layouts/egs.layout
-%%DATADIR%%/layouts/ejour2.layout
-%%DATADIR%%/layouts/foils.layout
-%%DATADIR%%/layouts/hollywood.layout
-%%DATADIR%%/layouts/iletter.layout
-%%DATADIR%%/layouts/jarticle.layout
-%%DATADIR%%/layouts/jbook.layout
-%%DATADIR%%/layouts/jlinuxdoc.layout
-%%DATADIR%%/layouts/jreport.layout
-%%DATADIR%%/layouts/latex8.layout
-%%DATADIR%%/layouts/letter.layout
-%%DATADIR%%/layouts/linuxdoc.layout
-%%DATADIR%%/layouts/literate-article.layout
-%%DATADIR%%/layouts/literate-book.layout
-%%DATADIR%%/layouts/literate-report.layout
-%%DATADIR%%/layouts/literate-scrap.inc
-%%DATADIR%%/layouts/lyxmacros.inc
-%%DATADIR%%/layouts/manpage.layout
-%%DATADIR%%/layouts/obsolete.inc
-%%DATADIR%%/layouts/paper.layout
-%%DATADIR%%/layouts/report.layout
-%%DATADIR%%/layouts/revtex.layout
-%%DATADIR%%/layouts/scrartcl.layout
-%%DATADIR%%/layouts/scrbook.layout
-%%DATADIR%%/layouts/scrclass.inc
-%%DATADIR%%/layouts/scrlettr.layout
-%%DATADIR%%/layouts/scrmacros.inc
-%%DATADIR%%/layouts/scrreprt.layout
-%%DATADIR%%/layouts/slides.layout
-%%DATADIR%%/layouts/stdclass.inc
-%%DATADIR%%/layouts/stdlayouts.inc
-%%DATADIR%%/layouts/stdletter.inc
-%%DATADIR%%/layouts/stdlists.inc
-%%DATADIR%%/layouts/stdsections.inc
-%%DATADIR%%/layouts/stdstarsections.inc
-%%DATADIR%%/layouts/stdstruct.inc
-%%DATADIR%%/lyxrc.defaults
-%%DATADIR%%/lyxrc.example
-%%DATADIR%%/lyxrc.jp
-%%DATADIR%%/packages.lst
-%%DATADIR%%/reLyX/BUGS
-%%DATADIR%%/reLyX/BasicLyX.pm
-%%DATADIR%%/reLyX/CHANGES
-%%DATADIR%%/reLyX/CleanTeX.pm
-%%DATADIR%%/reLyX/LastLyX.pm
-%%DATADIR%%/reLyX/MakePreamble.pm
-%%DATADIR%%/reLyX/README
-%%DATADIR%%/reLyX/ReadCommands.pm
-%%DATADIR%%/reLyX/RelyxFigure.pm
-%%DATADIR%%/reLyX/RelyxTable.pm
-%%DATADIR%%/reLyX/Text/TeX.pm
-%%DATADIR%%/reLyX/Verbatim.pm
-%%DATADIR%%/reLyX/reLyX.pod
-%%DATADIR%%/reLyX/reLyXmain.pl
-%%DATADIR%%/reLyX/syntax.default
-%%DATADIR%%/templates/aapaper.lyx
-%%DATADIR%%/templates/dinbrief.lyx
-%%DATADIR%%/templates/hollywood.lyx
-%%DATADIR%%/templates/iletter.lyx
-%%DATADIR%%/templates/latex8.lyx
-%%DATADIR%%/templates/letter.lyx
-%%DATADIR%%/templates/linuxdoctemplate.lyx
-%%DATADIR%%/templates/revtex.lyx
-%%DATADIR%%/templates/slides.lyx
-%%DATADIR%%/tex/broadway.cls
-%%DATADIR%%/tex/ejour2.cls
-%%DATADIR%%/tex/hollywood.cls
-%%DATADIR%%/tex/iletter.cls
-%%DATADIR%%/tex/revtex.cls
-%%DATADIR%%/textclass.lst
-@dirrm %%DATADIR%%/tex
-@dirrm %%DATADIR%%/templates
-@dirrm %%DATADIR%%/reLyX/Text
-@dirrm %%DATADIR%%/reLyX
-@dirrm %%DATADIR%%/layouts
-@dirrm %%DATADIR%%/kbd
-@dirrm %%DATADIR%%/images
-@dirrm %%DATADIR%%/examples
-@dirrm %%DATADIR%%/doc
-@dirrm %%DATADIR%%/clipart
-@dirrm %%DATADIR%%/bind
-@dirrm %%DATADIR%%