aboutsummaryrefslogtreecommitdiff
path: root/japanese/mailman/files/patch-configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/mailman/files/patch-configure.in')
-rw-r--r--japanese/mailman/files/patch-configure.in70
1 files changed, 70 insertions, 0 deletions
diff --git a/japanese/mailman/files/patch-configure.in b/japanese/mailman/files/patch-configure.in
new file mode 100644
index 000000000000..763462aa04b7
--- /dev/null
+++ b/japanese/mailman/files/patch-configure.in
@@ -0,0 +1,70 @@
+
+$FreeBSD: /tmp/pcvs/ports/japanese/mailman/files/patch-configure.in,v 1.1 2012-03-04 06:00:38 tota Exp $
+
+Mailman tests for existence of users during configure -- unfortunately
+this creates a problem; we create the users just before install.
+
+We remove the testing part.
+
+--- configure.in.orig 2011-12-11 16:56:23.000000000 +0900
++++ configure.in 2012-02-15 06:11:05.000000000 +0900
+@@ -341,28 +341,7 @@
+ # $2 == user id to check for
+ AC_SUBST($1)
+ changequote(,)
+-if test -z "$$1"
+-then
+- cat > conftest.py <<EOF
+-import grp
+-gid = ''
+-for group in "$2".split():
+- try:
+- try:
+- gname = grp.getgrgid(int(group))[0]
+- break
+- except ValueError:
+- gname = grp.getgrnam(group)[0]
+- break
+- except KeyError:
+- gname = ''
+-fp = open("conftest.out", "w")
+-fp.write("%s\n" % gname)
+-fp.close()
+-EOF
+- $PYTHON conftest.py
+- $1=`cat conftest.out`
+-fi
++$1=$2
+ changequote([, ])
+ rm -f conftest.out conftest.py])
+
+@@ -373,28 +352,7 @@
+ # $2 == user id to check for
+ AC_SUBST($1)
+ changequote(,)
+-if test -z "$$1"
+-then
+- cat > conftest.py <<EOF
+-import pwd
+-uid = ''
+-for user in "$2".split():
+- try:
+- try:
+- uname = pwd.getpwuid(int(user))[0]
+- break
+- except ValueError:
+- uname = pwd.getpwnam(user)[0]
+- break
+- except KeyError:
+- uname = ''
+-fp = open("conftest.out", "w")
+-fp.write("%s\n" % uname)
+-fp.close()
+-EOF
+- $PYTHON conftest.py
+- $1=`cat conftest.out`
+-fi
++$1=$2
+ changequote([, ])
+ rm -f conftest.out conftest.py])
+