aboutsummaryrefslogtreecommitdiff
path: root/japanese/man-doc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/man-doc/Makefile')
-rw-r--r--japanese/man-doc/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/japanese/man-doc/Makefile b/japanese/man-doc/Makefile
index 0ee26f0e6c5a..f683baa23460 100644
--- a/japanese/man-doc/Makefile
+++ b/japanese/man-doc/Makefile
@@ -17,6 +17,7 @@ COMMENT= Japanese translation of FreeBSD manual pages
RUN_DEPENDS= jman:${PORTSDIR}/japanese/man
+USES= uidfix
NO_MTREE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
PLIST= ${WRKDIR}/pkg-plist
@@ -53,12 +54,9 @@ post-build:
shift 2;\
esac; \
done; \
- if [ "x$${SUBDIR}" != "x" ]; then \
- ${ECHO_CMD} "@dirrm man/ja/$${SECNUM}$${SUBDIR}"; \
- fi; \
done | ${SORT} -r | uniq > ${PLIST}
-pre-su-install:
+pre-install:
for SEC in ${MANSECS}; do \
SECNUM=$${SEC%%/*}; \
cd ${WRKSRC}/$${SEC} && \
@@ -66,9 +64,6 @@ pre-su-install:
${MKDIR} ${STAGEDIR}${PREFIX}/man/ja/$${SECNUM}$${SUBDIR}; \
done
-post-install:
- @${CAT} ${PKGMESSAGE}
-
# XXX: make gendist generates distfile. Use with WITH_CVS.
gendist: extract
cd ${WRKDIR} && \