aboutsummaryrefslogtreecommitdiff
path: root/japanese/mh/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/mh/Makefile')
-rw-r--r--japanese/mh/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/japanese/mh/Makefile b/japanese/mh/Makefile
index 5d3e7270e61c..36df64883916 100644
--- a/japanese/mh/Makefile
+++ b/japanese/mh/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 March 1995
# Whom: Akito FUJITA <fujita@zoo.ncl.omron.co.jp>
#
-# $Id: Makefile,v 1.5 1996/11/11 10:12:24 max Exp $
+# $Id: Makefile,v 1.6 1996/11/18 14:01:51 asami Exp $
#
DISTNAME= mh-6.8.3
@@ -14,14 +14,25 @@ DISTFILES= mh-6.8.3-JP.2c.tar.gz
MAINTAINER= asami@FreeBSD.ORG
+RUN_DEPENDS= jless:${PORTSDIR}/japanese/less
+
MAN1= ali.1 anno.1 burst.1 comp.1 dist.1 folder.1 forw.1 inc.1 \
mark.1 mh-chart.1 mh.1 mhl.1 mhook.1 mhmail.1 mhn.1 \
mhparam.1 mhpath.1 msgchk.1 msh.1 next.1 packf.1 pick.1 \
prev.1 prompter.1 rcvstore.1 refile.1 repl.1 rmf.1 rmm.1 \
- scan.1 send.1 show.1 slocal.1 sortm.1 vmh.1 whatnow.1 whom.1
+ scan.1 send.1 show.1 slocal.1 sortm.1 vmh.1 whatnow.1 whom.1 \
+ popi.1
MAN5= mh-alias.5 mh-format.5 mh-mail.5 mh-profile.5 mh-sequence.5 \
mh-tailor.5
-MAN8= ap.8 conflict.8 dp.8 install-mh.8 post.8 fmtdump.8
+MAN8= ap.8 conflict.8 dp.8 install-mh.8 post.8 fmtdump.8 popauth.8
+
+do-configure:
+ @sed s%@PREFIX@%${PREFIX}%g ${FILESDIR}/FreeBSD.in \
+ > ${WRKSRC}/conf/FreeBSD
+ @(cd ${WRKSRC}/conf; make; ./mhconfig FreeBSD)
+
+pre-build:
+ @(cd ${WRKSRC} ; make clean)
post-install:
ldconfig -m ${PREFIX}/lib