aboutsummaryrefslogtreecommitdiff
path: root/japanese/navi2ch-emacs20
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/navi2ch-emacs20')
-rw-r--r--japanese/navi2ch-emacs20/Makefile1
-rw-r--r--japanese/navi2ch-emacs20/files/patch-navi2ch-article.el14
2 files changed, 15 insertions, 0 deletions
diff --git a/japanese/navi2ch-emacs20/Makefile b/japanese/navi2ch-emacs20/Makefile
index 47a6dd9ba64f..f30aa77d59c0 100644
--- a/japanese/navi2ch-emacs20/Makefile
+++ b/japanese/navi2ch-emacs20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= navi2ch
PORTVERSION= 1.7.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= japanese www elisp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
diff --git a/japanese/navi2ch-emacs20/files/patch-navi2ch-article.el b/japanese/navi2ch-emacs20/files/patch-navi2ch-article.el
new file mode 100644
index 000000000000..23182ffc9779
--- /dev/null
+++ b/japanese/navi2ch-emacs20/files/patch-navi2ch-article.el
@@ -0,0 +1,14 @@
+--- navi2ch-article.el.orig Wed Sep 10 21:54:33 2003
++++ navi2ch-article.el Mon Dec 8 19:41:55 2003
+@@ -1445,8 +1445,9 @@
+ (cond ((string-match "\\([0-9]+\\)-\\([0-9]+\\)" str)
+ (let* ((n1 (string-to-number (match-string 1 str)))
+ (n2 (string-to-number (match-string 2 str)))
+- (min (min n1 n2))
+- (i (max n1 n2))
++ (min (max (min n1 n2) 1))
++ (i (min (max n1 n2)
++ (1+ (length navi2ch-article-message-list))))
+ list)
+ (while (>= i min)
+ (push i list)