aboutsummaryrefslogtreecommitdiff
path: root/japanese/navi2ch-emacs20
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/navi2ch-emacs20')
-rw-r--r--japanese/navi2ch-emacs20/Makefile1
-rw-r--r--japanese/navi2ch-emacs20/files/patch-navi2ch-multibbs.el49
-rw-r--r--japanese/navi2ch-emacs20/files/patch-navi2ch-net.el33
3 files changed, 83 insertions, 0 deletions
diff --git a/japanese/navi2ch-emacs20/Makefile b/japanese/navi2ch-emacs20/Makefile
index 4cccc05c7e6d..877eaf3305a8 100644
--- a/japanese/navi2ch-emacs20/Makefile
+++ b/japanese/navi2ch-emacs20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= navi2ch
PORTVERSION= 1.6.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= japanese www elisp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
diff --git a/japanese/navi2ch-emacs20/files/patch-navi2ch-multibbs.el b/japanese/navi2ch-emacs20/files/patch-navi2ch-multibbs.el
new file mode 100644
index 000000000000..8b652e976bee
--- /dev/null
+++ b/japanese/navi2ch-emacs20/files/patch-navi2ch-multibbs.el
@@ -0,0 +1,49 @@
+Index: navi2ch-multibbs.el
+===================================================================
+RCS file: /cvsroot/navi2ch/navi2ch/navi2ch-multibbs.el,v
+retrieving revision 1.20
+diff -u -u -r1.20 navi2ch-multibbs.el
+--- navi2ch-multibbs.el 15 Dec 2002 04:23:00 -0000 1.20
++++ navi2ch-multibbs.el 23 Mar 2003 09:16:07 -0000
+@@ -32,6 +32,7 @@
+ (defvar navi2ch-multibbs-ident
+ "$Id: navi2ch-multibbs.el,v 1.20 2002/12/15 04:23:00 nanashi Exp $")
+
++(require 'navi2ch-http-date)
+ (require 'navi2ch)
+
+ (defvar navi2ch-multibbs-func-alist nil
+@@ -221,6 +222,18 @@
+ board 'article-to-url 'navi2ch-2ch-article-to-url)))
+ (funcall func board article start end nofirst)))
+
++(defun navi2ch-multibbs-get-message-time-field ()
++ (if (stringp navi2ch-net-last-date)
++ (navi2ch-http-date-decode navi2ch-net-last-date)
++ (let* ((now (current-time))
++ (lag 300) ; ずらす秒数
++ (h (nth 0 now))
++ (l (- (nth 1 now) lag)))
++ (when (< l 0)
++ (setq l (+ l 65536)
++ h (- h 0)))
++ (cons h l))))
++
+ (defun navi2ch-multibbs-send-message
+ (from mail message subject board article)
+ (let* ((bbstype (navi2ch-multibbs-get-bbstype board))
+@@ -236,12 +249,8 @@
+ (string-match "\\([^/]+\\)/$" uri)
+ (match-string 1 uri)))
+ (key (cdr (assq 'artid article)))
+- (time (mapconcat 'int-to-string
+- (let ((time (current-time)))
+- (navi2ch-bigint-add
+- (navi2ch-bigint-multiply
+- (nth 0 time) (expt 2 16)) (nth 1 time)))
+- ""))
++ (time (format-time-string
++ "%s" (navi2ch-multibbs-get-message-time-field)))
+ (navi2ch-net-http-proxy (and navi2ch-net-send-message-use-http-proxy
+ navi2ch-net-http-proxy))
+ (tries 2) ; 送信試行の最大回数
diff --git a/japanese/navi2ch-emacs20/files/patch-navi2ch-net.el b/japanese/navi2ch-emacs20/files/patch-navi2ch-net.el
new file mode 100644
index 000000000000..a1311a561b12
--- /dev/null
+++ b/japanese/navi2ch-emacs20/files/patch-navi2ch-net.el
@@ -0,0 +1,33 @@
+Index: navi2ch-net.el
+===================================================================
+RCS file: /cvsroot/navi2ch/navi2ch/navi2ch-net.el,v
+retrieving revision 1.66
+diff -u -u -r1.66 navi2ch-net.el
+--- navi2ch-net.el 15 Dec 2002 04:23:00 -0000 1.66
++++ navi2ch-net.el 23 Mar 2003 09:16:29 -0000
+@@ -34,6 +34,7 @@
+ (defvar navi2ch-net-connection-name "navi2ch connection")
+ (defvar navi2ch-net-user-agent "Monazilla/1.00 Navi2ch")
+ (defvar navi2ch-net-setting-file-name "SETTING.TXT")
++(defvar navi2ch-net-last-date nil)
+ (defvar navi2ch-net-last-url nil)
+ (defvar navi2ch-net-process nil)
+ (defvar navi2ch-net-last-host nil)
+@@ -250,6 +251,9 @@
+ (while (re-search-forward "^\\([^\r\n:]+\\): \\(.+\\)\r\n" end t)
+ (setq list (cons (cons (match-string 1) (match-string 2))
+ list)))
++ (let ((date (assoc-ignore-case "Date" list)))
++ (when (and date (stringp (cdr date)))
++ (setq navi2ch-net-last-date (cdr date))))
+ (setq navi2ch-net-header (nreverse list))))))))
+
+ (defun navi2ch-net-get-content-subr-with-temp-file (gzip-p start end)
+@@ -378,6 +382,7 @@
+ (cons "Pragma" "no-cache")
+ (and time (cons "If-Modified-Since" time)))
+ (and navi2ch-net-accept-gzip
++ (not (assoc "Range" other-header))
+ '("Accept-Encoding" . "gzip"))
+ (and navi2ch-net-user-agent
+ (cons "User-Agent" navi2ch-net-user-agent)))