aboutsummaryrefslogtreecommitdiff
path: root/japanese/nethack34/files
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/nethack34/files')
-rw-r--r--japanese/nethack34/files/patch-aa11
-rw-r--r--japanese/nethack34/files/patch-ab13
-rw-r--r--japanese/nethack34/files/patch-ac29
-rw-r--r--japanese/nethack34/files/patch-ad119
-rw-r--r--japanese/nethack34/files/patch-ae51
-rw-r--r--japanese/nethack34/files/patch-af41
-rw-r--r--japanese/nethack34/files/patch-ag21
-rw-r--r--japanese/nethack34/files/patch-ai10
-rw-r--r--japanese/nethack34/files/patch-ja14
9 files changed, 0 insertions, 309 deletions
diff --git a/japanese/nethack34/files/patch-aa b/japanese/nethack34/files/patch-aa
deleted file mode 100644
index f2a04b1adca2..000000000000
--- a/japanese/nethack34/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/config.h.orig Mon Feb 9 11:56:31 2004
-+++ include/config.h Mon Feb 9 11:59:57 2004
-@@ -222,7 +222,7 @@
- * otherwise it will be the current directory.
- */
- # ifndef HACKDIR
--# define HACKDIR "/usr/games/lib/jnethackdir"
-+# define HACKDIR "%%HACKDIR%%"
- # endif
-
- /*
diff --git a/japanese/nethack34/files/patch-ab b/japanese/nethack34/files/patch-ab
deleted file mode 100644
index d3ee0e028d96..000000000000
--- a/japanese/nethack34/files/patch-ab
+++ /dev/null
@@ -1,13 +0,0 @@
---- include/system.h.orig Sat Aug 30 09:07:23 2003
-+++ include/system.h Tue Sep 2 00:39:39 2003
-@@ -79,7 +79,9 @@
- # if !defined(__SC__) && !defined(LINUX)
- E long NDECL(random);
- # endif
--# if (!defined(SUNOS4) && !defined(bsdi) && !defined(__FreeBSD__)) || defined(RANDOM)
-+# if defined(__FreeBSD__)
-+E void FDECL(srandom, (unsigned long));
-+# elif (!defined(SUNOS4) && !defined(bsdi) && !defined(__FreeBSD__)) || defined(RANDOM)
- E void FDECL(srandom, (unsigned int));
- # else
- # if !defined(bsdi) && !defined(__FreeBSD__)
diff --git a/japanese/nethack34/files/patch-ac b/japanese/nethack34/files/patch-ac
deleted file mode 100644
index 7b5e921048b7..000000000000
--- a/japanese/nethack34/files/patch-ac
+++ /dev/null
@@ -1,29 +0,0 @@
---- include/unixconf.h.orig Mon Feb 9 12:02:12 2004
-+++ include/unixconf.h Mon Feb 9 12:02:48 2004
-@@ -19,7 +19,7 @@
- */
-
- /* define exactly one of the following four choices */
--/* #define BSD 1 */ /* define for 4.n/Free/Open/Net BSD */
-+#define BSD 1 /* define for 4.n/Free/Open/Net BSD */
- /* also for relatives like SunOS 4.x, DG/UX, and */
- /* older versions of Linux */
- /* #define ULTRIX */ /* define for Ultrix v3.0 or higher (but not lower) */
-@@ -143,7 +143,7 @@
- * A stat system call is done on the mailbox every MAILCKFREQ moves.
- */
-
--#define MAIL /* Deliver mail during the game */
-+/* #define MAIL */ /* Deliver mail during the game */
-
- /* The Andrew Message System does mail a little differently from normal
- * UNIX. Mail is deposited in the user's own directory in ~/Mailbox
-@@ -284,7 +284,7 @@
- #endif
-
- #if defined(BSD) || defined(ULTRIX)
--# if !defined(DGUX) && !defined(SUNOS4)
-+# if !defined(DGUX) && !defined(SUNOS4) && !defined(__FreeBSD__)
- #define memcpy(d, s, n) bcopy(s, d, n)
- #define memcmp(s1, s2, n) bcmp(s2, s1, n)
- # endif
diff --git a/japanese/nethack34/files/patch-ad b/japanese/nethack34/files/patch-ad
deleted file mode 100644
index 7231626085ea..000000000000
--- a/japanese/nethack34/files/patch-ad
+++ /dev/null
@@ -1,119 +0,0 @@
---- sys/unix/Makefile.src.orig Mon Feb 9 12:10:20 2004
-+++ sys/unix/Makefile.src Mon Feb 9 12:11:52 2004
-@@ -149,19 +149,29 @@
- # directories. The ones given below is the usual spot for linux systems.
- # The paths are for glibconfig.h and gnomesupport.h respectively.
- #
--GNOMEINC=-I/usr/lib/glib/include -I/usr/lib/gnome-libs/include -I../win/gnome
-+GNOMEINC= $(shell ${GNOME_CONFIG} --cflags gnomeui)
-
- # flags for debugging:
- # CFLAGS = -g -I../include
-
--CFLAGS = -W -g -O -I../include
-+CFLAGS += -I../include
-+ifeq ("$(GRAPHICS)","X11_GRAPHICS")
-+CFLAGS += -DX11_GRAPHICS -I${LOCALBASE}/include
-+endif
-+ifeq ("$(GRAPHICS)","QT_GRAPHICS")
-+CFLAGS += -DQT_GRAPHICS
-+endif
-+ifeq ("$(GRAPHICS)","GNOME_GRAPHICS")
-+CFLAGS += -DGNOME_GRAPHICS ${CPPFLAGS}
-+endif
-+
- LFLAGS =
-
- # The Qt and Be window systems are written in C++, while the rest of
- # NetHack is standard C. If using Qt, uncomment the LINK line here to get
- # the C++ libraries linked in.
--CXXFLAGS = $(CFLAGS) -I. -I$(QTDIR)/include
--CXX=g++
-+CXXFLAGS += -I. -I../include ${QTCPPFLAGS}
-+#CXX=g++
- #LINK=g++
- # For cross-compiling, eg. with gcc on Linux (see also CC further up):
- #CXX=arm-linux-g++
-@@ -228,7 +238,26 @@
- #
- #
- WINSRC = $(WINTTYSRC)
-+ifeq ("$(GRAPHICS)","X11_GRAPHICS")
-+WINSRC += $(WINX11SRC)
-+endif
-+ifeq ("$(GRAPHICS)","QT_GRAPHICS")
-+WINSRC += $(WINQTSRC)
-+endif
-+ifeq ("$(GRAPHICS)","GNOME_GRAPHICS")
-+WINSRC += $(WINGNOMESRC)
-+endif
-+
- WINOBJ = $(WINTTYOBJ)
-+ifeq ("$(GRAPHICS)","X11_GRAPHICS")
-+WINOBJ += $(WINX11OBJ)
-+endif
-+ifeq ("$(GRAPHICS)","QT_GRAPHICS")
-+WINOBJ += $(WINQTOBJ)
-+endif
-+ifeq ("$(GRAPHICS)","GNOME_GRAPHICS")
-+WINOBJ += $(WINGNOMEOBJ)
-+endif
-
- # on some systems the termcap library is in -ltermcap or -lcurses
- # on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
-@@ -248,19 +277,19 @@
- #
- # libraries for X11
- # If USE_XPM is defined in config.h, you will also need -lXpm here.
--WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
-+WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -L${LOCALBASE}/lib
- # WINX11LIB = -lXaw -lXmu -lXt -lX11
- # WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
- # WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
- #
- # libraries for Qt
--WINQTLIB = -L$(QTDIR)/lib -lqt
-+WINQTLIB = ${QTCFGLIBS} ${LIBQT} -lgnuregex
- #
- # libraries for KDE (with Qt)
- WINKDELIB = -lkdecore -lkdeui -lXext
- #
- # libraries for Gnome
--WINGNOMELIB = -lgnomeui -lgnome -lart_lgpl -lgtk -lgdk -lpopt
-+WINGNOMELIB = $(shell ${GNOME_CONFIG} --libs gnomeui) ${LDFLAGS}
- #
- # libraries for Gem port
- WINGEMLIB = -le_gem -lgem
-@@ -269,6 +298,15 @@
- WINBELIB = -lbe
-
- WINLIB = $(WINTTYLIB)
-+ifeq ("$(GRAPHICS)","X11_GRAPHICS")
-+WINLIB += $(WINX11LIB)
-+endif
-+ifeq ("$(GRAPHICS)","QT_GRAPHICS")
-+WINLIB += $(WINQTLIB)
-+endif
-+ifeq ("$(GRAPHICS)","GNOME_GRAPHICS")
-+WINLIB += $(WINGNOMELIB)
-+endif
-
- # any other strange libraries your system needs (for Sysunix only -- the more
- # specialized targets should already be right)
-@@ -478,13 +516,13 @@
-
- # Qt windowport meta-object-compiler output
- qt_kde0.moc: ../include/qt_kde0.h
-- $(QTDIR)/bin/moc -o qt_kde0.moc ../include/qt_kde0.h
-+ ${MOC} -o qt_kde0.moc ../include/qt_kde0.h
-
- qt_win.moc: ../include/qt_win.h
-- $(QTDIR)/bin/moc -o qt_win.moc ../include/qt_win.h
-+ ${MOC} -o qt_win.moc ../include/qt_win.h
-
- qttableview.moc: ../include/qttableview.h
-- $(QTDIR)/bin/moc -o qttableview.moc ../include/qttableview.h
-+ ${MOC} -o qttableview.moc ../include/qttableview.h
-
- $(MAKEDEFS): ../util/makedefs.c $(CONFIG_H) ../include/permonst.h \
- ../include/objclass.h ../include/monsym.h \
diff --git a/japanese/nethack34/files/patch-ae b/japanese/nethack34/files/patch-ae
deleted file mode 100644
index 02b54ebe6d66..000000000000
--- a/japanese/nethack34/files/patch-ae
+++ /dev/null
@@ -1,51 +0,0 @@
---- sys/unix/Makefile.top.orig Mon Feb 9 12:12:22 2004
-+++ sys/unix/Makefile.top Mon Feb 9 12:13:05 2004
-@@ -14,18 +14,17 @@
- # MAKE = make
-
- # make NetHack
--PREFIX = /usr
--GAME = jnethack
-+GAME = %%HACKNAME%%
- # GAME = nethack.prg
- GAMEUID = games
--GAMEGRP = bin
-+GAMEGRP = games
-
- # Permissions - some places use setgid instead of setuid, for instance
- # See also the option "SECURE" in include/config.h
--GAMEPERM = 04755
--FILEPERM = 0644
-+GAMEPERM = 02755
-+FILEPERM = 0664
- EXEPERM = 0755
--DIRPERM = 0755
-+DIRPERM = 0775
-
- # GAMEDIR also appears in config.h as "HACKDIR".
- # VARDIR may also appear in unixconf.h as "VAR_PLAYGROUND" else GAMEDIR
-@@ -35,12 +34,12 @@
- # therefore there should not be anything in GAMEDIR that you want to keep
- # (if there is, you'll have to do the installation by hand or modify the
- # instructions)
--GAMEDIR = $(PREFIX)/games/lib/$(GAME)dir
-+GAMEDIR = %%HACKDIR%%
- VARDIR = $(GAMEDIR)
--SHELLDIR = $(PREFIX)/games
-+SHELLDIR = $(PREFIX)/bin
-
- # per discussion in Install.X11 and Install.Qt
--VARDATND =
-+# VARDATND =
- # VARDATND = x11tiles NetHack.ad pet_mark.xbm
- # VARDATND = x11tiles NetHack.ad pet_mark.xbm rip.xpm
- # for Atari/Gem
-@@ -48,7 +47,7 @@
- # for BeOS
- # VARDATND = beostiles
- # for Gnome
--# VARDATND = x11tiles pet_mark.xbm rip.xpm mapbg.xpm
-+VARDATND = x11tiles pet_mark.xbm rip.xpm mapbg.xpm
-
- VARDATD = data joracles options quest.dat jrumors
- VARDAT = $(VARDATD) $(VARDATND)
diff --git a/japanese/nethack34/files/patch-af b/japanese/nethack34/files/patch-af
deleted file mode 100644
index 9a7b5f4fe852..000000000000
--- a/japanese/nethack34/files/patch-af
+++ /dev/null
@@ -1,41 +0,0 @@
---- sys/unix/Makefile.doc.orig Sun Jun 16 03:02:10 2002
-+++ sys/unix/Makefile.doc Sun Jun 16 03:15:50 2002
-@@ -38,15 +38,15 @@
-
-
- GAME = nethack
--MANDIR = /usr/local/man/man6
-+MANDIR = ${PREFIX}/man/man
- MANEXT = 6
-
- # manual installation for most BSD-style systems
--GAMEMANCREATE = cp nethack.6
--LEVMANCREATE = cp lev_comp.6
--DGNMANCREATE = cp dgn_comp.6
--RCVRMANCREATE = cp recover.6
--DLBMANCREATE = cp dlb.6
-+GAMEMANCREATE = ${BSD_INSTALL_MAN} nethack.6
-+LEVMANCREATE = ${BSD_INSTALL_MAN} lev_comp.6
-+DGNMANCREATE = ${BSD_INSTALL_MAN} dgn_comp.6
-+RCVRMANCREATE = ${BSD_INSTALL_MAN} recover.6
-+DLBMANCREATE = ${BSD_INSTALL_MAN} dlb.6
- # manual installation for most SYSV-style systems
- # GAMEMANCREATE = nroff -man nethack.6 >
- # LEVMANCREATE = nroff -man lev_comp.6 >
-@@ -55,11 +55,11 @@
- # DLBMANCREATE = nroff -man dlb.6 >
-
- manpages:
-- -$(GAMEMANCREATE) $(MANDIR)/$(GAME).$(MANEXT)
-- -$(LEVMANCREATE) $(MANDIR)/lev_comp.$(MANEXT)
-- -$(DGNMANCREATE) $(MANDIR)/dgn_comp.$(MANEXT)
-- -$(RCVRMANCREATE) $(MANDIR)/recover.$(MANEXT)
-- -$(DLBMANCREATE) $(MANDIR)/dlb.$(MANEXT)
-+ -$(GAMEMANCREATE) $(MANDIR)$(MANEXT)/$(GAME).$(MANEXT)
-+ -$(LEVMANCREATE) $(MANDIR)$(MANEXT)/lev_comp.$(MANEXT)
-+ -$(DGNMANCREATE) $(MANDIR)$(MANEXT)/dgn_comp.$(MANEXT)
-+ -$(RCVRMANCREATE) $(MANDIR)$(MANEXT)/recover.$(MANEXT)
-+ -$(DLBMANCREATE) $(MANDIR)$(MANEXT)/dlb.$(MANEXT)
-
- # manual creation for distribution
- DISTRIB = Guidebook.txt nethack.txt lev_comp.txt dgn_comp.txt recover.txt dlb.txt
diff --git a/japanese/nethack34/files/patch-ag b/japanese/nethack34/files/patch-ag
deleted file mode 100644
index 56aed0a0e35b..000000000000
--- a/japanese/nethack34/files/patch-ag
+++ /dev/null
@@ -1,21 +0,0 @@
---- sys/unix/Makefile.utl.orig Sun Jun 16 03:02:10 2002
-+++ sys/unix/Makefile.utl Sun Jun 16 03:13:16 2002
-@@ -89,7 +89,17 @@
- # flags for debugging:
- # CFLAGS = -g -I../include
-
--CFLAGS = -O -I../include
-+CFLAGS += -I../include
-+ifeq ("$(GRAPHICS)","X11_GRAPHICS")
-+CFLAGS += -DX11_GRAPHICS
-+endif
-+ifeq ("$(GRAPHICS)","QT_GRAPHICS")
-+CFLAGS += -DQT_GRAPHICS
-+endif
-+ifeq ("$(GRAPHICS)","GNOME_GRAPHICS")
-+CFLAGS += -DGNOME_GRAPHICS
-+endif
-+
- LFLAGS =
-
- LIBS =
diff --git a/japanese/nethack34/files/patch-ai b/japanese/nethack34/files/patch-ai
deleted file mode 100644
index 508c236b9e7c..000000000000
--- a/japanese/nethack34/files/patch-ai
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/files.c.orig Sun Feb 23 23:43:26 2003
-+++ src/files.c Thu Jun 19 11:51:59 2003
-@@ -29,6 +29,7 @@
- #endif
-
- #if defined(UNIX) && defined(QT_GRAPHICS)
-+#include <limits.h>
- #include <dirent.h>
- #endif
-
diff --git a/japanese/nethack34/files/patch-ja b/japanese/nethack34/files/patch-ja
deleted file mode 100644
index 9b865d411e2a..000000000000
--- a/japanese/nethack34/files/patch-ja
+++ /dev/null
@@ -1,14 +0,0 @@
---- include/winX.h.orig Sun Jun 16 13:15:58 2002
-+++ include/winX.h Sun Jun 16 13:21:39 2002
-@@ -378,11 +378,7 @@
- E void FDECL(clear_text_buffer,(struct text_buffer*));
- E void FDECL(free_text_buffer,(struct text_buffer*));
- #ifdef GRAPHIC_TOMBSTONE
--#ifndef XI18N
- E void FDECL(calculate_rip_text, (int));
--#else
--E void FDECL(calculate_rip_text, (int, XFontSet));
--#endif
- #endif
-
-