aboutsummaryrefslogtreecommitdiff
path: root/japanese/okphone/files/patch-aa
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/okphone/files/patch-aa')
-rw-r--r--japanese/okphone/files/patch-aa88
1 files changed, 2 insertions, 86 deletions
diff --git a/japanese/okphone/files/patch-aa b/japanese/okphone/files/patch-aa
index 478146aff9de..7c9afc7d59f2 100644
--- a/japanese/okphone/files/patch-aa
+++ b/japanese/okphone/files/patch-aa
@@ -5,7 +5,7 @@
CC = cc
-CFLAGS = -O
-+CFLAGS +=
++CFLAGS += -O
SRCS = convd.c
DEST = convd
-RDEST = /usr/local/etc/convd
@@ -18,91 +18,7 @@
install: ${DEST}
/bin/rm -f ${RDEST}
- cp ${DEST} ${RDEST}
-+ install -cs ${DEST} ${RDEST}
++ install -cs -m 755 -o bin -g bin ${DEST} ${RDEST}
clean:
/bin/rm -f ${DEST} core *.o
---- ./client/Makefile.org Wed Feb 7 18:45:34 1996
-+++ ./client/Makefile Wed Feb 7 18:45:36 1996
-@@ -20,14 +20,14 @@
- CC = cc
- #CFLAGS = -O -DSERVICES -DLOCAL_ECHO
- #CFLAGS = -g -DSERVICES -DLOCAL_ECHO
--CFLAGS = -Isw -O -DSERVICES -DLOCAL_ECHO
-+CFLAGS += -Isw -DSERVICES -DLOCAL_ECHO
- #LIBS = -lcurses -ltermlib #-lresolv
- LIBS = sw/libsw.a -ltermlib -ll
-
- LPR = lpr -Psony
- #RDEST = /usr/ucb/phone
- #RDEST = /usr/local/phone
--RDEST = /usr/local/bin/phone
-+RDEST = ${PREFIX}/bin/phone
-
- HDRS = defs.h
-
-@@ -69,7 +69,7 @@
-
- install: ${DEST}
- /bin/rm -f ${RDEST}
-- cp ${DEST} ${RDEST}
-+ install -cs ${DEST} ${RDEST}
-
- print: ${HDRS} ${SRCS}
- pr -f ${HDRS} ${SRCS} | expand -4 | ${LPR}
---- ./master/Makefile.org Wed Feb 7 18:45:36 1996
-+++ ./master/Makefile Wed Feb 7 18:45:36 1996
-@@ -29,7 +29,7 @@
- #CFLAGS = -O -DSERVICES -DDPATH=\"$(CONVD)\" -DFORK
- #CFLAGS = -O -DINETD -DDPATH=\"$(CONVD)\"
- #CFLAGS = -O -DINETD -DDPATH=\"$(CONVD)\" -DSERVICES
--CFLAGS = $(OFLAG) $(INETD) -DFORK -DSERVICES -DDPATH=\"/usr/local/etc/convd\"
-+CFLAGS += $(INETD) -DFORK -DSERVICES -DDPATH=\"${PREFIX}/libexec/convd\"
-
- LPR = lpr -Psony
- CC = cc
-@@ -44,7 +44,7 @@
- reinvite.o strsave.o utmp.o
-
- DEST = phoned
--RDEST = /usr/local/etc/in.phoned
-+RDEST = ${PREFIX}/libexec/phoned
- #RDEST = /etc/phoned
-
-
-@@ -61,7 +61,7 @@
-
- install: ${DEST}
- /bin/rm -f ${RDEST}
-- cp ${DEST} ${RDEST}
-+ install -cs ${DEST} ${RDEST}
-
- clean:
- /bin/rm -f ${DEST} core *.o
---- ./Makefile.org Fri Dec 15 01:30:07 1989
-+++ ./Makefile Wed Feb 7 20:39:53 1996
-@@ -13,3 +13,13 @@
- done
-
- default: all
-+
-+install:
-+ /bin/rm -f ${PREFIX}/man/man1/phone.1*
-+ install -c phone.1 ${PREFIX}/man/man1
-+ gzip -9nf ${PREFIX}/man/man1/phone.1
-+ mkdir -p ${PREFIX}/share/okphone
-+ install -c NOTE READ_ME Readme.kana ${PREFIX}/share/okphone
-+ for i in ${DIRS} ; do \
-+ cd $$i ; make MFLAGS="${MFLAGS}" $@ ; cd .. ; \
-+ done
---- ./client/sw/Makefile.org Fri Dec 15 01:30:11 1989
-+++ ./client/sw/Makefile Wed Feb 7 20:57:50 1996
-@@ -1,7 +1,7 @@
- # $Header: /home/ncvs/ports/japanese/okphone/patches/patch-aa,v 1.2 1996/02/08 05:01:24 asami Exp $
-
- #CFLAGS= -g -pg
--CFLAGS= -O
-+CFLAGS+=
- objs= winit.o wcreate.o woutput.o wredraw.o wput.o wclear.o wbox.o wbell.o\
- tosjis.o
- srcs= winit.c wcreate.c woutput.c wredraw.c wput.c wclear.c wbox.c wbell.c\