aboutsummaryrefslogtreecommitdiff
path: root/japanese/php5-mecab/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/php5-mecab/Makefile')
-rw-r--r--japanese/php5-mecab/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/japanese/php5-mecab/Makefile b/japanese/php5-mecab/Makefile
new file mode 100644
index 000000000000..03a80980dd0b
--- /dev/null
+++ b/japanese/php5-mecab/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: php5-mecab
+# Date created: 31 Aug 2006
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mecab
+PORTVERSION= 0.0.2
+CATEGORIES= japanese
+MASTER_SITES= http://page2.xrea.jp/pub/ \
+ http://dist.bsdlab.org/
+DISTNAME= php_mecab-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= A PHP5 extension for MeCab Morphological Analyzer
+
+LIB_DEPENDS= mecab:${PORTSDIR}/japanese/mecab
+
+USE_PHP= yes
+DEFAULT_PHP_VER=5
+USE_PHPEXT= yes
+CONFIGURE_ARGS= --with-mecab=${LOCALBASE}/bin/mecab-config
+
+.include <bsd.port.pre.mk>
+
+PKGNAMEPREFIX:= ${PKGNAMEPREFIX}php5-
+
+.include <bsd.port.post.mk>