aboutsummaryrefslogtreecommitdiff
path: root/japanese/ruby-mecab/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/ruby-mecab/Makefile')
-rw-r--r--japanese/ruby-mecab/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/japanese/ruby-mecab/Makefile b/japanese/ruby-mecab/Makefile
new file mode 100644
index 000000000000..d1c8f41d8178
--- /dev/null
+++ b/japanese/ruby-mecab/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: ruby-mecab
+# Date created: 23 April 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${MECAB_PORTNAME}
+PORTVERSION= ${MECAB_PORTVERSION}
+CATEGORIES= japanese textproc ruby
+MASTER_SITES= # none
+DISTFILES= # none
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= MeCab library module for Ruby
+
+EXTRACT_DEPENDS= ${NONEXISTENT}:${MECAB_PORTDIR}:patch
+LIB_DEPENDS= mecab.0:${MECAB_PORTDIR}
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+RUBY_WITH_PTHREAD= yes
+
+.include "${.CURDIR}/../mecab/Makefile.common"
+
+.include <bsd.port.pre.mk>
+
+PKGNAMEPREFIX:= ${PKGNAMEPREFIX}${RUBY_PKGNAMEPREFIX}
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${LN} -fs `${MECAB_WRKSRC_CMD}`/ruby ${WRKSRC}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/examples/mecab
+ ${INSTALL_DATA} ${WRKSRC}/test.rb ${PREFIX}/share/examples/mecab/
+.endif
+
+.include <bsd.port.post.mk>