aboutsummaryrefslogtreecommitdiff
path: root/japanese/samba
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/samba')
-rw-r--r--japanese/samba/Makefile1
-rw-r--r--japanese/samba/files/patch-eb19
2 files changed, 20 insertions, 0 deletions
diff --git a/japanese/samba/Makefile b/japanese/samba/Makefile
index a9df9a128ab6..96a7c11bb549 100644
--- a/japanese/samba/Makefile
+++ b/japanese/samba/Makefile
@@ -7,6 +7,7 @@
PORTNAME= samba
PORTVERSION= ${SAMBA_VERSION}.j${SAMBA_JA_VERSION}
+PORTREVISION= 1
CATEGORIES= japanese net
MASTER_SITES= ftp://ftp.samba.gr.jp/pub/samba-jp/%SUBDIR%/ \
ftp://ftp.iij.ad.jp/pub/SAMBA/samba-jp/%SUBDIR%/ \
diff --git a/japanese/samba/files/patch-eb b/japanese/samba/files/patch-eb
new file mode 100644
index 000000000000..f30e3acc7cf9
--- /dev/null
+++ b/japanese/samba/files/patch-eb
@@ -0,0 +1,19 @@
+--- smbd/reply.c.orig Fri May 4 04:11:44 2001
++++ smbd/reply.c Mon Jul 2 13:11:28 2001
+@@ -101,6 +101,7 @@
+ trim_string( remote_machine, strlen( remote_machine )+1,
+ " ", sizeof( " " ), " ", sizeof( " " ));
+ strlower(remote_machine);
++ alpha_strcpy(remote_machine,remote_machine,sizeof(remote_machine)-1);
+
+ fstrcpy(local_machine,name1);
+ len = strlen(local_machine);
+@@ -111,6 +112,7 @@
+ trim_string( local_machine, strlen( local_machine )+1,
+ " ", sizeof( " " ), " ", sizeof( " " ));
+ strlower(local_machine);
++ alpha_strcpy(local_machine,local_machine,sizeof(local_machine)-1);
+
+ if (name_type == 'R') {
+ /* We are being asked for a pathworks session ---
+