aboutsummaryrefslogtreecommitdiff
path: root/japanese/tk80/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/tk80/Makefile')
-rw-r--r--japanese/tk80/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/japanese/tk80/Makefile b/japanese/tk80/Makefile
index 802fe6b03974..08f1f700bc08 100644
--- a/japanese/tk80/Makefile
+++ b/japanese/tk80/Makefile
@@ -3,7 +3,7 @@
# Date created: 26 Dec 1997
# Whom: taguchi@tohoku.iij.ad.jp
#
-# $Id: Makefile,v 1.7 1998/09/28 15:15:11 kuriyama Exp $
+# $Id: Makefile,v 1.8 1998/11/02 03:47:50 steve Exp $
#
DISTNAME= tk8.0.3
@@ -31,6 +31,8 @@ USE_AUTOCONF= yes
USE_XLIB= yes
CONFIGURE_ARGS= --enable-shared --with-tcl=${PREFIX}/lib/tcl${VERSION}jp
+.include <bsd.port.pre.mk>
+
.if !defined(NOPORTDOCS)
post-patch:
@${CP} ${FILESDIR}/README.FreeBSD.in ${TOPDIR}/README.FreeBSD.JP.in
@@ -50,9 +52,9 @@ post-install:
)
.endif
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
- if [ "${PORTOBJFORMAT}" = "aout" ]; then \
- ${LN} -sf libtk80jp.so.1.2 ${PREFIX}/lib/libtk80jp.so; \
- fi
+.if ${PORTOBJFORMAT} == "aout"
+ ${LN} -sf libtk80jp.so.1.2 ${PREFIX}/lib/libtk80jp.so
+.endif
@${CAT} ${PKGDIR}/MESSAGE
test:
@@ -61,4 +63,4 @@ test:
install-man:
cd ${WRKSRC} && ${MAKE} install-man
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>