aboutsummaryrefslogtreecommitdiff
path: root/japanese/uim-prime/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/uim-prime/Makefile')
-rw-r--r--japanese/uim-prime/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/japanese/uim-prime/Makefile b/japanese/uim-prime/Makefile
new file mode 100644
index 000000000000..a103a0af28d0
--- /dev/null
+++ b/japanese/uim-prime/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: ja-uim-prime
+# Date created: 31 August 2003
+# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= japanese
+PKGNAMESUFFIX= -prime
+
+COMMENT= Uim plugin using PRIME input method
+
+RUN_DEPENDS= uim-module-manager:${PORTSDIR}/textproc/uim
+BUILD_DEPENDS= prime:${PORTSDIR}/japanese/prime
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+MASTERDIR= ${.CURDIR}/../../textproc/uim
+PKGDIR= ${.CURDIR}
+CONFIGURE_ARGS= --with-prime
+
+UIM_SLAVE= yes
+
+do-install:
+ cd ${WRKSRC}/uim && \
+ ${GMAKE} uim_plugin_LTLIBRARIES=libuim-prime.la install-uim_pluginLTLIBRARIES
+
+post-install:
+ uim-module-manager --register prime
+
+.include "${MASTERDIR}/Makefile"