aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
Diffstat (limited to 'japanese')
-rw-r--r--japanese/dvipsk/Makefile2
-rw-r--r--japanese/eijiro-fpw/Makefile3
-rw-r--r--japanese/emacs-emcws/Makefile2
-rw-r--r--japanese/groff/Makefile3
-rw-r--r--japanese/mendexk-euc/Makefile2
-rw-r--r--japanese/mozc-server/Makefile4
-rw-r--r--japanese/nethack34/Makefile3
-rw-r--r--japanese/ptex/Makefile2
-rw-r--r--japanese/scim-tables/Makefile3
-rw-r--r--japanese/tex-ptex/Makefile3
-rw-r--r--japanese/waeijiro-fpw/Makefile3
-rw-r--r--japanese/xdvik/Makefile2
12 files changed, 12 insertions, 20 deletions
diff --git a/japanese/dvipsk/Makefile b/japanese/dvipsk/Makefile
index c2b4e5d7ee21..577453f4b50c 100644
--- a/japanese/dvipsk/Makefile
+++ b/japanese/dvipsk/Makefile
@@ -39,7 +39,7 @@ PLIST_SUB= DVIPSDIR=${DVIPSDIR} \
FONTSMAPDIR=${FONTSMAPDIR} \
UPDMAP_SYS="${UPDMAP_SYS}"
USE_TEX= tetex base texmf
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-multiplatform \
--without-texinfo \
diff --git a/japanese/eijiro-fpw/Makefile b/japanese/eijiro-fpw/Makefile
index c3e1a35b4fcf..0b93044db3f4 100644
--- a/japanese/eijiro-fpw/Makefile
+++ b/japanese/eijiro-fpw/Makefile
@@ -17,8 +17,7 @@ BUILD_DEPENDS= ${LOCALBASE}/libexec/freepwing/catdump:${PORTSDIR}/japanese/freep
MANUAL_PACKAGE_BUILD=Needs data from CDROM
RESTRICTED= The original dictionary is not free
-USES= perl5
-USE_GMAKE= yes
+USES= perl5 gmake
MAKE_JOBS_UNSAFE=yes
WRKSRC= ${WRKDIR}/eijiro-fpw${PORTVERSION}
DICT_PATH?= /cdrom
diff --git a/japanese/emacs-emcws/Makefile b/japanese/emacs-emcws/Makefile
index 9b0d33c191b0..d024a85cad3c 100644
--- a/japanese/emacs-emcws/Makefile
+++ b/japanese/emacs-emcws/Makefile
@@ -34,7 +34,7 @@ CONFLICTS= emacs-19.* emacs-20.* emacs-22.* \
WRKSRC= ${WRKDIR}/emacs-${EMACS_VER}
USE_AUTOTOOLS= autoconf213
-USE_GMAKE= YES
+USES= gmake
# Change these as you like.
WITH_WNN6?= NO
diff --git a/japanese/groff/Makefile b/japanese/groff/Makefile
index a2a8b54ed3e9..ca2e05f4ec58 100644
--- a/japanese/groff/Makefile
+++ b/japanese/groff/Makefile
@@ -20,8 +20,7 @@ LICENSE= GPLv2
USE_GCC= any
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= iconv:wchar_t
+USES= iconv:wchar_t gmake
CONFIGURE_ARGS= --enable-multibyte
CONFIGURE_ENV= INSTALL_MAN="${INSTALL_MAN}" \
diff --git a/japanese/mendexk-euc/Makefile b/japanese/mendexk-euc/Makefile
index 0ecf70f41d9a..16369e55d47d 100644
--- a/japanese/mendexk-euc/Makefile
+++ b/japanese/mendexk-euc/Makefile
@@ -20,7 +20,7 @@ CONFIGURE_ENV= INSTALL_MAN="${INSTALL_MAN}" \
INSTALL_PROGRAM="${INSTALL_PROGRAM}"
MAKE_ENV= INSTALL_MAN="${INSTALL_MAN}" \
INSTALL_PROGRAM="${INSTALL_PROGRAM}"
-USE_GMAKE= yes
+USES= gmake
ALL_TARGET= mendex
MAN1= mendex.1
MANLANG= ja
diff --git a/japanese/mozc-server/Makefile b/japanese/mozc-server/Makefile
index 028d6a983ce0..4b98d0182f99 100644
--- a/japanese/mozc-server/Makefile
+++ b/japanese/mozc-server/Makefile
@@ -21,9 +21,7 @@ LIB_DEPENDS= protobuf:${PORTSDIR}/devel/protobuf \
zinnia:${PORTSDIR}/japanese/zinnia
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
-USES= pkgconfig iconv
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= pkgconfig iconv gmake tar:bzip2
USE_PYTHON_BUILD=yes
USE_OPENSSL= yes
diff --git a/japanese/nethack34/Makefile b/japanese/nethack34/Makefile
index 39a19211c6a7..837583f5bb11 100644
--- a/japanese/nethack34/Makefile
+++ b/japanese/nethack34/Makefile
@@ -19,8 +19,7 @@ COMMENT= Japanized NetHack
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= bison
-USE_GMAKE= yes
+USES= bison gmake
MAKE_ENV= GRAPHICS="${GRAPHICS}"
PLIST_SUB= HACKNAME="${HACKNAME}" \
HACKDIR="${HACKDIR}" \
diff --git a/japanese/ptex/Makefile b/japanese/ptex/Makefile
index b7ffa4910269..d9a2e4e75a31 100644
--- a/japanese/ptex/Makefile
+++ b/japanese/ptex/Makefile
@@ -34,7 +34,7 @@ CONFIGURE_ARGS= ${KANJICODE}
CONFIGURE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
INSTALL_DATA="${INSTALL_DATA}" \
INSTALL_PROGRAM="${INSTALL_PROGRAM}"
-USE_GMAKE= yes
+USES= gmake
.if make(do-build)
MAKE_ENV= TEXMFLOCALDIR=${WRKDIR}/ptex-texmf \
TEXMFDUMP=${LOCALBASE}/${TEXMFLOCALDIR} \
diff --git a/japanese/scim-tables/Makefile b/japanese/scim-tables/Makefile
index b54910ebc6f8..9f00492213de 100644
--- a/japanese/scim-tables/Makefile
+++ b/japanese/scim-tables/Makefile
@@ -13,8 +13,7 @@ COMMENT= SCIM table based Japanese input methods
BUILD_DEPENDS= scim-make-table:${PORTSDIR}/textproc/scim-table-imengine
RUN_DEPENDS= scim-make-table:${PORTSDIR}/textproc/scim-table-imengine
-USES= pkgconfig
-USE_GMAKE= yes
+USES= pkgconfig gmake
GNU_CONFIGURE= yes
NO_STAGE= yes
diff --git a/japanese/tex-ptex/Makefile b/japanese/tex-ptex/Makefile
index 7abb1b780892..f20681cefefd 100644
--- a/japanese/tex-ptex/Makefile
+++ b/japanese/tex-ptex/Makefile
@@ -15,8 +15,7 @@ EXTRACT_ONLY= texlive-${DISTVERSION_TEXLIVE}-source${EXTRACT_SUFX}
MAINTAINER= hrs@FreeBSD.org
COMMENT= ASCII Japanese pTeX
-USE_XZ= yes
-USE_GMAKE= yes
+USES= tar:xz gmake
USE_TEX= texlive kpathsea web2c ptexenc texmf formats fmtutil
EXTRACT_AFTER_ARGS= ${EXTRACT_FILES:S,^,${DISTNAME}/,}
EXTRACT_FILES= \
diff --git a/japanese/waeijiro-fpw/Makefile b/japanese/waeijiro-fpw/Makefile
index e1c526d4cb9f..81382ba9449b 100644
--- a/japanese/waeijiro-fpw/Makefile
+++ b/japanese/waeijiro-fpw/Makefile
@@ -18,8 +18,7 @@ BUILD_DEPENDS= ${LOCALBASE}/libexec/freepwing/catdump:${PORTSDIR}/japanese/freep
MANUAL_PACKAGE_BUILD=Needs data from a CDROM
RESTRICTED= The original dictionary is not free
-USES= perl5
-USE_GMAKE= yes
+USES= perl5 gmake
DICT_PATH?= /cdrom
SRCFILE?= waeiji52.txt
diff --git a/japanese/xdvik/Makefile b/japanese/xdvik/Makefile
index 40327193bb68..ad98fdace533 100644
--- a/japanese/xdvik/Makefile
+++ b/japanese/xdvik/Makefile
@@ -25,7 +25,7 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
DIST_SUBDIR= xdvik
USE_TEX= tetex base texmf
-USE_GMAKE= YES
+USES= gmake
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --datadir=${PREFIX}/${TEXMFDIR:S,texmf$,,} \
--enable-a4 --enable-shrink=${SHRINK} \