aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
Diffstat (limited to 'japanese')
-rw-r--r--japanese/ebview-gtk2/Makefile4
-rw-r--r--japanese/ebview/Makefile4
2 files changed, 6 insertions, 2 deletions
diff --git a/japanese/ebview-gtk2/Makefile b/japanese/ebview-gtk2/Makefile
index 2cbed02addf8..17c2cbfa1a19 100644
--- a/japanese/ebview-gtk2/Makefile
+++ b/japanese/ebview-gtk2/Makefile
@@ -16,6 +16,8 @@ COMMENT= Electronic Book Viewer
LIB_DEPENDS= eb.7:${PORTSDIR}/japanese/eb
+CONFLICTS= ja-ebview-gtk2-*
+
USE_GETOPT_LONG= yes
USE_GNOME= imlib
USE_GMAKE= yes
@@ -28,7 +30,7 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-pre-build:
+post-patch:
.for file in src/dictheading.c
cd ${WRKSRC} && ${MV} ${file} ${file}.pre_iconv \
&& iconv -c -t ascii ${file}.pre_iconv > ${file} || ${TRUE}
diff --git a/japanese/ebview/Makefile b/japanese/ebview/Makefile
index 2cbed02addf8..17c2cbfa1a19 100644
--- a/japanese/ebview/Makefile
+++ b/japanese/ebview/Makefile
@@ -16,6 +16,8 @@ COMMENT= Electronic Book Viewer
LIB_DEPENDS= eb.7:${PORTSDIR}/japanese/eb
+CONFLICTS= ja-ebview-gtk2-*
+
USE_GETOPT_LONG= yes
USE_GNOME= imlib
USE_GMAKE= yes
@@ -28,7 +30,7 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-pre-build:
+post-patch:
.for file in src/dictheading.c
cd ${WRKSRC} && ${MV} ${file} ${file}.pre_iconv \
&& iconv -c -t ascii ${file}.pre_iconv > ${file} || ${TRUE}