aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
Diffstat (limited to 'japanese')
-rw-r--r--japanese/xchat/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/japanese/xchat/Makefile b/japanese/xchat/Makefile
index 043fdef2d94c..9988373f16f1 100644
--- a/japanese/xchat/Makefile
+++ b/japanese/xchat/Makefile
@@ -8,7 +8,7 @@
PORTNAME= xchat
PORTVERSION= 1.4.3
PORTREVISION= 2
-CATEGORIES= japanese irc gnome ipv6
+CATEGORIES= japanese irc gnome
MASTER_SITES= http://xchat.org/files/source/1.4/ \
http://xchat.linuxpower.org/files/source/1.4/
@@ -27,7 +27,7 @@ PLIST= ${.CURDIR}/pkg-plist
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --enable-japanese-conv --enable-ipv6
+CONFIGURE_ARGS= --enable-japanese-conv
MAKE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -liconv -lintl"
@@ -44,6 +44,11 @@ CONFIGURE_ARGS+=--disable-python
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 400014
+CATEGORIES+= ipv6
+CONFIGURE_ARGS+=--enable-ipv6
+.endif
+
.if defined(WITH_SOCKS)
# Assign with `+=' for slave ports
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5