aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
Diffstat (limited to 'japanese')
-rw-r--r--japanese/bookview/Makefile2
-rw-r--r--japanese/eb/Makefile2
-rw-r--r--japanese/eb3/Makefile2
-rw-r--r--japanese/eblook/Makefile2
-rw-r--r--japanese/ebnetd/Makefile2
-rw-r--r--japanese/ebview/Makefile2
-rw-r--r--japanese/emacs-emcws/Makefile2
-rw-r--r--japanese/emacs20-dl-canna/Makefile2
-rw-r--r--japanese/emacs20-dl-wnn6/Makefile2
-rw-r--r--japanese/emacs20-emcws/Makefile2
-rw-r--r--japanese/iiimf-le-canna/Makefile2
-rw-r--r--japanese/iiimf-le-freewnn/Makefile2
-rw-r--r--japanese/perl5/Makefile2
13 files changed, 13 insertions, 13 deletions
diff --git a/japanese/bookview/Makefile b/japanese/bookview/Makefile
index 4d4f70ba5509..803876739987 100644
--- a/japanese/bookview/Makefile
+++ b/japanese/bookview/Makefile
@@ -17,7 +17,7 @@ COMMENT= NDTP client written in Tcl/Tk
RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= WISH=${LOCALBASE}/bin/wish8.4
.include <bsd.port.mk>
diff --git a/japanese/eb/Makefile b/japanese/eb/Makefile
index c2de232876dd..ad75d36cb115 100644
--- a/japanese/eb/Makefile
+++ b/japanese/eb/Makefile
@@ -61,7 +61,7 @@ USE_GETTEXT= yes
USE_PERL5= yes
USE_LIBTOOL_VER= 15
INSTALLS_SHLIB= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-nls \
--with-gettext-includes=${LOCALBASE}/include \
--with-gettext-libraries=${LOCALBASE}/lib \
diff --git a/japanese/eb3/Makefile b/japanese/eb3/Makefile
index 3f9bb04c5f58..526ba5a241bf 100644
--- a/japanese/eb3/Makefile
+++ b/japanese/eb3/Makefile
@@ -63,7 +63,7 @@ USE_GETTEXT= yes
USE_PERL5= yes
USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-nls \
--with-gettext-includes=${LOCALBASE}/include \
--with-gettext-libraries=${LOCALBASE}/lib \
diff --git a/japanese/eblook/Makefile b/japanese/eblook/Makefile
index 1232d000a4c9..c1a942ea84b7 100644
--- a/japanese/eblook/Makefile
+++ b/japanese/eblook/Makefile
@@ -18,7 +18,7 @@ COMMENT= Interactive EB interface command for seraching words in electoric dicti
LIB_DEPENDS= eb.9:${PORTSDIR}/japanese/eb
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-eb-includes=${PREFIX}/include \
--with-eb-libraries=${PREFIX}/lib
diff --git a/japanese/ebnetd/Makefile b/japanese/ebnetd/Makefile
index 1dbcb78a54c9..a2987a588e0d 100644
--- a/japanese/ebnetd/Makefile
+++ b/japanese/ebnetd/Makefile
@@ -18,7 +18,7 @@ COMMENT= Servers for accessing CD-ROM books via TCP/IP
LIB_DEPENDS= eb.9:${PORTSDIR}/japanese/eb
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=${RUNDIR} --with-logdir=${LOGDIR}
# Local variables
diff --git a/japanese/ebview/Makefile b/japanese/ebview/Makefile
index a35c9ffc9ba5..6568fee6ead8 100644
--- a/japanese/ebview/Makefile
+++ b/japanese/ebview/Makefile
@@ -23,7 +23,7 @@ USE_GETOPT_LONG= yes
USE_GNOME= imlib
USE_GMAKE= yes
USE_AUTOCONF_VER= 253
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
diff --git a/japanese/emacs-emcws/Makefile b/japanese/emacs-emcws/Makefile
index b87c05ef6966..fba2a206c59d 100644
--- a/japanese/emacs-emcws/Makefile
+++ b/japanese/emacs-emcws/Makefile
@@ -42,7 +42,7 @@ WITH_FREEWNN?= NO
WITH_CANNA?= YES
WITH_SJ3?= NO
-CONFIGURE_TARGET= ${ARCH}--freebsd
+CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
.if !defined(NO_X11)
CONFIGURE_ARGS= --with-x-toolkit --with-pop
diff --git a/japanese/emacs20-dl-canna/Makefile b/japanese/emacs20-dl-canna/Makefile
index a4e2f475c94d..640a83a0d177 100644
--- a/japanese/emacs20-dl-canna/Makefile
+++ b/japanese/emacs20-dl-canna/Makefile
@@ -29,7 +29,7 @@ CONFIGURE_ARGS= --with-canna-includes=${PREFIX}/include \
--with-canna-libraries=${PREFIX}/lib \
--with-emacs-srcdir=${EMACSDL_SRCDIR}
CONFIGURE_ENV= EMACS="emacs-dl-${EMACS_VER}"
-PLIST_SUB= EMACS_VER=${EMACS_VER} EMACS_ARCH=${ARCH}--freebsd \
+PLIST_SUB= EMACS_VER=${EMACS_VER} EMACS_ARCH=${MACHINE_ARCH}--freebsd \
DLCANNA_VER=${DLCANNA_VER} LISPDIR=${LISPDIR} DOCDIR=${DOCDIR}
# ports variables
diff --git a/japanese/emacs20-dl-wnn6/Makefile b/japanese/emacs20-dl-wnn6/Makefile
index 01d59ba61ab9..297bf2d766f7 100644
--- a/japanese/emacs20-dl-wnn6/Makefile
+++ b/japanese/emacs20-dl-wnn6/Makefile
@@ -28,7 +28,7 @@ CONFIGURE_ARGS= --with-wnn6 \
--with-wnn-libraries=${PREFIX}/lib \
--with-emacs-src=${EMACSDL_SRCDIR}
CONFIGURE_ENV= EMACS=${PREFIX}/bin/emacs-dl-${EMACS_VER}
-PLIST_SUB= EMACS_VER=${EMACS_VER} EMACS_ARCH=${ARCH}--freebsd \
+PLIST_SUB= EMACS_VER=${EMACS_VER} EMACS_ARCH=${MACHINE_ARCH}--freebsd \
DOCDIR=${DOCDIR}
DOCDIR= share/doc/emacs20-dl-wnn6
diff --git a/japanese/emacs20-emcws/Makefile b/japanese/emacs20-emcws/Makefile
index 86f8d87af4a0..fbe86e2f4f1d 100644
--- a/japanese/emacs20-emcws/Makefile
+++ b/japanese/emacs20-emcws/Makefile
@@ -39,7 +39,7 @@ WITH_FREEWNN?= NO
WITH_CANNA?= YES
WITH_SJ3?= NO
-CONFIGURE_TARGET= ${ARCH}--freebsd
+CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
.if !defined(NO_X11)
CONFIGURE_ARGS= --with-x-toolkit --with-pop
diff --git a/japanese/iiimf-le-canna/Makefile b/japanese/iiimf-le-canna/Makefile
index effd0d5d886e..ff9f9a693e5a 100644
--- a/japanese/iiimf-le-canna/Makefile
+++ b/japanese/iiimf-le-canna/Makefile
@@ -31,7 +31,7 @@ USE_AUTOMAKE_VER= 19
WANT_LIBTOOL_VER= 15
AUTOMAKE_ARGS+= --add-missing
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${DISTNAME:S/src-//}/leif
PATCH_WRKSRC= ${WRKDIR}/${DISTNAME:S/src-//}
diff --git a/japanese/iiimf-le-freewnn/Makefile b/japanese/iiimf-le-freewnn/Makefile
index a24c34bb573b..db4b1f0af62c 100644
--- a/japanese/iiimf-le-freewnn/Makefile
+++ b/japanese/iiimf-le-freewnn/Makefile
@@ -32,7 +32,7 @@ USE_AUTOMAKE_VER= 19
WANT_LIBTOOL_VER= 15
AUTOMAKE_ARGS+= --add-missing
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${DISTNAME:S/src-//}/leif
PATCH_WRKSRC= ${WRKDIR}/${DISTNAME:S/src-//}
diff --git a/japanese/perl5/Makefile b/japanese/perl5/Makefile
index ae474ffe483b..0fd3182c3134 100644
--- a/japanese/perl5/Makefile
+++ b/japanese/perl5/Makefile
@@ -131,7 +131,7 @@ post-install:
@${LN} -fs ${PREFIX}/bin/perl${JPERL_VERSION} ${PREFIX}/bin/jperl${JPERL_VERSION}
@${LN} -fs ${PREFIX}/bin/sperl${JPERL_VERSION} ${PREFIX}/bin/suidperl
@${LN} -fs ${PREFIX}/bin/sperl${JPERL_VERSION} ${PREFIX}/bin/jsuidperl
- @${LN} -fs ${PREFIX}/lib/perl5/${JPERL_VERSION}/${ARCH}-freebsd/CORE/libperl.so.${PERL_SHLIBVER} ${PREFIX}/lib/perl5/${JPERL_VERSION}/${ARCH}-freebsd/CORE/libperl.so
+ @${LN} -fs ${PREFIX}/lib/perl5/${JPERL_VERSION}/${MACHINE_ARCH}-freebsd/CORE/libperl.so.${PERL_SHLIBVER} ${PREFIX}/lib/perl5/${JPERL_VERSION}/${MACHINE_ARCH}-freebsd/CORE/libperl.so
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.post.mk>