aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
Diffstat (limited to 'japanese')
-rw-r--r--japanese/ming/Makefile2
-rw-r--r--japanese/ming/files/patch-raw2adpcm.c30
2 files changed, 31 insertions, 1 deletions
diff --git a/japanese/ming/Makefile b/japanese/ming/Makefile
index 55154adde9b1..4ca569b07596 100644
--- a/japanese/ming/Makefile
+++ b/japanese/ming/Makefile
@@ -40,7 +40,7 @@ DOCS_UTIL= README \
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
+#BROKEN= "Does not compile"
.endif
post-extract:
diff --git a/japanese/ming/files/patch-raw2adpcm.c b/japanese/ming/files/patch-raw2adpcm.c
new file mode 100644
index 000000000000..2378ac5c3964
--- /dev/null
+++ b/japanese/ming/files/patch-raw2adpcm.c
@@ -0,0 +1,30 @@
+--- ../util/raw2adpcm.c.orig Thu Oct 16 11:25:25 2003
++++ ../util/raw2adpcm.c Thu Oct 16 11:26:25 2003
+@@ -178,17 +178,16 @@
+ int i;
+
+ if (argc < 3) {
+- printf("\
+-%s converts a raw sound data to adpcm compressed.
+-
+-Usage:
+-%s in out [16bit] [stereo]
+-
+-in : the filename of input file, raw sound data
+-out : the filename of output file, ADPCM compressed
+-16bit : bits per sample 0=8bit 1=16bit default=1=16bit
+-stereo : number of channels 0=mono 1=stereo default=1=stereo
+-", argv[0], argv[0]);
++ printf("\n");
++ printf("%s converts a raw sound data to adpcm compressed.\n", argv[0]);
++ printf("\n");
++ printf("Usage:\n");
++ printf("%s in out [16bit] [stereo]\n", argv[0]);
++ printf("\n");
++ printf("in : the filename of input file, raw sound data\n");
++ printf("out : the filename of output file, ADPCM compressed\n");
++ printf("16bit : bits per sample 0=8bit 1=16bit default=1=16bit\n");
++ printf("stereo : number of channels 0=mono 1=stereo default=1=stereo\n");
+ exit(0);
+ }
+