aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-pydev
diff options
context:
space:
mode:
Diffstat (limited to 'java/eclipse-pydev')
-rw-r--r--java/eclipse-pydev/Makefile45
-rw-r--r--java/eclipse-pydev/distinfo4
-rw-r--r--java/eclipse-pydev/files/pkg-install.in25
3 files changed, 21 insertions, 53 deletions
diff --git a/java/eclipse-pydev/Makefile b/java/eclipse-pydev/Makefile
index 5e65e15299cb..215748f3955e 100644
--- a/java/eclipse-pydev/Makefile
+++ b/java/eclipse-pydev/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pydev
-PORTVERSION= 2.8.1
+PORTVERSION= 2.8.2
PORTREVISION= 0
CATEGORIES= java devel python
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/PyDev%20${PORTVERSION}/
@@ -16,49 +16,42 @@ LICENSE= EPL
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+BUNDLES_INFO= ${PREFIX}/lib/eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info
+
+DISTDATE= 2013090511
+
+JYTHON_DESC= Use Jython as Python interpreter
+
NO_WRKSUBDIR= yes
OPTIONS_DEFINE= JYTHON
-JYTHON_DESC= Use Jython as Python interpreter
+PLUGINDIR= share/eclipse/dropins/pydev/eclipse/plugins
+PYDEV_BUNDLES_INFO= ${PREFIX}/${PLUGINDIR}/bundles.info
+
+USE_PYTHON= yes
USES= zip
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MJYTHON}
RUN_DEPENDS+= jython:${PORTSDIR}/lang/jython
.endif
-USE_PYTHON= yes
-
-DISTDATE= 2013072611
-
-SUB_FILES= pkg-install
-SUB_LIST= BUNDLES_INFO=${BUNDLES_INFO} PLUGINDIR=${PLUGINDIR}
-
pre-install:
- @# ignore javashell.py file, because there is a syntax error
- @# see http://goo.gl/E4epH
- ${PYTHON_CMD} -m compileall -x javashell.py -f ${WRKSRC}/plugins
- ${PYTHON_CMD} -O -m compileall -x javashell.py -f ${WRKSRC}
-
-PLUGINDIR= share/eclipse/dropins/pydev/eclipse/plugins
-BUNDLES_INFO= ${PREFIX}/lib/eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info
-
-post-install:
- @${ECHO_MSG} "===> Updating ${BUNDLES_INFO}"
- @PLUGINS=$$(ls -1 ${PREFIX}/${PLUGINDIR}); \
+ @${ECHO_MSG} "===> Creating bundles.info"
+ @PLUGINS=$$(ls -1 ${WRKDIR}/plugins); \
for d in $${PLUGINS}; do \
(${ECHO_CMD} "$${d},../../${PLUGINDIR}/$${d}/,4,false" | \
- ${SED} -e 's/_\([0-9]\)/,\1/1' -e '/templates/d') >> ${BUNDLES_INFO}; \
+ ${SED} -e 's/_\([0-9]\)/,\1/1' -e '/templates/d') >> ${WRKDIR}/plugins/bundles.info; \
done
- @(${SORT} ${BUNDLES_INFO} > ${BUNDLES_INFO}.sort) && \
- ${MV} ${BUNDLES_INFO}.sort ${BUNDLES_INFO}
- @${CAT} ${PKGMESSAGE}
+ @# ignore javashell.py file, because there is a syntax error
+ @# see http://goo.gl/E4epH
+ ${PYTHON_CMD} -m compileall -x javashell.py -f ${WRKSRC}/plugins
+ ${PYTHON_CMD} -O -m compileall -x javashell.py -f ${WRKSRC}
add-plist-post:
- @${ECHO_CMD} "@exec ${MKDIR} %D/share/eclipse/dropins/${PORTNAME}/eclipse/plugins/com.python.pydev.codecompletion_${PORTVERSION}.${DISTDATE}/icons" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${CAT} ${PYDEV_BUNDLES_INFO} >> ${BUNDLES_INFO}" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${SED} -i '' -E '/^((org)|(com))\.python\.pydev/d' %D/lib/eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info" >> ${TMPPLIST}
.include "${PORTSDIR}/java/eclipse/Makefile.plugins"
diff --git a/java/eclipse-pydev/distinfo b/java/eclipse-pydev/distinfo
index 358859c37ffa..7b1810702fda 100644
--- a/java/eclipse-pydev/distinfo
+++ b/java/eclipse-pydev/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PyDev%202.8.1.zip) = 779d5bb8a0b2c77b13c19c482a178511f40e4640c55c42967af6105ce437cbde
-SIZE (PyDev%202.8.1.zip) = 7956817
+SHA256 (PyDev%202.8.2.zip) = 4219c513d182d0dd96d81ab2c2fa788271a40bbd51a696f4a2468c98af11f229
+SIZE (PyDev%202.8.2.zip) = 8070787
diff --git a/java/eclipse-pydev/files/pkg-install.in b/java/eclipse-pydev/files/pkg-install.in
deleted file mode 100644
index 3c5c2d73b759..000000000000
--- a/java/eclipse-pydev/files/pkg-install.in
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/sh
-
-if [ $# -ne 2 ]; then
- echo "usage: $0 distname { POST-INSTALL }" >&2
- exit 1
-fi
-
-PATH="/bin:/sbin:/usr/bin:/usr/sbin"
-
-BUNDLES_INFO=%%BUNDLES_INFO%%
-PLUGINDIR=%%PLUGINDIR%%
-PREFIX=%%PREFIX%%
-
-if [ "$2" = "POST-INSTALL" ]; then
- echo "===> Updating ${BUNDLES_INFO}"
- for d in $(ls -1 ${PREFIX}/${PLUGINDIR})
- do
- (echo "${d},../../${PLUGINDIR}/${d}/,4,false" | \
- sed -e 's/_\([0-9]\)/,\1/1' -e '/templates/d') >> ${BUNDLES_INFO}
- done
- sort ${BUNDLES_INFO} > ${BUNDLES_INFO}.sort && \
- mv ${BUNDLES_INFO}.sort ${BUNDLES_INFO}
-fi
-
-exit 0