aboutsummaryrefslogtreecommitdiff
path: root/java/icedtea-web
diff options
context:
space:
mode:
Diffstat (limited to 'java/icedtea-web')
-rw-r--r--java/icedtea-web/Makefile4
-rw-r--r--java/icedtea-web/files/patch-netx-Boot.java21
-rw-r--r--java/icedtea-web/files/patch-netx-JNLPRuntime.java11
-rw-r--r--java/icedtea-web/files/patch-plugin-PluginMain.java22
4 files changed, 56 insertions, 2 deletions
diff --git a/java/icedtea-web/Makefile b/java/icedtea-web/Makefile
index e7acc0baac80..4687b81bf698 100644
--- a/java/icedtea-web/Makefile
+++ b/java/icedtea-web/Makefile
@@ -2,6 +2,7 @@
PORTNAME= icedtea-web
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= java www
MASTER_SITES= http://icedtea.wildebeest.org/download/source/ \
http://icedtea.classpath.org/download/source/
@@ -16,14 +17,13 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/zip:${PORTSDIR}/archivers/zip \
RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_JAVA= yes
JAVA_OS= native
JAVA_VENDOR= openjdk
JAVA_VERSION= 1.6+
USE_PERL5_BUILD=yes
USE_XORG= x11
-USES= pkgconfig shebangfix
+USES= gmake pkgconfig shebangfix
SHEBANG_FILES= javac.in jrunscript.in
WANT_GNOME= yes
diff --git a/java/icedtea-web/files/patch-netx-Boot.java b/java/icedtea-web/files/patch-netx-Boot.java
new file mode 100644
index 000000000000..fbdc39fef7fe
--- /dev/null
+++ b/java/icedtea-web/files/patch-netx-Boot.java
@@ -0,0 +1,21 @@
+--- netx/net/sourceforge/jnlp/runtime/Boot.java Tue Jun 18 15:57:01 2013 -0400
++++ netx/net/sourceforge/jnlp/runtime/Boot.java Thu Jun 20 15:20:57 2013 +0200
+@@ -35,6 +35,8 @@
+ import net.sourceforge.jnlp.cache.UpdatePolicy;
+ import net.sourceforge.jnlp.security.viewer.CertificateViewer;
+ import net.sourceforge.jnlp.services.ServiceUtil;
++import sun.awt.AppContext;
++import sun.awt.SunToolkit;
+
+ /**
+ * This is the main entry point for the JNLP client. The main
+@@ -113,6 +115,9 @@
+ * Launch the JNLP file specified by the command-line arguments.
+ */
+ public static void main(String[] argsIn) {
++ if (AppContext.getAppContext() == null) {
++ SunToolkit.createNewAppContext();
++ }
+ args = argsIn;
+
+ if (null != getOption("-viewer")) {
diff --git a/java/icedtea-web/files/patch-netx-JNLPRuntime.java b/java/icedtea-web/files/patch-netx-JNLPRuntime.java
new file mode 100644
index 000000000000..6d2c67539d92
--- /dev/null
+++ b/java/icedtea-web/files/patch-netx-JNLPRuntime.java
@@ -0,0 +1,11 @@
+--- netx/net/sourceforge/jnlp/runtime/JNLPRuntime.java Tue Jun 18 15:57:01 2013 -0400
++++ netx/net/sourceforge/jnlp/runtime/JNLPRuntime.java Thu Jun 20 15:20:57 2013 +0200
+@@ -234,7 +234,7 @@
+ try {
+ UIManager.setLookAndFeel(UIManager.getSystemLookAndFeelClassName());
+ } catch (Exception e) {
+- // ignore it
++ e.printStackTrace();
+ }
+
+ doMainAppContextHacks();
diff --git a/java/icedtea-web/files/patch-plugin-PluginMain.java b/java/icedtea-web/files/patch-plugin-PluginMain.java
new file mode 100644
index 000000000000..17a254f9366a
--- /dev/null
+++ b/java/icedtea-web/files/patch-plugin-PluginMain.java
@@ -0,0 +1,22 @@
+--- plugin/icedteanp/java/sun/applet/PluginMain.java Tue Jun 18 15:57:01 2013 -0400
++++ plugin/icedteanp/java/sun/applet/PluginMain.java Thu Jun 20 15:20:57 2013 +0200
+@@ -72,6 +72,8 @@
+ import java.net.ProxySelector;
+ import java.util.Enumeration;
+ import java.util.Properties;
++import sun.awt.AppContext;
++import sun.awt.SunToolkit;
+
+ import net.sourceforge.jnlp.config.DeploymentConfiguration;
+ import net.sourceforge.jnlp.runtime.JNLPRuntime;
+@@ -94,6 +96,9 @@
+ */
+ public static void main(String args[])
+ throws IOException {
++ if (AppContext.getAppContext() == null) {
++ SunToolkit.createNewAppContext();
++ }
+ if (args.length != 2 || !(new File(args[0]).exists()) || !(new File(args[1]).exists())) {
+ System.err.println("Invalid pipe names provided. Refusing to proceed.");
+ System.exit(1);
+