aboutsummaryrefslogtreecommitdiff
path: root/java/jakarta-commons-codec/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/jakarta-commons-codec/Makefile')
-rw-r--r--java/jakarta-commons-codec/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/java/jakarta-commons-codec/Makefile b/java/jakarta-commons-codec/Makefile
index 693536288a3a..64deae5d59e5 100644
--- a/java/jakarta-commons-codec/Makefile
+++ b/java/jakarta-commons-codec/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= commons-codec
-PORTVERSION= 1.7
+PORTVERSION= 1.8
CATEGORIES= java converters
MASTER_SITES= ${MASTER_SITE_APACHE_COMMONS_SOURCE}
MASTER_SITE_SUBDIR= ${PORTNAME:S,commons-,,}
@@ -24,12 +24,14 @@ PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
PORTDOCS= *
+.include <bsd.port.options.mk>
+
do-install:
@${ECHO_MSG} -n ">> Installing JAR file as ${JAVAJARDIR}/${PORTNAME}.jar..."
- @${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}-${PORTVERSION}-SNAPSHOT.jar \
+ @${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}-${PORTVERSION}.jar \
${JAVAJARDIR}/${PORTNAME}.jar
@${ECHO_MSG} " [DONE]"
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} -n ">> Installing documentation..."
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC}/dist/docs && ${FIND} api \