aboutsummaryrefslogtreecommitdiff
path: root/java/jc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/jc/Makefile')
-rw-r--r--java/jc/Makefile47
1 files changed, 0 insertions, 47 deletions
diff --git a/java/jc/Makefile b/java/jc/Makefile
deleted file mode 100644
index 7d531dbd8a28..000000000000
--- a/java/jc/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-# Created by: Archie Cobbs <archie@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= jc
-PORTVERSION= 1.4.7
-PORTREVISION= 7
-CATEGORIES= java
-MASTER_SITES= SF/${PORTNAME}vm/JC%20source%20distribution/Release%20${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= JVM that converts class files to C source and compiles them with GCC
-
-BROKEN= Fails to build
-
-BUILD_DEPENDS= ${LOCALBASE}/share/classpath/glibj.zip:${PORTSDIR}/java/classpath
-LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt
-
-NO_PACKAGE= Takes too many resources to build
-
-MAN1= jc.1
-
-USES= gmake
-USE_JAVA= yes
-JAVA_BUILD= jre
-USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-classpath=${LOCALBASE}
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-INFO= jc
-ONLY_FOR_ARCHS= i386
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-post-install:
-.for dir in ${PREFIX}/include/jc ${PREFIX}/lib/jc ${PREFIX}/share/jc
- @${FIND} ${dir} ! -type d | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${dir} -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
- @if [ -f ${PREFIX}/lib/libjc.a ]; then \
- ${ECHO} lib/libjc.a >> ${TMPPLIST}; \
- fi
-.endfor
-
-.include <bsd.port.post.mk>