aboutsummaryrefslogtreecommitdiff
path: root/java/netbeans/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/netbeans/Makefile')
-rw-r--r--java/netbeans/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/java/netbeans/Makefile b/java/netbeans/Makefile
index 41afc35d98ec..2fc4dcb3a44a 100644
--- a/java/netbeans/Makefile
+++ b/java/netbeans/Makefile
@@ -30,6 +30,9 @@ DOWNLOAD_URL?= http://www.netbeans.info/downloads/download.php?type=5.0&p=1&a=bs
IGNORE= you must manually fetch the source distribution (${DISTFILES}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
+do-configure:
+ @${REINPLACE_CMD} 's|%%JAVA_HOME%%|${JAVA_HOME}|' ${WRKSRC}/etc/netbeans.conf
+
do-install:
@${MKDIR} ${PREFIX}/netbeans
@${CP} -r ${WRKSRC}/* ${PREFIX}/netbeans