aboutsummaryrefslogtreecommitdiff
path: root/java/netbeans4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/netbeans4/Makefile')
-rw-r--r--java/netbeans4/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/java/netbeans4/Makefile b/java/netbeans4/Makefile
index 3e9623091a54..a1f2e69c5866 100644
--- a/java/netbeans4/Makefile
+++ b/java/netbeans4/Makefile
@@ -30,6 +30,13 @@ DOWNLOAD_URL?= http://www.netbeans.info/downloads/download.php?p=1&a=bd&os=1&lan
IGNORE= you must manually fetch the source distribution (${DISTFILES}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
+post-patch:
+ @${RM} ${WRKSRC}/etc/netbeans.conf.orig
+
+do-configure:
+ @${REINPLACE_CMD} 's|%%JAVA_HOME%%|${JAVA_HOME}|' ${WRKSRC}/etc/netbeans.conf
+ @${RM} ${WRKSRC}/etc/netbeans.conf.bak
+
do-install:
@${MKDIR} ${PREFIX}/netbeans4
@${CP} -r ${WRKSRC}/* ${PREFIX}/netbeans4