aboutsummaryrefslogtreecommitdiff
path: root/java/phpeclipse/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/phpeclipse/Makefile')
-rw-r--r--java/phpeclipse/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/java/phpeclipse/Makefile b/java/phpeclipse/Makefile
index a766ca8456e5..a688c2b2f4e4 100644
--- a/java/phpeclipse/Makefile
+++ b/java/phpeclipse/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= phpeclipse
-PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTVERSION= 1.1.3
CATEGORIES= java editors devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= phpeclipse
-DISTNAME= PHPEclipse${PORTVERSION}-2004-10-24
+DISTNAME= PHPEclipse${PORTVERSION}-2005-01-29
MAINTAINER= rtdean@cytherianage.net
COMMENT= PHP Eclipse adds PHP support to the Eclipse IDE Framework
@@ -20,22 +19,18 @@ RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
NO_BUILD= yes
USE_ZIP= yes
-WRKSRC= ${WRKDIR}
+NO_WRKSUBDIR= yes
ECLIPSE= ${PREFIX}/eclipse
+PLIST_SUB= VER=${PORTVERSION} NSP=net.sourceforge.phpeclipse \
+ NSEVER=net.sf.eclipsetidy_1.2.1
+
do-install:
@${CP} -r ${WRKSRC}/features/* ${ECLIPSE}/features
@${CP} -r ${WRKSRC}/plugins/* ${ECLIPSE}/plugins
post-install:
- @${FIND} -s ${WRKSRC}/features -not -type d \
- | ${SED} -ne 's,^${WRKSRC},${ECLIPSE:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
- @${FIND} -s ${WRKSRC}/plugins -not -type d \
- | ${SED} -ne 's,^${WRKSRC},${ECLIPSE:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
- @${FIND} -s -d ${WRKSRC}/features/* -type d \
- | ${SED} -ne 's,^${WRKSRC},@dirrm ${ECLIPSE:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
- @${FIND} -s -d ${WRKSRC}/plugins/* -type d \
- | ${SED} -ne 's,^${WRKSRC},@dirrm ${ECLIPSE:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>