aboutsummaryrefslogtreecommitdiff
path: root/java/sablevm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/sablevm/Makefile')
-rw-r--r--java/sablevm/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/java/sablevm/Makefile b/java/sablevm/Makefile
new file mode 100644
index 000000000000..6afe34674c3b
--- /dev/null
+++ b/java/sablevm/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: sablevm
+# Date created: 9 July 2002
+# Whom: Archie Cobbs <archie@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sablevm
+PORTVERSION= 0.1.6
+CATEGORIES= java
+MASTER_SITES= http://unc.dl.sourceforge.net/sablevm/
+
+MAINTAINER= archie@freebsd.org
+
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
+ ffi.2:${PORTSDIR}/devel/libffi
+RUN_DEPENDS= ${LOCALBASE}/lib/sablepath/libjavalang.a:${PORTSDIR}/java/sablepath
+
+PATCH_STRIP= -p1
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>