aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
Diffstat (limited to 'java')
-rw-r--r--java/kaffe/Makefile26
-rw-r--r--java/kaffe/distinfo1
-rw-r--r--java/kaffe/pkg-comment1
-rw-r--r--java/kaffe/pkg-descr13
-rw-r--r--java/kaffe/pkg-plist13
5 files changed, 54 insertions, 0 deletions
diff --git a/java/kaffe/Makefile b/java/kaffe/Makefile
new file mode 100644
index 000000000000..d2c182cdb42f
--- /dev/null
+++ b/java/kaffe/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: kaffe
+# Version required: 0.2
+# Date created: 20 February 1995
+# Whom: Tim Wilkinson <tim@sarc.city.ac.uk>
+#
+# $Id: Makefile,v 1.5 1995/11/27 04:05:58 asami Exp $
+#
+
+DISTNAME= kaffe-0.2
+CATEGORIES+= www
+MASTER_SITES= ftp://ftp.sarc.city.ac.uk/pub/kaffe/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= tim@sarc.city.ac.uk
+
+GNU_CONFIGURE= yes
+
+do-configure:
+ @(cd ${WRKSRC}; ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS})
+
+post-install:
+ cp ${WRKSRC}/sun/COPYRIGHT ${PREFIX}/share/kaffe
+ cp ${WRKSRC}/license.terms ${PREFIX}/share/kaffe
+ /sbin/ldconfig -m ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/java/kaffe/distinfo b/java/kaffe/distinfo
new file mode 100644
index 000000000000..29813765d8af
--- /dev/null
+++ b/java/kaffe/distinfo
@@ -0,0 +1 @@
+MD5 (kaffe-0.2.tgz) = 50fbe364d52cbf7f9a1e9aa603e72ae7
diff --git a/java/kaffe/pkg-comment b/java/kaffe/pkg-comment
new file mode 100644
index 000000000000..941c18d9c881
--- /dev/null
+++ b/java/kaffe/pkg-comment
@@ -0,0 +1 @@
+A virtual machine capable of running Java(tm) code
diff --git a/java/kaffe/pkg-descr b/java/kaffe/pkg-descr
new file mode 100644
index 000000000000..d5bd75d9f21a
--- /dev/null
+++ b/java/kaffe/pkg-descr
@@ -0,0 +1,13 @@
+This is Kaffe, a virtual machine design to execute Java bytecode. Unlike
+other virtual machines available, this machine performs "just-in-time"
+code conversion from the abstract code to the host machine's native code.
+This will ultimately allow execution of Java code at the same speed as
+standard compiled code but while maintaining the advantages and flexibility
+of code independence.
+
+Please note, this is version 0.2 and many feature are not yet implemented
+(notable there is no graphics support at the moment) and there are likely
+to be various odd bugs. All comments to the mail address below.
+
+Tim
+tim@sarc.city.ac.uk
diff --git a/java/kaffe/pkg-plist b/java/kaffe/pkg-plist
new file mode 100644
index 000000000000..575d5e3441fa
--- /dev/null
+++ b/java/kaffe/pkg-plist
@@ -0,0 +1,13 @@
+bin/javac
+bin/javadoc
+bin/kaffe
+bin/kaffeh
+include/kaffe/native.h
+include/kaffe/stubPreamble.h
+lib/libnative.so.0.2
+lib/libnet.so.0.2
+@exec /sbin/ldconfig -m %B
+share/kaffe/classes.zip
+share/kaffe/lib/javac.properties
+share/kaffe/COPYRIGHT
+share/kaffe/license.terms