aboutsummaryrefslogtreecommitdiff
path: root/korean/ami/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'korean/ami/Makefile')
-rw-r--r--korean/ami/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/korean/ami/Makefile b/korean/ami/Makefile
index 13cd980d6f96..ba910c4ae2a4 100644
--- a/korean/ami/Makefile
+++ b/korean/ami/Makefile
@@ -1,13 +1,12 @@
# New ports collection makefile for: ami
-# Version required: ami-0.4.1
# Date created: 05 Jun 1999
# Whom: CHOI Junho <cjh@kr.freebsd.org>
#
# $FreeBSD$
#
-DISTNAME= ami-${AMI_VER}
-PKGNAME= ko-ami-${AMI_VER}
+PORTNAME= ami
+PORTVERSION= 1.0.4
CATEGORIES= korean x11
MASTER_SITES= http://www.kr.freebsd.org/~hwang/ami/ \
http://adam.kaist.ac.kr/~cwryu/archive/misc/
@@ -24,8 +23,6 @@ CONFIGURE_ENV= GLIB_CONFIG=${LOCALBASE}/bin/glib12-config \
GTK_CONFIG=${X11BASE}/bin/gtk12-config
CONFIGURE_ARGS+= --with-hangul-keyboard=2
-AMI_VER= 1.0.4
-
# Korean input in dvorak keyboard
.if defined(WITH_DVORAK)
CONFIGURE_ARGS+= --with-english-keyboard=dvorak
@@ -33,7 +30,7 @@ CONFIGURE_ARGS+= --with-english-keyboard=dvorak
# gnome support
.if defined(WITH_GNOME_APPLET)
-PKGNAME= ko-ami-gnome-${AMI_VER}
+PKGNAMESUFFIX= -gnome
RUN_DEPENDS+= panel:${PORTSDIR}/x11/gnomecore
LIB_DEPENDS+= gnome.3:${PORTSDIR}/x11/gnomelibs
CONFIGURE_ARGS+= --enable-gnome-applet