aboutsummaryrefslogtreecommitdiff
path: root/korean/eterm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'korean/eterm/Makefile')
-rw-r--r--korean/eterm/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/korean/eterm/Makefile b/korean/eterm/Makefile
new file mode 100644
index 000000000000..031faf63d858
--- /dev/null
+++ b/korean/eterm/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: ko-eterm-0.8.9
+# Version required: 0.8.9
+# Date created: 8 Jun 1999
+# Whom: Oh Junseon <hollywar@mail.holywar.net>
+#
+# $Id$
+#
+
+DISTNAME= Eterm-0.8.9
+PKGNAME= ko-eterm-0.8.9
+CATEGORIES= korean x11
+MASTER_SITES= ftp://ftp.eterm.org/pub/Eterm/ \
+ ftp://ftp.holywar.net/pub/FreeBSD/ \
+ ftp://ftp.kr.freebsd.org/pub/FreeBSD-kr/distfiles/ \
+ http://www.tcserv.com/archive/E/ \
+ http://eterm.is.nontoxic.org/download/ \
+ http://www.tcserv.com/archive/E/old/
+
+MAINTAINER= hollywar@mail.holywar.net
+
+LIB_DEPENDS= Imlib.4:${PORTSDIR}/graphics/imlib
+RUN_DEPENDS= ${PREFIX}/lib/X11/fonts/local/hmm12.pcf.gz:${PORTSDIR}/korean/hanyangfonts
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lxpg4"
+MAN1= Eterm.1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/Eterm
+ @${INSTALL_DATA} ${WRKSRC}/ReleaseNotes ${PREFIX}/share/doc/Eterm
+ @${INSTALL_DATA} ${WRKSRC}/doc/Eterm_reference.html ${PREFIX}/share/doc/Eterm
+ @${INSTALL_DATA} ${WRKSRC}/doc/Eterm.tcap ${PREFIX}/share/doc/Eterm
+ @${INSTALL_DATA} ${WRKSRC}/doc/Eterm.ti ${PREFIX}/share/doc/Eterm
+ @${INSTALL_DATA} ${WRKSRC}/doc/FAQ.html ${PREFIX}/share/doc/Eterm
+.endif
+
+.include <bsd.port.mk>