aboutsummaryrefslogtreecommitdiff
path: root/lang/bigloo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/bigloo/Makefile')
-rw-r--r--lang/bigloo/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/lang/bigloo/Makefile b/lang/bigloo/Makefile
index 77bbaa642174..3014c0a24a8d 100644
--- a/lang/bigloo/Makefile
+++ b/lang/bigloo/Makefile
@@ -6,19 +6,17 @@
#
PORTNAME= bigloo
-PORTVERSION= 3.2a
+PORTVERSION= 3.2a.2
CATEGORIES= lang scheme
MASTER_SITES= ftp://ftp-sop.inria.fr/mimosa/fp/Bigloo/ \
ftp://kaolin.unice.fr/pub/Bigloo/
-DISTNAME= ${PORTNAME}${PORTVERSION}
+DISTNAME= ${PORTNAME}${PORTVERSION:R}-${PORTVERSION:E}
MAINTAINER= ports@FreeBSD.org
COMMENT= A Scheme interpreter and native code compiler
LIB_DEPENDS= gc.1:${PORTSDIR}/devel/boehm-gc
-WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
-
USE_OPENSSL= yes
USE_GSTREAMER= yes
USE_EMACS= yes
@@ -34,8 +32,8 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--customgc=no
ALL_TARGET= build
INSTALL_TARGET= install-progs compile-bee install-bee
-USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/bigloo/${PORTVERSION}
-PLIST_SUB= BIGLOO_VERSION="${PORTVERSION}"
+USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/bigloo/${PORTVERSION:R}
+PLIST_SUB= BIGLOO_VERSION="${PORTVERSION:R}"
MAN1= bigloo.1
INFO= bigloo