aboutsummaryrefslogtreecommitdiff
path: root/lang/clisp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/clisp/Makefile')
-rw-r--r--lang/clisp/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/lang/clisp/Makefile b/lang/clisp/Makefile
index a4f7dbaa813d..d68db524dea8 100644
--- a/lang/clisp/Makefile
+++ b/lang/clisp/Makefile
@@ -29,14 +29,13 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix="${PREFIX}" --mandir="${MANPREFIX}/man" \
--elispdir="${DATADIR}/emacs" --vimdir="${DATADIR}/vim" \
--docdir="${DOCSDIR}"
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_TARGET= ${ARCH:S/amd64/x86_64/}-portbld-freebsd${OSREL}
# Complaints if the environment changes between build stages.
MAKE_ENV= ${CONFIGURE_ENV}
BUILD_WRKSRC= ${WRKSRC}/src
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE=yes
OPTIONS= BDB "Build Berkeley Database module" Off \