aboutsummaryrefslogtreecommitdiff
path: root/lang/clover/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/clover/Makefile')
-rw-r--r--lang/clover/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/lang/clover/Makefile b/lang/clover/Makefile
index 8ad320fed62e..744e6f2916b4 100644
--- a/lang/clover/Makefile
+++ b/lang/clover/Makefile
@@ -2,7 +2,7 @@
PORTNAME= clover
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang
COMMENT= Mesa "Clover" OpenCL library
@@ -31,9 +31,9 @@ MESA_INSTALL_WRKSRC= src/gallium/targets/opencl src/gallium/targets/pipe-loader
.include "${MASTERDIR}/Makefile.targets"
pre-configure:
- @if [ -e ${LOCALBASE}/bin/llvm-config${MESA_LLVM_VER} ] && \
- ! [ -e ${LOCALBASE}/bin/clang${MESA_LLVM_VER} ]; then \
- ${ECHO_MSG} "Your llvm${MESA_LLVM_VER} is not built with clang support, which is required."; \
+ @if [ -e ${LOCALBASE}/bin/llvm-config${LLVM_DEFAULT} ] && \
+ ! [ -e ${LOCALBASE}/bin/clang${LLVM_DEFAULT} ]; then \
+ ${ECHO_MSG} "Your llvm${LLVM_DEFAULT} is not built with clang support, which is required."; \
${FALSE}; \
fi