aboutsummaryrefslogtreecommitdiff
path: root/lang/ezm3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ezm3/Makefile')
-rw-r--r--lang/ezm3/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/lang/ezm3/Makefile b/lang/ezm3/Makefile
index c1b666a26cf4..cd98d0a3e162 100644
--- a/lang/ezm3/Makefile
+++ b/lang/ezm3/Makefile
@@ -54,6 +54,11 @@ WORDSIZE= 64
ENDIANESS= be
.endif
+# The build fails for -O2 or greater. Override it with plain -O.
+.if defined(CFLAGS) && !empty(CFLAGS:M-O[2-9s]*)
+CFLAGS+= -O
+.endif
+
post-patch:
.if ${ARCH} == "sparc64" && ${OSVERSION} < 502107
@${REINPLACE_CMD} -E -e 's|(^.*time_t.*=.*)int64_t;|\1int32_t;|' \