aboutsummaryrefslogtreecommitdiff
path: root/lang/ferite/files
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ferite/files')
-rw-r--r--lang/ferite/files/patch-Makefile.in26
-rw-r--r--lang/ferite/files/patch-docs::images::Makefile.in27
-rw-r--r--lang/ferite/files/patch-libs-aphex-src-Makefile.in11
-rw-r--r--lang/ferite/files/patch-libs::aphex::src::aphex_thread.c14
-rw-r--r--lang/ferite/files/patch-scripts::test::test.fe32
-rw-r--r--lang/ferite/files/patch-tools::doc::Makefile.in26
-rw-r--r--lang/ferite/files/patch-tools::doc::template::Makefile.in25
-rw-r--r--lang/ferite/files/patch-tools::doc::template::html::Makefile.in27
8 files changed, 84 insertions, 104 deletions
diff --git a/lang/ferite/files/patch-Makefile.in b/lang/ferite/files/patch-Makefile.in
index 8b553a11883b..2d63498225bf 100644
--- a/lang/ferite/files/patch-Makefile.in
+++ b/lang/ferite/files/patch-Makefile.in
@@ -1,25 +1,17 @@
---- Makefile.in.orig Thu Jan 9 04:49:25 2003
-+++ Makefile.in Tue Jan 14 09:37:06 2003
-@@ -137,7 +137,7 @@
- bin_SCRIPTS = ferite-config
-
- fbm_DATA = LICENSE AUTHORS TODO ROADMAP DEVELOPERS ABOUT RELEASE.NOTES
--fbmdir = $(prefix)/share/ferite
-+fbmdir = $(prefix)/share/doc/ferite
-
- EXTRA_DIST = shtool $(fbm_DATA) $(m4data_DATA) ferite.spec
-
-@@ -236,6 +236,7 @@
+--- Makefile.in.orig Wed Oct 19 18:47:17 2005
++++ Makefile.in Wed Oct 19 18:48:23 2005
+@@ -363,6 +363,8 @@
+ -rm -f libtool
uninstall-info-am:
- fbmDATA_INSTALL = $(INSTALL_DATA)
install-fbmDATA: $(fbm_DATA)
++
+ifndef NOPORTDOCS
@$(NORMAL_INSTALL)
- $(mkinstalldirs) $(DESTDIR)$(fbmdir)
+ test -z "$(fbmdir)" || $(mkdir_p) "$(DESTDIR)$(fbmdir)"
@list='$(fbm_DATA)'; for p in $$list; do \
-@@ -244,6 +245,7 @@
- echo " $(fbmDATA_INSTALL) $$d$$p $(DESTDIR)$(fbmdir)/$$f"; \
- $(fbmDATA_INSTALL) $$d$$p $(DESTDIR)$(fbmdir)/$$f; \
+@@ -371,6 +373,7 @@
+ echo " $(fbmDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(fbmdir)/$$f'"; \
+ $(fbmDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(fbmdir)/$$f"; \
done
+endif
diff --git a/lang/ferite/files/patch-docs::images::Makefile.in b/lang/ferite/files/patch-docs::images::Makefile.in
index 7140dd52180a..dfc2930e7095 100644
--- a/lang/ferite/files/patch-docs::images::Makefile.in
+++ b/lang/ferite/files/patch-docs::images::Makefile.in
@@ -1,25 +1,26 @@
---- docs/images/Makefile.in.orig Thu Jan 9 04:49:26 2003
-+++ docs/images/Makefile.in Tue Jan 14 09:37:43 2003
-@@ -127,7 +127,7 @@
- ferite_logo_black.png
-
+--- docs/images/Makefile.in.orig Wed Oct 19 18:50:00 2005
++++ docs/images/Makefile.in Wed Oct 19 18:51:35 2005
+@@ -233,7 +233,7 @@
+ images_DATA = \
+ ferite_logo_black.png ferite_logo_colour.png
-imagesdir = $(prefix)/share/ferite/images
+imagesdir = $(prefix)/share/doc/ferite/images
-
EXTRA_DIST = $(images_DATA)
- subdir = docs/images
-@@ -158,6 +158,7 @@
+ all: all-am
+
+@@ -278,6 +278,8 @@
+ -rm -f libtool
uninstall-info-am:
- imagesDATA_INSTALL = $(INSTALL_DATA)
install-imagesDATA: $(images_DATA)
++
+ifndef NOPORTDOCS
@$(NORMAL_INSTALL)
- $(mkinstalldirs) $(DESTDIR)$(imagesdir)
+ test -z "$(imagesdir)" || $(mkdir_p) "$(DESTDIR)$(imagesdir)"
@list='$(images_DATA)'; for p in $$list; do \
-@@ -166,6 +167,7 @@
- echo " $(imagesDATA_INSTALL) $$d$$p $(DESTDIR)$(imagesdir)/$$f"; \
- $(imagesDATA_INSTALL) $$d$$p $(DESTDIR)$(imagesdir)/$$f; \
+@@ -286,6 +288,7 @@
+ echo " $(imagesDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(imagesdir)/$$f'"; \
+ $(imagesDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(imagesdir)/$$f"; \
done
+endif
diff --git a/lang/ferite/files/patch-libs-aphex-src-Makefile.in b/lang/ferite/files/patch-libs-aphex-src-Makefile.in
new file mode 100644
index 000000000000..6739398d74d2
--- /dev/null
+++ b/lang/ferite/files/patch-libs-aphex-src-Makefile.in
@@ -0,0 +1,11 @@
+--- libs/aphex/src/Makefile.in.orig Wed Oct 19 19:30:12 2005
++++ libs/aphex/src/Makefile.in Wed Oct 19 19:30:31 2005
+@@ -119,7 +119,7 @@
+ CXXDEPMODE = @CXXDEPMODE@
+ CXXFLAGS = @CXXFLAGS@
+ CYGPATH_W = @CYGPATH_W@
+-DEFS = @debugdefs@ @thread_defs@
++DEFS = @debugdefs@ @thread_defs@ -DUSING_FAKE_RECURSIVE_MUTEX
+ DEPDIR = @DEPDIR@
+ ECHO = @ECHO@
+ ECHO_C = @ECHO_C@
diff --git a/lang/ferite/files/patch-libs::aphex::src::aphex_thread.c b/lang/ferite/files/patch-libs::aphex::src::aphex_thread.c
deleted file mode 100644
index 48fdee8a7ace..000000000000
--- a/lang/ferite/files/patch-libs::aphex::src::aphex_thread.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- libs/aphex/src/aphex_thread.c.orig Sat Nov 23 05:28:53 2002
-+++ libs/aphex/src/aphex_thread.c Tue Jan 14 08:40:17 2003
-@@ -134,7 +134,11 @@
- pthread_mutex_init( &mutex->mutex, NULL );
- #else
- pthread_mutexattr_init( &mutex->attr );
-+#if defined(__FreeBSD__)
-+ pthread_mutexattr_setkind_np( &mutex->attr, PTHREAD_MUTEX_RECURSIVE );
-+#else
- pthread_mutexattr_setkind_np( &mutex->attr, PTHREAD_MUTEX_RECURSIVE_NP );
-+#endif
- pthread_mutex_init( &mutex->mutex, &mutex->attr );
- #endif
- mutex->recursive = 1;
diff --git a/lang/ferite/files/patch-scripts::test::test.fe b/lang/ferite/files/patch-scripts::test::test.fe
index 4a025ceb00e2..ddb054d0ee8b 100644
--- a/lang/ferite/files/patch-scripts::test::test.fe
+++ b/lang/ferite/files/patch-scripts::test::test.fe
@@ -1,26 +1,22 @@
---- scripts/test/test.fe.orig Sat Nov 23 05:29:42 2002
-+++ scripts/test/test.fe Sat Jan 11 18:27:52 2003
-@@ -17,17 +17,17 @@
+--- scripts/test/test.fe.orig Wed Jan 5 08:36:10 2005
++++ scripts/test/test.fe Wed Oct 19 19:41:02 2005
+@@ -17,16 +17,16 @@
a_global_int = 10;
- Console.println( "Printing Out All ext3 Partitions in /etc/fstab" );
+ Console.println( "Printing Out All ufs Partitions in /etc/fstab" );
- testfile = Sys.openfile( "/etc/fstab", 0 );
+ testfile = File.open( "/etc/fstab" );
Console.println( "Here." );
while( (blam = testfile.readln()) )
{
- if( blam =~ m/
-- (\/dev\/[hs]d[a-g][1-9]) # device entry
-- [\ \t]* # whitespace
-- (\/[a-z]*(\/[a-z]*)*) # mount point
-- [\ \t]* # whitespace
-- ext3 # force adherance to ext3
-+ (\/dev\/[adw][ad][0-9][0-9]?s?[1-4]?[a-h]) # device entry
-+ [\ \t]* # whitespace
-+ (\/[a-z]*(\/[a-z]*)*) # mount point
-+ [\ \t]* # whitespace
-+ ufs # force adherance to ufs
- /xoi /* make usre it's not case sensitive */
- )
- {
+- object reg1 = new Regexp( '(\/dev\/[hs]d[a-g][1-9]) # device entry
++ object reg1 = new Regexp( '(\/dev\/[adw][ad][0-9][0-9]?s?[1-4]?[a-h]) # device entry
+ [\ \t]* # whitespace
+ (\/[a-z]*(\/[a-z]*)*) # mount point
+ [\ \t]* # whitespace
+- ext3 # force adherance to ext3', 'xoi' );
++ ufs # force adherance to ufs', 'xoi' );
+ object reg2 = new Regexp( "[^ \t]+", "" );
+
+ if( reg1.match( blam ) )
diff --git a/lang/ferite/files/patch-tools::doc::Makefile.in b/lang/ferite/files/patch-tools::doc::Makefile.in
index 0f3d288cba55..26e693e22574 100644
--- a/lang/ferite/files/patch-tools::doc::Makefile.in
+++ b/lang/ferite/files/patch-tools::doc::Makefile.in
@@ -1,25 +1,17 @@
---- tools/doc/Makefile.in.orig Thu Jan 9 04:49:50 2003
-+++ tools/doc/Makefile.in Tue Jan 14 09:38:37 2003
-@@ -125,7 +125,7 @@
- SUBDIRS = template
-
- doc_DATA = parser.fe structs.fe doc.fe template.fe
--docdir = @prefix@/share/ferite/doc
-+docdir = @prefix@/share/doc/ferite
-
- bin_SCRIPTS = feritedoc
-
-@@ -188,6 +188,7 @@
+--- tools/doc/Makefile.in.orig Wed Oct 19 19:04:42 2005
++++ tools/doc/Makefile.in Wed Oct 19 19:05:15 2005
+@@ -312,6 +312,8 @@
+ -rm -f libtool
uninstall-info-am:
- docDATA_INSTALL = $(INSTALL_DATA)
install-docDATA: $(doc_DATA)
++
+ifndef NOPORTDOCS
@$(NORMAL_INSTALL)
- $(mkinstalldirs) $(DESTDIR)$(docdir)
+ test -z "$(docdir)" || $(mkdir_p) "$(DESTDIR)$(docdir)"
@list='$(doc_DATA)'; for p in $$list; do \
-@@ -196,6 +197,7 @@
- echo " $(docDATA_INSTALL) $$d$$p $(DESTDIR)$(docdir)/$$f"; \
- $(docDATA_INSTALL) $$d$$p $(DESTDIR)$(docdir)/$$f; \
+@@ -320,6 +322,7 @@
+ echo " $(docDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(docdir)/$$f'"; \
+ $(docDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(docdir)/$$f"; \
done
+endif
diff --git a/lang/ferite/files/patch-tools::doc::template::Makefile.in b/lang/ferite/files/patch-tools::doc::template::Makefile.in
index ee7405ca1cb6..ad3cf14fa4ae 100644
--- a/lang/ferite/files/patch-tools::doc::template::Makefile.in
+++ b/lang/ferite/files/patch-tools::doc::template::Makefile.in
@@ -1,25 +1,26 @@
---- tools/doc/template/Makefile.in.orig Thu Jan 9 04:49:50 2003
-+++ tools/doc/template/Makefile.in Tue Jan 14 09:39:24 2003
-@@ -124,7 +124,7 @@
+--- tools/doc/template/Makefile.in.orig Wed Oct 19 19:06:40 2005
++++ tools/doc/template/Makefile.in Wed Oct 19 19:07:52 2005
+@@ -240,7 +240,7 @@
+ xml_CFLAGS = @xml_CFLAGS@
xml_LIBS = @xml_LIBS@
template_DATA = text.fe html.fe
-
-templatedir = @prefix@/share/ferite/doc/template
+templatedir = @prefix@/share/doc/ferite/template
-
EXTRA_DIST = $(template_DATA)
-
-@@ -163,6 +163,7 @@
+ SUBDIRS = html
+ all: all-recursive
+@@ -286,6 +286,8 @@
+ -rm -f libtool
uninstall-info-am:
- templateDATA_INSTALL = $(INSTALL_DATA)
install-templateDATA: $(template_DATA)
++
+ifndef NOPORTDOCS
@$(NORMAL_INSTALL)
- $(mkinstalldirs) $(DESTDIR)$(templatedir)
+ test -z "$(templatedir)" || $(mkdir_p) "$(DESTDIR)$(templatedir)"
@list='$(template_DATA)'; for p in $$list; do \
-@@ -171,6 +172,7 @@
- echo " $(templateDATA_INSTALL) $$d$$p $(DESTDIR)$(templatedir)/$$f"; \
- $(templateDATA_INSTALL) $$d$$p $(DESTDIR)$(templatedir)/$$f; \
+@@ -294,6 +296,7 @@
+ echo " $(templateDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(templatedir)/$$f'"; \
+ $(templateDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(templatedir)/$$f"; \
done
+endif
diff --git a/lang/ferite/files/patch-tools::doc::template::html::Makefile.in b/lang/ferite/files/patch-tools::doc::template::html::Makefile.in
index 933cc8381eff..9512cdee5a40 100644
--- a/lang/ferite/files/patch-tools::doc::template::html::Makefile.in
+++ b/lang/ferite/files/patch-tools::doc::template::html::Makefile.in
@@ -1,25 +1,26 @@
---- tools/doc/template/html/Makefile.in.orig Thu Jan 9 04:49:51 2003
-+++ tools/doc/template/html/Makefile.in Tue Jan 14 09:40:05 2003
-@@ -124,7 +124,7 @@
- xml_LIBS = @xml_LIBS@
- template_DATA = namespace.png class.png empty.png back.png var.png function.png style.css
+--- tools/doc/template/html/Makefile.in.orig Wed Oct 19 19:08:04 2005
++++ tools/doc/template/html/Makefile.in Wed Oct 19 19:08:52 2005
+@@ -245,7 +245,7 @@
+ warning.png \
+ style.css
-templatedir = @prefix@/share/ferite/doc/template/html
+templatedir = @prefix@/share/doc/ferite/template/html
-
EXTRA_DIST = $(template_DATA)
- subdir = tools/doc/template/html
-@@ -155,6 +155,7 @@
+ all: all-am
+
+@@ -290,6 +290,8 @@
+ -rm -f libtool
uninstall-info-am:
- templateDATA_INSTALL = $(INSTALL_DATA)
install-templateDATA: $(template_DATA)
++
+ifndef NOPORTDOCS
@$(NORMAL_INSTALL)
- $(mkinstalldirs) $(DESTDIR)$(templatedir)
+ test -z "$(templatedir)" || $(mkdir_p) "$(DESTDIR)$(templatedir)"
@list='$(template_DATA)'; for p in $$list; do \
-@@ -163,6 +164,7 @@
- echo " $(templateDATA_INSTALL) $$d$$p $(DESTDIR)$(templatedir)/$$f"; \
- $(templateDATA_INSTALL) $$d$$p $(DESTDIR)$(templatedir)/$$f; \
+@@ -298,6 +300,7 @@
+ echo " $(templateDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(templatedir)/$$f'"; \
+ $(templateDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(templatedir)/$$f"; \
done
+endif