aboutsummaryrefslogtreecommitdiff
path: root/lang/fpl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/fpl/Makefile')
-rw-r--r--lang/fpl/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/lang/fpl/Makefile b/lang/fpl/Makefile
new file mode 100644
index 000000000000..b97d3b69b23a
--- /dev/null
+++ b/lang/fpl/Makefile
@@ -0,0 +1,34 @@
+#
+# New ports collection makefile for: fpl
+# Date created: 02/01/2003
+# Whom: Dominic Marks <dom@cus.org.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fpl
+PORTVERSION= 14.12
+CATEGORIES= lang
+MASTER_SITES= ftp://ich.bin.kein.hoschi.de/fpl/ \
+ http://www.cus.org.uk/~dom/distfiles/fpl/
+
+MAINTAINER= d.marks@student.umist.ac.uk
+COMMENT= An interpreted script/macro language
+
+ALL_TARGET=
+
+.include <bsd.port.pre.mk>
+
+pre-build:
+ @${MV} ${WRKSRC}/src/Makefile ${WRKSRC}/src/Makefile.old
+ @${MV} ${WRKSRC}/src/Makefile.FreeBSD ${WRKSRC}/src/Makefile
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/${PORTNAME}/
+ ${INSTALL_DATA} -m 0644 \
+ ${WRKSRC}/src/libfpl.a \
+ ${WRKSRC}/src/libent.a \
+ ${WRKSRC}/src/liballoc.a \
+ ${PREFIX}/lib/${PORTNAME}/
+
+.include <bsd.port.post.mk>