aboutsummaryrefslogtreecommitdiff
path: root/lang/fsharp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/fsharp/Makefile')
-rw-r--r--lang/fsharp/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/lang/fsharp/Makefile b/lang/fsharp/Makefile
index fac851321dae..e7e11b6e5f1e 100644
--- a/lang/fsharp/Makefile
+++ b/lang/fsharp/Makefile
@@ -32,4 +32,14 @@ do-test:
MONO_PATH=${WRKSRC}/Release/net40/bin \
./run-all.sh)
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(MONO_DEFAULT)
+.if ${MONO_DEFAULT} > 6
+BROKEN= fails to build with Mono version ${MONO_DEFAULT}: A unique overload for method 'GetFileNameWithoutExtension' could not be determined based on type information prior to this program point
+.elif ${MONO_DEFAULT} > 5.10
+BROKEN= fails to build with Mono version ${MONO_DEFAULT}: The type 'HashSet' is not defined
+.endif
+.endif
+
+.include <bsd.port.post.mk>