aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc40
diff options
context:
space:
mode:
Diffstat (limited to 'lang/gcc40')
-rw-r--r--lang/gcc40/Makefile245
-rw-r--r--lang/gcc40/distinfo7
-rw-r--r--lang/gcc40/files/opt.patch-bc11
-rw-r--r--lang/gcc40/files/patch-fa179
-rw-r--r--lang/gcc40/files/patch-fb13
-rw-r--r--lang/gcc40/files/patch-fc21
-rw-r--r--lang/gcc40/files/patch-gengtype-yacc.y12
-rw-r--r--lang/gcc40/pkg-descr7
-rw-r--r--lang/gcc40/pkg-plist64
9 files changed, 0 insertions, 559 deletions
diff --git a/lang/gcc40/Makefile b/lang/gcc40/Makefile
deleted file mode 100644
index 2d7e2d1953f9..000000000000
--- a/lang/gcc40/Makefile
+++ /dev/null
@@ -1,245 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: egcs
-# Date created: 9 Jan 1998
-# Whom: John Polstra <jdp@polstra.com>
-#
-# $FreeBSD$
-#
-
-SNAPDATE= 2003-07-07
-#CVS_DATE= ${SNAPDATE} 18:53:04 EDT
-
-PORTNAME= gcc
-PORTVERSION= 3.3.1
-PORTREVISION= ${SNAPDATE:S/-//g}
-CATEGORIES= lang java
-VERSIONSTRING= ${PORTREVISION}
-MASTER_SITES= ${MASTER_SITE_GCC} \
- http://web.inter.NL.net/hcc/Haj.Ten.Brugge/:bc
-MASTER_SITE_SUBDIR= snapshots/3.3-${PORTREVISION}
-.if !defined(CVS_DATE)
-DISTFILES= \
- gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-g77-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-java-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-objc-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
-.endif
-
-MAINTAINER?= ports@FreeBSD.org
-COMMENT?= GNU Compiler Collection 3.3
-
-.if defined (WITH_BOUNDSCHECKING)
-# Fetch another file, but don't extract it. Also add another patchfile.
-BCPATCH= bounds-checking-gcc-3.3-1.00.patch.bz2
-DISTFILES+= ${BCPATCH}:bc
-EXTRACT_ONLY= ${DISTFILES:S/${BCPATCH}:bc//}
-EXTRA_PATCHES= ${FILESDIR}/opt.patch-bc
-.endif
-
-LATEST_LINK?= gcc33${PKGNAMESUFFIX}
-
-USE_BZIP2= yes
-USE_REINPLACE= yes
-USE_PERL5_BUILD=yes
-
-PATCH_WRKSRC= ${SRCDIR}
-CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
-NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
-
-.include <bsd.port.pre.mk>
-
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-
-GCC_VER= ${PORTVERSION:C/\.0$//}
-SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
-WRKSRC= ${WRKDIR}/build
-TARGLIB= ${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${GCC_VER}
-GCJINC= ${PREFIX}/include/gcj
-GNUINC= ${PREFIX}/include/gnu
-JAVAINC= ${PREFIX}/include/java
-JAVAINC2= ${PREFIX}/include/javax
-PLIST_SUB= GCC_VER=${GCC_VER} GNU_HOST=${CONFIGURE_TARGET}
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_BISON= yes
-CONFIGURE_ARGS= --disable-nls \
- --with-gxx-include-dir=${TARGLIB}/include/c++/${GCC_REV}
-#CONFIGURE_ARGS+= --program-suffix=33
-# Java
-CONFIGURE_ARGS+= --with-system-zlib #--includedir=${TARGLIB}/include/Java -libdir=${TARGLIB}
-MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
-.if defined(WANT_SHAREDLIBS)
-CONFIGURE_ARGS+= --enable-shared
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= %%PREFIX%%/lib ${TARGLIB}
-EXTRA_SHLIB= libgcc_s
-.else
-CONFIGURE_ARGS+= --disable-shared
-.endif
-.if defined(WANT_THREADS_SUPPORT)
-CONFIGURE_ARGS+= --enable-threads
-# ?is this an ObjC only thing?
-CONFIGURE_ARGS+= --enable-threads=posix
-.endif
-ALL_TARGET= bootstrap
-MAN1= cpp33.1 g++33.1 g77-33.1 gcc33.1 gcov33.1 \
- gcj33.1 gcjh33.1 gij33.1 grepjar33.1 jar33.1 \
- jcf-dump33.1 jv-scan33.1 jv-convert33.1 \
- rmic33.1 rmiregistry33.1
-MAN7= fsf-funding.7 gfdl.7 gpl.7
-
-pre-fetch:
- @${ECHO} "Making GCC ${DISTNAME:S/^gcc-//} for ${OPSYS} ${OSREL} ${PORTOBJFORMAT} target ${CONFIGURE_TARGET}"
-.if !defined(WITH_BOUNDSCHECKING)
- @${ECHO_MSG} "You can enable fine-grained bounds-checking support for compiled C programs"
- @${ECHO_MSG} "by defining WITH_BOUNDSCHECKING. Compile and link with \"-fbounds-checking\""
- @${ECHO_MSG} "to use."
-.endif
-
-.if defined(CVS_DATE)
-NO_CHECKSUM= yes
-DIST_SUBDIR= ${PKGNAME}
-CVS_CMD?= cvs -z3 -qR
-CVSROOT= :pserver:anoncvs@subversions.gnu.org:/cvsroot/gcc
-STAMPFILE= ${DISTDIR}/${DIST_SUBDIR}/.timestamp
-do-fetch:
- @if [ ! -e ${STAMPFILE} ] || \
- [ "X${CVS_DATE}" != "X$$(${CAT} ${STAMPFILE})" ]; then \
- ${MKDIR} ${DISTDIR}/${DIST_SUBDIR} && \
- cd ${DISTDIR}/${DIST_SUBDIR} ; \
- unset CVS_RSH CVS_SERVER || ${TRUE} ; \
- ${ECHO_MSG} ">> Attempting to CVS checkout from ${CVSROOT}." ;\
- if ${CVS_CMD} -d ${CVSROOT} co -D "${CVS_DATE}" gcc ; \
- then \
- ( ${ECHO} -n "${CVS_DATE}" > ${STAMPFILE} ) ; \
- exit ; \
- fi ; \
- ${ECHO_MSG} ">> Couldn't CVS checkout ${PKGNAME}." ; \
- ${ECHO_MSG} ">> Please try again later."; \
- exit 1; \
- fi
-
-do-extract:
- ${MKDIR} ${SRCDIR}
- cd ${DISTDIR}/${DIST_SUBDIR}/${DIST_SUBDIR ; pax -pe -rwt . ${SRCDIR}
-.endif # CVS_DATE
-
-.if defined(WITH_BOUNDSCHECKING)
-# Extract bounds-checking patch, removing the ada parts of the patch with sed.
-pre-patch:
- cd ${_DISTDIR} ; \
- ${BZCAT} ${BCPATCH} | \
- ${SED} -e '/^--- .*ada/,/^diff/d' | \
- ${PATCH} -d ${PATCH_WRKSRC} -E -p1 --quiet
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|\(const char version_string.*\)";|\1 [FreeBSD]";|' \
- ${SRCDIR}/gcc/version.c
-
-pre-configure:
- cd ${SRCDIR} ; contrib/gcc_update --touch
- @${RM} -f ${SRCDIR}/gcc/*/*.info*
- @${MKDIR} ${CONFIGURE_WRKSRC}
-
-post-build:
- @echo "Consider running 'make check' before 'make install',"
- @echo "especially if you have not built port on -STABLE or -CURRENT."
- @echo "This assumes that you have the dejagnu port installed."
-
-check: build
- cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
-
-pre-install:
- ${MKDIR} ${PREFIX}/info
-
-post-install:
- @${RM} -f ${PREFIX}/bin/c++ ${PREFIX}/bin/${CONFIGURE_TARGET}-c++
- @(for prog in \
- ${TARGLIB}/cc1 ${TARGLIB}/cc1obj ${TARGLIB}/cc1plus \
- ${TARGLIB}/collect2 ${TARGLIB}/f771 ; \
- do \
- ${STRIP_CMD} $$prog ; \
- done )
-.for f in gcc g++ cpp gcov ${CONFIGURE_TARGET}-gcc ${CONFIGURE_TARGET}-g++ gcj gcjh gij jv-scan jcf-dump jv-convert jar grepjar rmic rmiregistry
- ${STRIP_CMD} ${PREFIX}/bin/${f}
- ${MV} -f ${PREFIX}/bin/${f} ${PREFIX}/bin/${f}33
- ( ${TEST} ! -e ${PREFIX}/man/man1/${f}.1 \
- || ${MV} -f ${PREFIX}/man/man1/${f}.1 \
- ${PREFIX}/man/man1/${f}33.1 )
-.endfor
-.for f in g77
- ${MV} -f ${PREFIX}/bin/${f} ${PREFIX}/bin/${f}-33
- ( ${TEST} ! -e ${PREFIX}/man/man1/${f}.1 \
- || ${MV} -f ${PREFIX}/man/man1/${f}.1 \
- ${PREFIX}/man/man1/${f}-33.1 )
-.endfor
- ${MV} -f ${PREFIX}/bin/gccbug ${PREFIX}/bin/gccbug-${PORTVERSION}
- # These 3 libraries are moved from PREFIX/lib to avoid conflicts
- # with the stock compiler.
-.for f in libstdc++ libsupc++ libg2c libfrtbegin libobjc ${EXTRA_SHLIB}
- ${MV} -f ${PREFIX}/lib/${f}.* ${TARGLIB}
-.endfor
- -${MV} -f ${PREFIX}/lib/ieee ${TARGLIB}
- # Java
- -${MV} -f ${PREFIX}/lib/libgcj.* ${TARGLIB}
- ${RM} -f ${PREFIX}/lib/libiberty.a
- ${RM} -f ${TARGLIB}/*.la
-.for info in cpp cppinternals g77 gcc gccint gcj fastjar
- install-info ${PREFIX}/info/${info}.info ${PREFIX}/info/dir
-.endfor
-# I am sick and tired of the anonyance that man pages can only be generated if
-# perl 5.6 is installed. This is becoming a royal PITA on non-5-CURRENT systems
-.for mp in ${_MANPAGES}
- ( ${TEST} -e ${mp} && ${TOUCH} ${TOUCH_FLAGS} ${mp} )
-.endfor
- cd ${PREFIX} ;\
- ${FIND} ${TARGLIB:S/^${PREFIX}\///} -type f -o -type l \
- >${WRKDIR}/PLIST.gcc-lib
- cd ${PREFIX} ;\
- ${FIND} ${TARGLIB:S/^${PREFIX}\///} -type d \
- | sort -r | ${SED} -e 's/^/@dirrm /g' >>${WRKDIR}/PLIST.gcc-lib
- (${ECHO_CMD} "@unexec rmdir %D/lib/gcc-lib/${CONFIGURE_TARGET} 2>&1 || true" ; ${ECHO_CMD} "@unexec rmdir %D/lib/gcc-lib 2>&1 || true") >> ${WRKDIR}/PLIST.gcc-lib
- cd ${PREFIX} ;\
- ${FIND} ${GCJINC:S/^${PREFIX}\///} -type f -o -type l \
- >${WRKDIR}/PLIST.gcj-inc
- cd ${PREFIX} ;\
- ${FIND} ${GNUINC:S/^${PREFIX}\///} -type f -o -type l \
- >>${WRKDIR}/PLIST.gcj-inc
- cd ${PREFIX} ;\
- ${FIND} ${JAVAINC:S/^${PREFIX}\///} -type f -o -type l \
- >>${WRKDIR}/PLIST.gcj-inc
- cd ${PREFIX} ;\
- ${FIND} ${JAVAINC2:S/^${PREFIX}\///} -type f -o -type l \
- >>${WRKDIR}/PLIST.gcj-inc
- cd ${PREFIX} ;\
- ${FIND} ${GCJINC:S/^${PREFIX}\///} -type d \
- | sort -r | ${SED} -e 's/^/@dirrm /g' >>${WRKDIR}/PLIST.gcj-inc
- cd ${PREFIX} ;\
- ${FIND} ${GNUINC:S/^${PREFIX}\///} -type d \
- | sort -r | ${SED} -e 's/^/@dirrm /g' >>${WRKDIR}/PLIST.gcj-inc
- cd ${PREFIX} ;\
- ${FIND} ${JAVAINC:S/^${PREFIX}\///} -type d \
- | sort -r | ${SED} -e 's/^/@dirrm /g' >>${WRKDIR}/PLIST.gcj-inc
- cd ${PREFIX} ;\
- ${FIND} ${JAVAINC2:S/^${PREFIX}\///} -type d \
- | sort -r | ${SED} -e 's/^/@dirrm /g' >>${WRKDIR}/PLIST.gcj-inc
- ${ECHO_CMD} "r ${TMPPLIST}" > ${WRKDIR}/ex.script
- ${ECHO_CMD} "/Insert PLIST.gcc-lib" >> ${WRKDIR}/ex.script
- ${ECHO_CMD} "d" >> ${WRKDIR}/ex.script
- ${ECHO_CMD} "r ${WRKDIR}/PLIST.gcc-lib" >> ${WRKDIR}/ex.script
- ${ECHO_CMD} "/Insert PLIST.gcj-inc" >> ${WRKDIR}/ex.script
- ${ECHO_CMD} "d" >> ${WRKDIR}/ex.script
- ${ECHO_CMD} "r ${WRKDIR}/PLIST.gcj-inc" >> ${WRKDIR}/ex.script
- ${ECHO_CMD} "x!" >> ${WRKDIR}/ex.script
- ${CP} -p ${TMPPLIST} ${TMPPLIST}.pre-gcc-lib
- cd ${WRKDIR} ; ex < ex.script
-
-cklatest:
-.for SITE in ftp://gcc.gnu.org/pub/gcc/snapshots/ ftp://mirrors.rcn.net/mirrors/sources.redhat.com/gcc/snapshots/
- @-ncftpls ${SITE} | ${GREP} LATEST
-.endfor
-
-.include <bsd.port.post.mk>
diff --git a/lang/gcc40/distinfo b/lang/gcc40/distinfo
deleted file mode 100644
index bf88314c11db..000000000000
--- a/lang/gcc40/distinfo
+++ /dev/null
@@ -1,7 +0,0 @@
-MD5 (gcc-core-20030707.tar.bz2) = 3df86998f88c234a3896abd4ba8ffd75
-MD5 (gcc-g++-20030707.tar.bz2) = 64f8b0be34d67daf7e5b078b1b1aa015
-MD5 (gcc-g77-20030707.tar.bz2) = 5fe94c84234c624267acdc4bfdc2f407
-MD5 (gcc-java-20030707.tar.bz2) = 6aa26adb77f607e8d7daeba19b0cd96e
-MD5 (gcc-objc-20030707.tar.bz2) = 0dfe91ca18dc14c28be450965c9c9201
-MD5 (gcc-testsuite-20030707.tar.bz2) = 3f3e2c3ba9b252b95c60342f7ac49f86
-MD5 (bounds-checking-gcc-3.3-1.00.patch.bz2) = b3ac2dbb902f78ffd3db3e38cab9762b
diff --git a/lang/gcc40/files/opt.patch-bc b/lang/gcc40/files/opt.patch-bc
deleted file mode 100644
index 024997f4c17c..000000000000
--- a/lang/gcc40/files/opt.patch-bc
+++ /dev/null
@@ -1,11 +0,0 @@
---- gcc/bounds/lib/Makefile.orig Tue May 20 16:35:05 2003
-+++ gcc/bounds/lib/Makefile Tue May 20 16:35:19 2003
-@@ -14,7 +14,7 @@
- SUBDIR_INCLUDES = -I../.. -I$(srcdir)/bounds/lib -I$(srcdir) -I$(srcdir)/config -I$(srcdir)/../include
-
- # Use this on System V.
--CPPFLAGS = -DUSG
-+CPPFLAGS = -DBSD4_2
-
- .c.o:
- $(GCC_FOR_TARGET) -Wall $(OPTIMIZE) $(CPPFLAGS) \
diff --git a/lang/gcc40/files/patch-fa b/lang/gcc40/files/patch-fa
deleted file mode 100644
index 064c33a2eb88..000000000000
--- a/lang/gcc40/files/patch-fa
+++ /dev/null
@@ -1,179 +0,0 @@
---- gcc/c-format.c.orig Wed Feb 20 14:54:32 2002
-+++ gcc/c-format.c Mon May 27 20:42:37 2002
-@@ -19,6 +19,8 @@
- Software Foundation, 59 Temple Place - Suite 330, Boston, MA
- 02111-1307, USA. */
-
-+/* $FreeBSD$ */
-+
- #include "config.h"
- #include "system.h"
- #include "tree.h"
-@@ -75,6 +77,7 @@
- last. */
- enum format_type { printf_format_type, scanf_format_type,
- strftime_format_type, strfmon_format_type,
-+ printf0_format_type,
- format_type_error };
-
- typedef struct function_format_info
-@@ -82,6 +85,7 @@
- enum format_type format_type; /* type of format (printf, scanf, etc.) */
- unsigned HOST_WIDE_INT format_num; /* number of format argument */
- unsigned HOST_WIDE_INT first_arg_num; /* number of first arg (zero for varargs) */
-+ int null_format_ok; /* TRUE if the format string may be NULL */
- } function_format_info;
-
- static bool decode_format_attr PARAMS ((tree,
-@@ -249,7 +253,7 @@
- {
- if (validated_p)
- abort ();
-- error ("unrecognized format specifier");
-+ error_with_decl (getdecls (), "unrecognized format specifier");
- return false;
- }
- else
-@@ -540,6 +544,7 @@
- /* Pointer to type of argument expected if '*' is used for a precision,
- or NULL if '*' not used for precisions. */
- tree *const precision_type;
-+ const int null_format_ok;
- } format_kind_info;
-
-
-@@ -783,6 +788,18 @@
- { "S", 1, STD_EXT, { TEX_W, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN }, "-wp", "R" },
- /* GNU conversion specifiers. */
- { "m", 0, STD_EXT, { T89_V, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN }, "-wp", "" },
-+ /* BSD conversion specifiers. */
-+ /* FreeBSD kernel extensions (src/sys/kern/subr_prf.c).
-+ The format %b is supported to decode error registers.
-+ Its usage is: printf("reg=%b\n", regval, "<base><arg>*");
-+ which produces: reg=3<BITTWO,BITONE>
-+ The format %D provides a hexdump given a pointer and separator string:
-+ ("%6D", ptr, ":") -> XX:XX:XX:XX:XX:XX
-+ ("%*D", len, ptr, " ") -> XX XX XX XX ...
-+ */
-+ { "D", 1, STD_EXT, { T89_C, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN }, "-wp", "cR" },
-+ { "b", 1, STD_EXT, { T89_C, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN }, "-wp", "" },
-+ { "rz", 0, STD_EXT, { T89_I, BADLEN, BADLEN, T89_L, BADLEN, BADLEN, BADLEN, BADLEN, BADLEN }, "-wp0 +#", "i" },
- { NULL, 0, 0, NOLENGTHS, NULL, NULL }
- };
-
-@@ -847,23 +864,29 @@
- printf_flag_specs, printf_flag_pairs,
- FMT_FLAG_ARG_CONVERT|FMT_FLAG_DOLLAR_MULTIPLE|FMT_FLAG_USE_DOLLAR|FMT_FLAG_EMPTY_PREC_OK,
- 'w', 0, 'p', 0, 'L',
-- &integer_type_node, &integer_type_node
-+ &integer_type_node, &integer_type_node, 0
- },
- { "scanf", scanf_length_specs, scan_char_table, "*'I", NULL,
- scanf_flag_specs, scanf_flag_pairs,
- FMT_FLAG_ARG_CONVERT|FMT_FLAG_SCANF_A_KLUDGE|FMT_FLAG_USE_DOLLAR|FMT_FLAG_ZERO_WIDTH_BAD|FMT_FLAG_DOLLAR_GAP_POINTER_OK,
- 'w', 0, 0, '*', 'L',
-- NULL, NULL
-+ NULL, NULL, 0
- },
- { "strftime", NULL, time_char_table, "_-0^#", "EO",
- strftime_flag_specs, strftime_flag_pairs,
- FMT_FLAG_FANCY_PERCENT_OK, 'w', 0, 0, 0, 0,
-- NULL, NULL
-+ NULL, NULL, 0
- },
- { "strfmon", strfmon_length_specs, monetary_char_table, "=^+(!-", NULL,
- strfmon_flag_specs, strfmon_flag_pairs,
- FMT_FLAG_ARG_CONVERT, 'w', '#', 'p', 0, 'L',
-- NULL, NULL
-+ NULL, NULL, 0
-+ },
-+ { "printf0", printf_length_specs, print_char_table, " +#0-'I", NULL,
-+ printf_flag_specs, printf_flag_pairs,
-+ FMT_FLAG_ARG_CONVERT|FMT_FLAG_DOLLAR_MULTIPLE|FMT_FLAG_USE_DOLLAR|FMT_FLAG_EMPTY_PREC_OK,
-+ 'w', 0, 'p', 0, 'L',
-+ &integer_type_node, &integer_type_node, 1
- }
- };
-
-@@ -917,6 +940,14 @@
-
- static void check_format_types PARAMS ((int *, format_wanted_type *));
-
-+
-+inline static int get_null_fmt_ok (fmttype)
-+ enum format_type fmttype;
-+{
-+ return format_types[(int)fmttype].null_format_ok;
-+}
-+
-+
- /* Decode a format type from a string, returning the type, or
- format_type_error if not valid, in which case the caller should print an
- error message. */
-@@ -1986,6 +2017,57 @@
- }
- }
-
-+ if (*format_chars == 'b')
-+ {
-+ /* There should be an int arg to control the string arg. */
-+ if (params == 0)
-+ {
-+ status_warning (status, "too few arguments for format");
-+ return;
-+ }
-+ if (info->first_arg_num != 0)
-+ {
-+ cur_param = TREE_VALUE (params);
-+ params = TREE_CHAIN (params);
-+ ++arg_num;
-+ if ((TYPE_MAIN_VARIANT (TREE_TYPE (cur_param))
-+ != integer_type_node)
-+ &&
-+ (TYPE_MAIN_VARIANT (TREE_TYPE (cur_param))
-+ != unsigned_type_node))
-+ {
-+ status_warning (status, "bitmap is not type int (arg %d)",
-+ arg_num);
-+ }
-+ }
-+ }
-+ if (*format_chars == 'D')
-+ {
-+ /* There should be an unsigned char * arg before the string arg. */
-+ if (params == 0)
-+ {
-+ status_warning (status, "too few arguments for format");
-+ return;
-+ }
-+ if (info->first_arg_num != 0)
-+ {
-+ tree cur_type;
-+
-+ cur_param = TREE_VALUE (params);
-+ params = TREE_CHAIN (params);
-+ ++arg_num;
-+ cur_type = TREE_TYPE (cur_param);
-+ if (TREE_CODE (cur_type) != POINTER_TYPE
-+ || TYPE_MAIN_VARIANT (TREE_TYPE (cur_type))
-+ != unsigned_char_type_node)
-+ {
-+ status_warning (status,
-+ "ethernet address is not type unsigned char * (arg %d)",
-+ arg_num);
-+ }
-+ }
-+ }
-+
- format_char = *format_chars;
- if (format_char == 0
- || (!(fki->flags & (int) FMT_FLAG_FANCY_PERCENT_OK)
-@@ -2112,7 +2194,7 @@
- else if (strchr (fci->flags2, '2') != 0)
- y2k_level = 2;
- if (y2k_level == 3)
-- status_warning (status, "`%%%c' yields only last 2 digits of year in some locales",
-+ status_warning (status, "`%%%c' yields only last 2 digits of year in some locales on non-BSD systems",
- format_char);
- else if (y2k_level == 2)
- status_warning (status, "`%%%c' yields only last 2 digits of year", format_char);
diff --git a/lang/gcc40/files/patch-fb b/lang/gcc40/files/patch-fb
deleted file mode 100644
index dae6d331898c..000000000000
--- a/lang/gcc40/files/patch-fb
+++ /dev/null
@@ -1,13 +0,0 @@
---- gcc/flags.h.orig Sun Jan 31 09:46:18 1999
-+++ gcc/flags.h Tue Mar 30 13:17:11 1999
-@@ -137,6 +137,10 @@
-
- extern int warn_aggregate_return;
-
-+/* Nonzero means that -Wformat accepts certain non-ANSI formats. */
-+
-+extern int flag_format_extensions;
-+
- /* Nonzero if generating code to do profiling. */
-
- extern int profile_flag;
diff --git a/lang/gcc40/files/patch-fc b/lang/gcc40/files/patch-fc
deleted file mode 100644
index 628048a209e7..000000000000
--- a/lang/gcc40/files/patch-fc
+++ /dev/null
@@ -1,21 +0,0 @@
---- gcc/toplev.c.orig Tue Jun 6 13:11:39 2000
-+++ gcc/toplev.c Mon Jun 26 20:19:31 2000
-@@ -787,6 +787,9 @@
- /* Tag all structures with __attribute__(packed) */
- int flag_pack_struct = 0;
-
-+/* Nonzero means that -Wformat accepts certain system-dependent formats. */
-+int flag_format_extensions = 0;
-+
- /* Emit code to check for stack overflow; also may cause large objects
- to be allocated dynamically. */
- int flag_stack_check;
-@@ -1064,6 +1067,8 @@
- "Do the full regmove optimization pass"},
- {"pack-struct", &flag_pack_struct, 1,
- N_("Pack structure members together without holes") },
-+ {"format-extensions", &flag_format_extensions, 1,
-+ N_("-Wformat accepts certain FreeBSD system-dependent formats") },
- {"stack-check", &flag_stack_check, 1,
- N_("Insert stack checking code into the program") },
- {"argument-alias", &flag_argument_noalias, 0,
diff --git a/lang/gcc40/files/patch-gengtype-yacc.y b/lang/gcc40/files/patch-gengtype-yacc.y
deleted file mode 100644
index 4afaae159533..000000000000
--- a/lang/gcc40/files/patch-gengtype-yacc.y
+++ /dev/null
@@ -1,12 +0,0 @@
---- gcc/gengtype-yacc.y.orig Fri Sep 20 00:33:24 2002
-+++ gcc/gengtype-yacc.y Tue Apr 22 09:11:27 2003
-@@ -24,6 +24,9 @@
- #include "system.h"
- #include "gengtype.h"
- #define YYERROR_VERBOSE
-+
-+#define malloc xmalloc
-+#define realloc xrealloc
- %}
-
- %union {
diff --git a/lang/gcc40/pkg-descr b/lang/gcc40/pkg-descr
deleted file mode 100644
index c2c52fc7e3f0..000000000000
--- a/lang/gcc40/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-GCC, the GNU Compiler Collection includes gcc, g++, g77, and gcj.
-
-Beware: This port installs new versions of "gcc", "g++", "c++" and
-so forth into the "${PREFIX}/bin" directory. Mind your PATHs if you
-don't want to use this compiler by default.
-
-WWW: http://gcc.gnu.org/
diff --git a/lang/gcc40/pkg-plist b/lang/gcc40/pkg-plist
deleted file mode 100644
index 98c6cf89c8e6..000000000000
--- a/lang/gcc40/pkg-plist
+++ /dev/null
@@ -1,64 +0,0 @@
-@comment $FreeBSD$
-bin/cpp33
-bin/g++33
-bin/g77-33
-bin/gcc33
-bin/gcov33
-bin/%%GNU_HOST%%-gcc-%%GCC_VER%%
-bin/%%GNU_HOST%%-gcc33
-bin/%%GNU_HOST%%-g++33
-bin/%%GNU_HOST%%-gcj
-bin/gccbug-%%GCC_VER%%
-bin/gcj33
-bin/gcjh33
-bin/gij33
-bin/jv-scan33
-bin/jcf-dump33
-bin/jv-convert33
-bin/jar33
-bin/grepjar33
-bin/rmic33
-bin/rmiregistry33
-bin/addr2name.awk
-include/fficonfig.h
-include/ffi.h
-include/ffi_mips.h
-include/jni.h
-include/jvmpi.h
-lib/libffi.la
-lib/libffi.a
-lib/security/classpath.security
-lib/security/libgcj.security
-@dirrm lib/security
-lib/lib-org-xml-sax.la
-lib/lib-org-xml-sax.a
-lib/lib-org-w3c-dom.la
-lib/lib-org-w3c-dom.a
-share/java/libgcj-%%GCC_VER%%.jar
-@comment Insert PLIST.gcc-lib here
-@comment -=[ begin PLIST.gcc-lib ]=-
-@comment -=[ end PLIST.gcc-lib ]=-
-@comment Insert PLIST.gcj-inc here
-@comment -=[ begin PLIST.gcj-inc ]=-
-@comment -=[ end PLIST.gcj-inc ]=-
-@unexec install-info --delete %D/info/cpp.info %D/info/dir
-@unexec install-info --delete %D/info/cppinternals.info %D/info/dir
-@unexec install-info --delete %D/info/g77.info %D/info/dir
-@unexec install-info --delete %D/info/gcc.info %D/info/dir
-@unexec install-info --delete %D/info/gccint.info %D/info/dir
-@unexec install-info --delete %D/info/gcj.info %D/info/dir
-@unexec install-info --delete %D/info/fastjar.info %D/info/dir
-info/cpp.info
-info/cppinternals.info
-info/g77.info
-info/gcc.info
-info/gccint.info
-info/gcj.info
-info/fastjar.info
-@exec install-info %D/info/cpp.info %D/info/dir
-@exec install-info %D/info/cppinternals.info %D/info/dir
-@exec install-info %D/info/g77.info %D/info/dir
-@exec install-info %D/info/gcc.info %D/info/dir
-@exec install-info %D/info/gccint.info %D/info/dir
-@exec install-info %D/info/gcj.info %D/info/dir
-@exec install-info %D/info/fastjar.info %D/info/dir