aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc42
diff options
context:
space:
mode:
Diffstat (limited to 'lang/gcc42')
-rw-r--r--lang/gcc42/Makefile95
-rw-r--r--lang/gcc42/distinfo1
-rw-r--r--lang/gcc42/files/patch-aa12
-rw-r--r--lang/gcc42/files/patch-ab11
-rw-r--r--lang/gcc42/files/patch-ac13
-rw-r--r--lang/gcc42/files/patch-ad66
-rw-r--r--lang/gcc42/files/patch-af66
-rw-r--r--lang/gcc42/files/patch-ai54
-rw-r--r--lang/gcc42/files/patch-ak30
-rw-r--r--lang/gcc42/files/patch-al29
-rw-r--r--lang/gcc42/pkg-comment1
-rw-r--r--lang/gcc42/pkg-descr15
-rw-r--r--lang/gcc42/pkg-plist264
13 files changed, 0 insertions, 657 deletions
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
deleted file mode 100644
index fd16aa58c606..000000000000
--- a/lang/gcc42/Makefile
+++ /dev/null
@@ -1,95 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: egcs
-# Version required: 1998-09-14
-# Date created: 9 Jan 1998
-# Whom: John Polstra <jdp@polstra.com>
-#
-# $Id: Makefile,v 1.44 1999/02/09 18:24:50 obrien Exp $
-#
-
-DISTNAME= egcs-1.1.1
-CATEGORIES= lang
-MASTER_SITES= ftp://go.cygnus.com/pub/ftp.cygnus.com/egcs/releases/egcs-1.1.1/ \
- ftp://ftp.funet.fi/mirrors/ftp.cygnus.com/pub/egcs/releases/egcs-1.1.1/ \
- ftp://egcs.cygnus.com/pub/egcs/releases/egcs-1.1.1/ \
- ftp://ftp.fu-berlin.de/unix/languages/egcs/releases/egcs-1.1.1/ \
- ftp://cambridge.cygnus.com/pub/egcs/releases/egcs-1.1.1/
-
-MAINTAINER= obrien@FreeBSD.org
-
-USE_BZIP2= yes
-
-.include <bsd.port.pre.mk>
-
-EGCS_REV= egcs-2.91.60
-LIBSTDCPP_REV= 2.9.0
-
-.if ${PORTOBJFORMAT} == "elf"
-PLIST= ${WRKDIR}/PLIST
-GNUHOST= ${ARCH}-unknown-freebsd${OSREL}
-.else
-#GNUHOST= ${ARCH}-unknown-freebsdaout${OSREL}
-GNUHOST= ${ARCH}-unknown-freebsdaout
-.endif
-
-PLIST_SUB= EGCS_REV=${EGCS_REV} GNU_HOST=${GNUHOST}
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-CONFIGURE_ARGS= --with-gnu-as --with-gnu-ld ${GNUHOST} \
- --with-gxx-include-dir=${PREFIX}/lib/gcc-lib/${GNUHOST}/${EGCS_REV}/include/g++
-ALL_TARGET= bootstrap
-MAN1= cccp.1 g++.1 g77.1 gcc.1
-
-pre-patch:
- @${MV} ${WRKSRC}/gcc/config/i386/freebsd.h ${WRKSRC}/gcc/config/i386/freebsd-aout.h
- @${MV} ${WRKSRC}/gcc/config/i386/freebsd-elf.h ${WRKSRC}/gcc/config/i386/freebsd.h
-
-pre-configure:
- @# Keep from running `autoconf' and `autoheader' since we modified
- @# configure.in by patching it.
- @touch ${WRKSRC}/gcc/configure
- @touch ${WRKSRC}/gcc/cstamp-h.in
- @(cd ${WRKSRC}/gcc/config/${ARCH}/ ; \
- MAJ=`sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \
- ${MV} freebsd-aout.h freebsd-aout.h.in ; \
- ${SED} -e "s:__FreeBSD__:__FreeBSD__=$${MAJ}:" freebsd-aout.h.in \
- >freebsd-aout.h ; \
- ${MV} freebsd.h freebsd.h.in ; \
- ${SED} -e "s:__FreeBSD__:__FreeBSD__=$${MAJ}:" freebsd.h.in >freebsd.h )
-.if ${PORTOBJFORMAT} == "elf"
- @${SED} -e 's/^@comment ELF-only://' ${PKGDIR}/PLIST >${PLIST}
-.endif
-
-pre-install:
- ${MKDIR} ${PREFIX}/info
- ${TOUCH} ${PREFIX}/info/dir
-
-post-install:
- @${RM} -f ${PREFIX}/bin/c++
- @${MV} -f ${PREFIX}/bin/c++filt ${PREFIX}/bin/g++filt
- @(for prog in ${PREFIX}/bin/gcc ${PREFIX}/bin/g++ \
- ${PREFIX}/bin/g++filt ${PREFIX}/bin/g77 ${PREFIX}/bin/gcov \
- ${PREFIX}/bin/protoize ${PREFIX}/bin/unprotoize \
- ${PREFIX}/bin/${GNUHOST}-gcc \
- ${PREFIX}/lib/gcc-lib/${GNUHOST}/${EGCS_REV}/cc1 \
- ${PREFIX}/lib/gcc-lib/${GNUHOST}/${EGCS_REV}/cc1obj \
- ${PREFIX}/lib/gcc-lib/${GNUHOST}/${EGCS_REV}/cc1plus \
- ${PREFIX}/lib/gcc-lib/${GNUHOST}/${EGCS_REV}/cpp \
- ${PREFIX}/lib/gcc-lib/${GNUHOST}/${EGCS_REV}/collect2 \
- ${PREFIX}/lib/gcc-lib/${GNUHOST}/${EGCS_REV}/f771 ; \
- do strip $$prog ; \
- done)
- ln -f ${PREFIX}/bin/gcc ${PREFIX}/bin/egcc
- ln -f ${PREFIX}/bin/g++ ${PREFIX}/bin/eg++
- ${MV} ${PREFIX}/lib/libiberty.a \
- ${PREFIX}/lib/gcc-lib/${GNUHOST}/${EGCS_REV}
- ${MV} -f ${PREFIX}/lib/libstdc++.a \
- ${PREFIX}/lib/gcc-lib/${GNUHOST}/${EGCS_REV}/libstdc++.a
- if [ ! -f ${PREFIX}/info/dir ]; then \
- ${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
- fi
-.for info in cpp g77 gcc
- install-info ${PREFIX}/info/${info}.info ${PREFIX}/info/dir
-.endfor
-
-.include <bsd.port.post.mk>
diff --git a/lang/gcc42/distinfo b/lang/gcc42/distinfo
deleted file mode 100644
index 98386758f461..000000000000
--- a/lang/gcc42/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (egcs-1.1.1.tar.bz2) = 854ed488f030075e4a4ac1fbedcb27fb
diff --git a/lang/gcc42/files/patch-aa b/lang/gcc42/files/patch-aa
deleted file mode 100644
index 9dc2e19279bb..000000000000
--- a/lang/gcc42/files/patch-aa
+++ /dev/null
@@ -1,12 +0,0 @@
---- gcc/cpp.texi.orig Mon Aug 11 08:57:05 1997
-+++ gcc/cpp.texi Sat Jan 10 11:59:15 1998
-@@ -1,5 +1,9 @@
- \input texinfo
- @setfilename cpp.info
-+@dircategory The egcs enhanced GNU compiler suite
-+@direntry
-+* cpp: (cpp). The egcs C/C++ preprocessor.
-+@end direntry
- @settitle The C Preprocessor
-
- @ignore
diff --git a/lang/gcc42/files/patch-ab b/lang/gcc42/files/patch-ab
deleted file mode 100644
index f298fd056742..000000000000
--- a/lang/gcc42/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- gcc/f/g77.texi.orig Thu Jun 4 03:41:18 1998
-+++ gcc/f/g77.texi Tue Jun 9 17:52:16 1998
-@@ -150,7 +150,7 @@
-
- @dircategory Programming
- @direntry
--* g77: (g77). The GNU Fortran compiler.
-+* g77: (g77). The EGCS GNU Fortran compiler.
- @end direntry
- @node Top, Copying,, (DIR)
- @top Introduction
diff --git a/lang/gcc42/files/patch-ac b/lang/gcc42/files/patch-ac
deleted file mode 100644
index 961874c5c315..000000000000
--- a/lang/gcc42/files/patch-ac
+++ /dev/null
@@ -1,13 +0,0 @@
---- gcc/gcc.texi.orig Fri Jan 2 15:38:11 1998
-+++ gcc/gcc.texi Sat Jan 10 11:56:49 1998
-@@ -1,6 +1,10 @@
- >\input texinfo @c -*-texinfo-*-
- @c %**start of header
- @setfilename gcc.info
-+@dircategory The egcs enhanced GNU compiler suite
-+@direntry
-+* gcc: (gcc). The egcs C/C++ compiler.
-+@end direntry
- @c @setfilename usegcc.info
- @c @setfilename portgcc.info
- @c To produce the full manual, use the "gcc.info" setfilename, and
diff --git a/lang/gcc42/files/patch-ad b/lang/gcc42/files/patch-ad
deleted file mode 100644
index 3fa37c95418b..000000000000
--- a/lang/gcc42/files/patch-ad
+++ /dev/null
@@ -1,66 +0,0 @@
---- gcc/config/i386/freebsd-aout.h.orig Tue Jun 30 15:52:18 1998
-+++ gcc/config/i386/freebsd-aout.h Fri Jan 22 04:08:44 1999
-@@ -89,6 +89,10 @@
- /* Don't default to pcc-struct-return, because gcc is the only compiler, and
- we want to retain compatibility with older gcc versions. */
- #define DEFAULT_PCC_STRUCT_RETURN 0
-+
-+/* Ensure we the configuration knows our system correctly so we can link with
-+ libraries compiled with the native cc. */
-+#undef NO_DOLLAR_IN_LABEL
-
- /* i386 freebsd still uses old binutils that don't insert nops by default
- when the .align directive demands to insert extra space in the text
-@@ -99,19 +103,18 @@
-
- /* Profiling routines, partially copied from i386/osfrose.h. */
-
--/* Redefine this to use %eax instead of %edx. */
-+/* Tell final.c that we don't need a label passed to mcount. */
-+#define NO_PROFILE_DATA
-+
- #undef FUNCTION_PROFILER
- #define FUNCTION_PROFILER(FILE, LABELNO) \
- { \
- if (flag_pic) \
- { \
-- fprintf (FILE, "\tleal %sP%d@GOTOFF(%%ebx),%%eax\n", \
-- LPREFIX, (LABELNO)); \
- fprintf (FILE, "\tcall *mcount@GOT(%%ebx)\n"); \
- } \
- else \
- { \
-- fprintf (FILE, "\tmovl $%sP%d,%%eax\n", LPREFIX, (LABELNO)); \
- fprintf (FILE, "\tcall mcount\n"); \
- } \
- }
-@@ -129,6 +132,7 @@
-
- #define TYPE_ASM_OP ".type"
- #define SIZE_ASM_OP ".size"
-+#define SET_ASM_OP ".set"
-
- /* The following macro defines the format used to output the second
- operand of the .type assembler directive. Different svr4 assemblers
-@@ -138,6 +142,12 @@
-
- #define TYPE_OPERAND_FMT "@%s"
-
-+#define HANDLE_SYSV_PRAGMA 1
-+
-+#define ASM_WEAKEN_LABEL(FILE,NAME) \
-+ do { fputs ("\t.weak\t", FILE); assemble_name (FILE, NAME); \
-+ fputc ('\n', FILE); } while (0)
-+
- /* Write the extra assembler code needed to declare a function's result.
- Most svr4 assemblers don't require any special declaration of the
- result value, but there are exceptions. */
-@@ -239,6 +249,8 @@
- #define STARTFILE_SPEC \
- "%{shared:c++rt0.o%s} \
- %{!shared:%{pg:gcrt0.o%s}%{!pg:%{static:scrt0.o%s}%{!static:crt0.o%s}}}"
-+
-+#define MD_STARTFILE_PREFIX "/usr/lib/aout/"
-
- /* This is defined when gcc is compiled in the BSD-directory-tree, and must
- * make up for the gap to all the stuff done in the GNU-makefiles.
diff --git a/lang/gcc42/files/patch-af b/lang/gcc42/files/patch-af
deleted file mode 100644
index e9d23249070c..000000000000
--- a/lang/gcc42/files/patch-af
+++ /dev/null
@@ -1,66 +0,0 @@
---- gcc/config/i386/freebsd.h.orig Mon Jul 13 15:38:36 1998
-+++ gcc/config/i386/freebsd.h Fri Jan 22 04:11:03 1999
-@@ -26,8 +26,13 @@
-
- /* The svr4 ABI for the i386 says that records and unions are returned
- in memory. */
-+/* On FreeBSD, we do not. */
- #undef DEFAULT_PCC_STRUCT_RETURN
--#define DEFAULT_PCC_STRUCT_RETURN 1
-+#define DEFAULT_PCC_STRUCT_RETURN 0
-+
-+/* This gets defined in tm.h->linux.h->svr4.h, and keeps us from using
-+ libraries compiled with the native cc, so undef it. */
-+#undef NO_DOLLAR_IN_LABEL
-
- /* This is how to output an element of a case-vector that is relative.
- This is only used for PIC code. See comments by the `casesi' insn in
-@@ -108,22 +113,19 @@
- : ((n) >= FIRST_STACK_REG && (n) <= LAST_STACK_REG) ? (n)+3 \
- : (-1))
-
--/* Output assembler code to FILE to increment profiler label # LABELNO
-- for profiling a function entry. */
-+/* Tell final.c that we don't need a label passed to mcount. */
-+#define NO_PROFILE_DATA
-
- #undef FUNCTION_PROFILER
- #define FUNCTION_PROFILER(FILE, LABELNO) \
- { \
- if (flag_pic) \
- { \
-- fprintf (FILE, "\tleal %sP%d@GOTOFF(%%ebx),%%edx\n", \
-- LPREFIX, (LABELNO)); \
-- fprintf (FILE, "\tcall *mcount@GOT(%%ebx)\n"); \
-+ fprintf (FILE, "\tcall *.mcount@GOT(%%ebx)\n"); \
- } \
- else \
- { \
-- fprintf (FILE, "\tmovl $%sP%d,%%edx\n", LPREFIX, (LABELNO)); \
-- fprintf (FILE, "\tcall mcount\n"); \
-+ fprintf (FILE, "\tcall .mcount\n"); \
- } \
- }
-
-@@ -146,20 +148,8 @@
- #define CPP_SPEC "%(cpp_cpu) %{fPIC:-D__PIC__ -D__pic__} %{fpic:-D__PIC__ -D__pic__} %{posix:-D_POSIX_SOURCE}"
-
- #undef LIB_SPEC
--#if 1
--/* We no longer link with libc_p.a or libg.a by default. If you
-- * want to profile or debug the C library, please add
-- * -lc_p or -ggdb to LDFLAGS at the link time, respectively.
-- */
--#define LIB_SPEC \
-- "%{!shared: %{mieee-fp:-lieee} %{p:-lgmon} %{pg:-lgmon} \
-- %{!ggdb:-lc} %{ggdb:-lg}}"
--#else
- #define LIB_SPEC \
-- "%{!shared: \
-- %{mieee-fp:-lieee} %{p:-lgmon -lc_p} %{pg:-lgmon -lc_p} \
-- %{!p:%{!pg:%{!g*:-lc} %{g*:-lg}}}}"
--#endif
-+ "%{!shared: %{p:-lc_p} %{pg:-lc_p} %{!p:%{!pg:-lc}}}"
-
- /* Provide a LINK_SPEC appropriate for FreeBSD. Here we provide support
- for the special GCC options -static and -shared, which allow us to
diff --git a/lang/gcc42/files/patch-ai b/lang/gcc42/files/patch-ai
deleted file mode 100644
index 4395574d635a..000000000000
--- a/lang/gcc42/files/patch-ai
+++ /dev/null
@@ -1,54 +0,0 @@
---- gcc/final.c.orig Sat Sep 5 22:52:01 1998
-+++ gcc/final.c Wed Oct 7 17:06:58 1998
-@@ -383,6 +383,8 @@
- /* zero word */
- assemble_integer (const0_rtx, long_bytes, 1);
-
-+ fprintf(asm_out_file,".stabs \"bbset\", 25, 0, 0, LPBX0\n");
-+
- /* address of filename */
- ASM_GENERATE_INTERNAL_LABEL (name, "LPBX", 1);
- assemble_integer (gen_rtx_SYMBOL_REF (Pmode, name), pointer_bytes, 1);
-@@ -1635,6 +1637,9 @@
- leaf_renumber_regs (first);
- #endif
-
-+ if (profile_block_flag)
-+ add_bb (file);
-+
- /* The Sun386i and perhaps other machines don't work right
- if the profiling code comes after the prologue. */
- #ifdef PROFILE_BEFORE_PROLOGUE
-@@ -1696,7 +1701,9 @@
- profile_function (file)
- FILE *file;
- {
-+#ifndef NO_PROFILE_DATA
- int align = MIN (BIGGEST_ALIGNMENT, LONG_TYPE_SIZE);
-+#endif /* not NO_PROFILE_DATA */
- #if defined(ASM_OUTPUT_REG_PUSH)
- #if defined(STRUCT_VALUE_INCOMING_REGNUM) || defined(STRUCT_VALUE_REGNUM)
- int sval = current_function_returns_struct;
-@@ -1706,10 +1713,12 @@
- #endif
- #endif /* ASM_OUTPUT_REG_PUSH */
-
-+#ifndef NO_PROFILE_DATA
- data_section ();
- ASM_OUTPUT_ALIGN (file, floor_log2 (align / BITS_PER_UNIT));
- ASM_OUTPUT_INTERNAL_LABEL (file, "LP", profile_label_no);
- assemble_integer (const0_rtx, LONG_TYPE_SIZE / BITS_PER_UNIT, 1);
-+#endif /* not NO_PROFILE_DATA */
-
- function_section (current_function_decl);
-
-@@ -1800,6 +1809,9 @@
- code to restore the stack frame and return to the caller. */
- FUNCTION_EPILOGUE (file, get_frame_size ());
- #endif
-+
-+ if (profile_block_flag)
-+ add_bb (file);
-
- #ifdef SDB_DEBUGGING_INFO
- if (write_symbols == SDB_DEBUG)
diff --git a/lang/gcc42/files/patch-ak b/lang/gcc42/files/patch-ak
deleted file mode 100644
index 817e789e8f53..000000000000
--- a/lang/gcc42/files/patch-ak
+++ /dev/null
@@ -1,30 +0,0 @@
---- gcc/configure.orig Wed Dec 2 11:22:52 1998
-+++ gcc/configure Tue Feb 9 02:21:19 1999
-@@ -2748,20 +2748,21 @@
- # Next line turned off because both 386BSD and BSD/386 use GNU ld.
- # use_collect2=yes
- ;;
-- i[34567]86-*-freebsdelf*)
-- tm_file="i386/i386.h i386/att.h linux.h i386/freebsd-elf.h i386/perform.h"
-+ i[34567]86-*-freebsdaout*)
-+ tm_file=i386/freebsd.h
- # On FreeBSD, the headers are already ok, except for math.h.
- fixincludes=fixinc.wrap
- tmake_file=i386/t-freebsd
-- gas=yes
-- gnu_ld=yes
-- stabs=yes
- ;;
- i[34567]86-*-freebsd*)
-- tm_file=i386/freebsd.h
-+ tm_file="i386/i386.h i386/att.h linux.h i386/freebsd.h i386/perform.h"
- # On FreeBSD, the headers are already ok, except for math.h.
- fixincludes=fixinc.wrap
-+ extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
- tmake_file=i386/t-freebsd
-+ gas=yes
-+ gnu_ld=yes
-+ stabs=yes
- ;;
- i[34567]86-*-netbsd*)
- tm_file=i386/netbsd.h
diff --git a/lang/gcc42/files/patch-al b/lang/gcc42/files/patch-al
deleted file mode 100644
index 5630ff63f6d5..000000000000
--- a/lang/gcc42/files/patch-al
+++ /dev/null
@@ -1,29 +0,0 @@
---- gcc/configure.in.orig Thu Aug 27 17:19:04 1998
-+++ gcc/configure.in Tue Feb 9 02:22:10 1999
-@@ -846,20 +846,20 @@
- # Next line turned off because both 386BSD and BSD/386 use GNU ld.
- # use_collect2=yes
- ;;
-- i[[34567]]86-*-freebsdelf*)
-- tm_file="i386/i386.h i386/att.h linux.h i386/freebsd-elf.h i386/perform.h"
-+ i[[34567]]86-*-freebsdaout*)
-+ tm_file=i386/freebsd.h
- # On FreeBSD, the headers are already ok, except for math.h.
- fixincludes=fixinc.wrap
- tmake_file=i386/t-freebsd
-- gas=yes
-- gnu_ld=yes
-- stabs=yes
- ;;
- i[[34567]]86-*-freebsd*)
-- tm_file=i386/freebsd.h
-+ tm_file="i386/i386.h i386/att.h linux.h i386/freebsd.h i386/perform.h"
- # On FreeBSD, the headers are already ok, except for math.h.
- fixincludes=fixinc.wrap
- tmake_file=i386/t-freebsd
-+ gas=yes
-+ gnu_ld=yes
-+ stabs=yes
- ;;
- i[[34567]]86-*-netbsd*)
- tm_file=i386/netbsd.h
diff --git a/lang/gcc42/pkg-comment b/lang/gcc42/pkg-comment
deleted file mode 100644
index c23b39554386..000000000000
--- a/lang/gcc42/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-EGCS enhanced version of the GNU compiler suite
diff --git a/lang/gcc42/pkg-descr b/lang/gcc42/pkg-descr
deleted file mode 100644
index 8931be9c3979..000000000000
--- a/lang/gcc42/pkg-descr
+++ /dev/null
@@ -1,15 +0,0 @@
-Egcs (pronounced "eggs") is an enhanced version of the GNU compiler
-suite, including gcc, g++, and g77. Egcs is based on a recent
-snapshot of the gcc-2.8 development sources; it contains nearly
-all of the new features found in gcc-2.8. Egcs also contains many
-improvements and features not found in gcc-2.7 and even the soon to be
-released gcc-2.8 compilers. C++ support, and in particular template
-support, is vastly improved over gcc-2.7.
-
-For more details, see <http://www.cygnus.com/egcs/>.
-
-Beware: This port installs new versions of "gcc", "g++", "c++" and
-so forth into the "${PREFIX}/bin" directory. Mind your PATHs if you
-don't want to use this compiler by default.
-
-- John Polstra <jdp@polstra.com>
diff --git a/lang/gcc42/pkg-plist b/lang/gcc42/pkg-plist
deleted file mode 100644
index 85e5aea5a688..000000000000
--- a/lang/gcc42/pkg-plist
+++ /dev/null
@@ -1,264 +0,0 @@
-@comment $Id: PLIST,v 1.20 1998/12/02 09:41:28 obrien Exp $
-bin/g++filt
-bin/g++
-bin/eg++
-bin/g77
-bin/gcc
-bin/egcc
-bin/gcov
-bin/%%GNU_HOST%%-gcc
-bin/protoize
-bin/unprotoize
-%%GNU_HOST%%/include/_G_config.h
-%%GNU_HOST%%/include/assert.h
-%%GNU_HOST%%/lib/libiberty.a
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/PlotFile.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/SFile.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/algo.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/algobase.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/algorithm
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/alloc.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/builtinbuf.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/bvector.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/cassert
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/cctype
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/cerrno
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/cfloat
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/ciso646
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/climits
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/clocale
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/cmath
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/complex
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/complex.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/csetjmp
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/csignal
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/cstdarg
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/cstddef
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/cstdio
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/cstdlib
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/cstring
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/ctime
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/cwchar
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/cwctype
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/defalloc.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/deque
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/deque.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/dummy.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/editbuf.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/floatio.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/fstream
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/fstream.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/function.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/functional
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/hash_map
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/hash_map.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/hash_set
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/hash_set.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/hashtable.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/heap.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/indstream.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/iolibio.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/iomanip
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/iomanip.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/iosfwd
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/iostdio.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/iostream
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/iostream.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/iostreamP.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/istream.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/iterator
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/iterator.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/libio.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/libioP.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/list
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/list.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/map
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/map.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/memory
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/multimap.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/multiset.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/numeric
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/ostream.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/pair.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/parsestream.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/pfstream.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/procbuf.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/pthread_alloc
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/pthread_alloc.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/queue
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/rope
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/rope.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/ropeimpl.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/set
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/set.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/slist
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/slist.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stack
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stack.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/std/bastring.cc
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/std/bastring.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/std/complext.cc
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/std/complext.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/std/dcomplex.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/std/fcomplex.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/std/ldcomplex.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/std/straits.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stdexcept
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stdiostream.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_algo.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_algobase.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_alloc.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_bvector.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_config.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_construct.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_deque.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_function.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_hash_fun.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_hash_map.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_hash_set.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_hashtable.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_heap.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_iterator.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_list.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_map.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_multimap.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_multiset.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_numeric.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_pair.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_queue.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_raw_storage_iter.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_relops.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_rope.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_set.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_slist.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_stack.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_tempbuf.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_tree.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_uninitialized.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stl_vector.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/stream.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/streambuf.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/strfile.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/string
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/strstream
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/strstream.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/tempbuf.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/tree.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/type_traits.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/utility
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/vector
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/vector.h
-@unexec install-info --delete %D/info/gcc.info %D/info/dir
-@unexec install-info --delete %D/info/g77.info %D/info/dir
-@unexec install-info --delete %D/info/cpp.info %D/info/dir
-info/cpp.info
-info/cpp.info-1
-info/cpp.info-2
-info/cpp.info-3
-info/g77.info
-info/g77.info-1
-info/g77.info-10
-info/g77.info-11
-info/g77.info-12
-info/g77.info-13
-info/g77.info-14
-info/g77.info-15
-info/g77.info-16
-info/g77.info-17
-info/g77.info-18
-info/g77.info-19
-info/g77.info-2
-info/g77.info-20
-info/g77.info-3
-info/g77.info-4
-info/g77.info-5
-info/g77.info-6
-info/g77.info-7
-info/g77.info-8
-info/g77.info-9
-info/gcc.info
-info/gcc.info-1
-info/gcc.info-10
-info/gcc.info-11
-info/gcc.info-12
-info/gcc.info-13
-info/gcc.info-14
-info/gcc.info-15
-info/gcc.info-16
-info/gcc.info-17
-info/gcc.info-18
-info/gcc.info-19
-info/gcc.info-2
-info/gcc.info-20
-info/gcc.info-21
-info/gcc.info-22
-info/gcc.info-23
-info/gcc.info-24
-info/gcc.info-25
-info/gcc.info-26
-info/gcc.info-27
-info/gcc.info-28
-info/gcc.info-29
-info/gcc.info-3
-info/gcc.info-4
-info/gcc.info-5
-info/gcc.info-6
-info/gcc.info-7
-info/gcc.info-8
-info/gcc.info-9
-@exec [ -f %D/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/info/dir
-@exec install-info %D/info/cpp.info %D/info/dir
-@exec install-info %D/info/g77.info %D/info/dir
-@exec install-info %D/info/gcc.info %D/info/dir
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/SYSCALLS.c.X
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/cc1
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/cc1obj
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/cc1plus
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/cpp
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/collect2
-@comment ELF-only:lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/crtbegin.o
-@comment ELF-only:lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/crtbeginS.o
-@comment ELF-only:lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/crtend.o
-@comment ELF-only:lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/crtendS.o
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/f771
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/README
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/assert.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/exception
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/float.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g2c.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/limits.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/math.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/new
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/new.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/objc/NXConstStr.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/objc/Object.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/objc/Protocol.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/objc/encoding.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/objc/hash.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/objc/objc-api.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/objc/objc-list.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/objc/objc.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/objc/sarray.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/objc/thr.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/objc/typedstream.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/syslimits.h
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/typeinfo
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/libgcc.a
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/libobjc.a
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/specs
-@comment These 3 libraries are moved from PREFIX/lib to avoid conflicts
-@comment with the stock compiler.
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/libg2c.a
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/libiberty.a
-lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/libstdc++.a
-@dirrm %%GNU_HOST%%/include
-@dirrm %%GNU_HOST%%/lib
-@dirrm %%GNU_HOST%%
-@dirrm lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/objc
-@dirrm lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++/std
-@dirrm lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include/g++
-@dirrm lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%/include
-@dirrm lib/gcc-lib/%%GNU_HOST%%/%%EGCS_REV%%
-@dirrm lib/gcc-lib/%%GNU_HOST%%
-@dirrm lib/gcc-lib